none
Exchange Server 2010: Accessing shared mailbox via EWS API is failing with 401 error. RRS feed

  • Question

  • I have created a new mailbox on Exchange Server 2010 and made it a shared mail box by giving full access permissions to a group of users.

    This mailbox is accessible from OWA but not form EWS Managed API.

    Accessing this via API always fails with 401 Unauthorized access errors.

    I tried with EwsEditor 1.18 and I get the same error.

    Could you please help me in resolving this.

    Tuesday, April 11, 2017 8:44 AM

All replies

  • Hey there

    Guess you  might want to check the authentication type your using in your code eg are you trying to use basic authentication where the default in EWS would be NTLM and the basic will be disabled by default.
    If you want to enable Basic you can perform the below:
    Go to Internet Information Services Manager -> Sites -> Default Web Site -> EWS -> Authentication -> Basic Authentication: Set to enabled
    So basically the problem lies on identifying your code using which type of authentication and enabling them on the EWS will most likely solve your issue


    Remember to mark as helpful if you find my contribution useful or as an answer if it does answer your question.That will encourage me - and others - to take time out to help you Check out my latest blog posts on http://exchangequery.com Thanks Sathish (MVP)

    Saturday, April 15, 2017 7:24 AM