locked
MSDTC RRS feed

  • Question

  • We have an active-passive cluster environment with Windows Server 2003 and SQL Server 2005, where the MSDTC is working correctly, in the passive environment is installed SQL Server 2005 used for testing, but does not activate the service Distributed Transaction Coordinator (DTC), we need activate it for use with the Biztalk databases. The screen is disabled Security Configuration option, no service is started. What is the suggestion to enable the DTC on the passive node.

    Friday, February 5, 2010 10:12 PM

Answers

  • Hi Elmo,
    Sorry for the delay since I was trying to consult Windows Integration Support team on this. Now I get the update.

    Unfortunately on Windows Server 2003, you cannot configure a local MSDTC without affecting the existing clustered MS DTC resource group. Once a Windows 2003 clustered MS DTC resource group created, you should not see the Distributed Transaction Coordinator service in Services panel. You can only see that service on the active node, which is for the clustered MS DTC resource.

    The good news is that this is possible on Windows Server 2008. On Windows Server 2008, the local MS DTC service is visible to passive node which means that you can configure a local MS DTC and it will not affect the clustered MS DTC resource which is configured at the active node.

    Best regards,
    Charles Wang


    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    • Marked as answer by Elmo Chavez Thursday, February 11, 2010 6:09 AM
    Thursday, February 11, 2010 5:38 AM

All replies

  • Hi Elmo,
    You need to first create a cluster resource group for MSDTC and then bring the resource group online. This KB article contains detail information on the configuration:
    How to configure Microsoft Distributed Transaction Coordinator on a Windows Server 2003 cluster
    http://support.microsoft.com/kb/301600

    In addition, if you want to know of the configurations on MSDTC security, please refer to this article:
    How to Cluster MSDTC
    http://msdn.microsoft.com/en-us/library/dd897479(BTS.10).aspx

    Hope this helps.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Monday, February 8, 2010 5:25 AM
  • MSTDC should run with the account with AUTHORITY\NetworkService Please check then the option Security Configuration will enable

    Thanks
    Bhushan
    Monday, February 8, 2010 1:38 PM
  • Hi Charles

    In the Cluster environment is running the MSDTC, but Node 2 (Passive) we have installed another instance (SQLPRU) SQL Server 2005, used as a test environment, we need to enable MSDTC on node 2 without affecting the production environment . How can we do?


    Thanks
    Tuesday, February 9, 2010 12:24 AM
  • The DTC service is running with the user NT AUTHORITY \ NetworkService, tried installing the MSDTC on the passive node, then stopped the cluster MSDTC service, therefore there is conflict.
    How do I set the passive node that has SQL Server 2005, so you can use the MSDTC Cluster, without affecting performance largely Production Service?
    Tuesday, February 9, 2010 6:25 PM
  • Hi Elmo,
    Sorry for the delay since I was trying to consult Windows Integration Support team on this. Now I get the update.

    Unfortunately on Windows Server 2003, you cannot configure a local MSDTC without affecting the existing clustered MS DTC resource group. Once a Windows 2003 clustered MS DTC resource group created, you should not see the Distributed Transaction Coordinator service in Services panel. You can only see that service on the active node, which is for the clustered MS DTC resource.

    The good news is that this is possible on Windows Server 2008. On Windows Server 2008, the local MS DTC service is visible to passive node which means that you can configure a local MS DTC and it will not affect the clustered MS DTC resource which is configured at the active node.

    Best regards,
    Charles Wang


    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    • Marked as answer by Elmo Chavez Thursday, February 11, 2010 6:09 AM
    Thursday, February 11, 2010 5:38 AM