none
word 2007 issue RRS feed

  • Question

  • We have found an issue with Word 2007

     

     

     

    Steps:

    1. Create New Word Document

    2. Insert any picture and choose Insert and Link 3. Go to VB immediate window and type:

    thisdocument.InlineShapes(1).LinkFormat.update

    4. Type it again:

    thisdocument.InlineShapes(1).LinkFormat.update

    The error occurs Run-Time error 91. This is because the first command is removing the link. This does not occur with Word 2003 and Word 2010.

     

     

    We have tried on a virtual machine with a clean win 7 and office 2007 and the issue persists

     

     

    If you could advise of any workrounds or fixes

    Tuesday, October 8, 2013 9:28 AM

All replies

  • Hello,

    In my experience, if the Error 91 occured, maybe update command can't find some object, as you said:

    This is because the first command is removing the link.

    Because I'm using Word 2013, this issue can't be reproduced lol

    However, I think we can insert an "if" check to see if linkFormat = nothing

    Thursday, October 10, 2013 1:45 PM
  • Hi,

    Thank you for posting in the MSDN Forum.
    I'm trying to involve some senior engineers into this issue and it will take some time. Your patience will be greatly appreciated.

    Sorry for any inconvenience and have a nice day!
    Best regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, October 11, 2013 6:02 AM
    Moderator