locked
Windows app certification kit 2.2 fails to find any apps to validate

    Question

  • I'm running windows 8 and visual studio express for windows 8.

    I have created an app and had it successfully submitted to the app store.

    I am now working on a second app and getting ready to submit it.  However, I just updated to the latest win8 SDK and to Windows app certification kit 2.2.  Ever since I updated, I have been unable to run the cert kit.

    Whenever I run the cert kit as part of the 'create app packages' I get the following error.  I find it interesting that my first app gets the same behavior.

    The {0} cannot continue testing since the specified Windows Store App was not found.  Please verify the packagefullname is correct.

    So, I try running the Windows App Certification kit 2.2 in stand-alone mode.  When I select to certify windows store app, it thinks for a bit and then returns with an empty list of applications.

    I found the following link wack doesn't see my app and followed the steps but still no joy.

    Thursday, January 17, 2013 7:48 PM

All replies

  • Hi mheyd,

    I have seen another report of this issue where the OP end up with re-installing the Windows which resolves the problem.

    I will try to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.
     
    Thank you for your understanding and support.


    Min Zhu
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, January 18, 2013 3:01 AM
    Moderator
  • Hi mheyd,

    I was told that it is suggested re-install the Windows to resolve this issue.This is probably caused by some internal module conflicts.

    Best regards,


    Min Zhu
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, January 18, 2013 7:44 AM
    Moderator
  • is this a full install from a formatted drive, or is there a repair option that would serve a similar purpose?

    do you have any additional insight into what causes the problem?  I'd hate to go through the long journey of installing windows, installing visual studio, installing other necessary software and have the problem happen again.

    Friday, January 18, 2013 4:30 PM
  • Hi,

    I am now having the same problem. I had this problem once before, but somehow I was able to get it working. Its something to do with windows indexing. I was playing around with it back in November when I first got the problem. Today, I even ran a backup version of my app and WACK was still unable to find it. I feel the tool is JUNK and they need to rework it somehow so that we can manually add our app packages instead of letting Windows 8 search for it and Install it.

    Here is a link from my old post.

    http://social.msdn.microsoft.com/Forums/en-US/toolsforwinapps/thread/f87c1fd7-991b-4617-9923-02fc06716abf

    Also, I am not sure if rebooting the computer or the stars and the moons have to be aliened for the WACK to see the apps.

    I hope someone can give some insight on why this happens.

    Update: It is something to do within Windows, both PCs are having the same problem. Someone needs to be looking into the cause of this problem before all developers are unable to update their apps. I created a blank app associated with the store and ran WACK and getting the same message.

    John


    John Lisenby developer of My PC Playbook


    Saturday, January 19, 2013 3:06 PM
  • This is a very frustrating problem.  For me, I was able to log in to the same PC with a different user account and run the WACK from there.  There is something in my user account that is causing the WACK to fail.  I sure how they fix this soon.

    Dave Paquette @Dave_Paquette www.davepaquette.com

    Thursday, June 13, 2013 7:00 PM
  • I'm getting the same response from WACK on release 6 of my app; the previous 5 releases were fine with WACK. The material difference in this release is that I've added an in-app purchase.

    This is the first time I've run WACK since installing 8.1 -- maybe that is an issue.

    I see a number of posts related to this issue over the past year, with no definitive answer ("reinstall Windows" is certainly an unacceptable answer).

    In case this is related, I'm also getting an error message from Simulator for the first time, saying it needs my "current credentials."

    I'm going to submit and see what happens.

    Bill


    Bill

    Monday, October 14, 2013 5:45 PM
  • You need to upgrade to WACK3.1, it is in the latest Windows sdk.


    n.Wright

    Monday, October 14, 2013 8:15 PM