none
Visual Studio - Publish requires TLS1.0?

    Question

  • We've developed our site using Visual Studio 2012.  We've been publishing it fine until recently using VS's "Publish Web" feature.  I recently had to disable incoming TLS1.0 traffic on our IIS server so we could get PCI-DSS accreditation.  Now I can no longer publish.  Is there a solution to this?
    • Edited by OutstandingBill Tuesday, February 09, 2016 3:10 AM clarification
    Tuesday, February 09, 2016 2:56 AM

Answers

All replies

  • Hi OutstandingBill,

    Please create a new website and try to publish it using Publish Web feature with enable TLS1.0 in IIS. If it can be published successful, then please disable the TLS1.0 to check whether it still can be publish.

    If still publish successful, the problem is related to your site project. Please debug your project to check what causes this problem.

    If can't publish, please try publish the website with previous way with disable TLS1.0. If successful with previous way, it means the TLS1.0 can't be disabled when publishing with Publish Web feature.

    If the website can't be published when disable/enable TLS1.0 with Publish Web feature, there may be something wrong with your Visual Studio.

    Please install Visual Studio 2012 Update 5 first and then reset/repair your Visual Studio to check whether it can be fixed.

    Best Regards,
    Weiwei

    Thursday, February 11, 2016 9:02 AM
    Moderator
  • Hi Weiwei,

    Thank you for your reply.  Unfortunately it has not helped solve the problem.  If anyone else can help resolve this I'd be grateful.

    I installed the Visual Studio update you mentioned (I had previously been on update 4, so for me update 5 only fixed a potential TFS branching issue) and retested as follows:

    1. Starting point: publish with TLS1.0 enabled works fine.
    2. Disable TLS1.0.  No other changes.  Publish no longer working (see error message below).
    3. Enable TLS1.0.  No other changes.  Publish working again.

    Other users have reported the same problem.  http://stackoverflow.com/questions/33122221/how-to-publish-asp-net-website-when-tls1-0-has-been-disabled

    Here's the error:

    Error 104 Web deployment task failed. (Could not complete the request to remote agent URL 'https://my-test-site.com:8172/msdeploy.axd?site=Default Web Site'.)
    This error indicates that you cannot connect to the server. Make sure the service URL is correct, firewall and network settings on this computer and on the server computer are configured properly, and the appropriate services have been started on the server.
    Error details:
    Could not complete the request to remote agent URL 'https://my-test-site.com:8172/msdeploy.axd?site=Default Web Site'.
    The underlying connection was closed: An unexpected error occurred on a send.
    Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.
    An existing connection was forcibly closed by the remote host 0 0 WebProjectName

    Thanks,
    Bill

    Friday, February 12, 2016 10:23 PM
  • Hi OutstandingBill,

    According to your troubleshooting steps, it seems that the TLS1.0 need to be enabled when publish website with Publish Web Wizard.

    I find you have submit this issue to Visual Studio Connect, I think the report team experts will evaluate this problem seriously. Thanks for your feedback for the VS products.

    https://connect.microsoft.com/VisualStudio/feedback/details/2353425

    Best Regards,
    Weiwei



    Monday, February 15, 2016 1:50 AM
    Moderator