none
.NET Framework 2.0 Service Pack 1 Big Problem - Help! RRS feed

  • Question

  •  

    Hi folks,

     

    This is the first time ive posted here but for the last few days ive had an issue with the Microsoft .NET Framework 2.0 Service Pack 1 (KB110806) update that is driving me crazy! I have windows automatic updates switched on and it keeps trying to install this, however it constantly fails! Each time i start up windows it trys over again! I checked my installed programs and have Framework 1.1, hotfix 1.1 and framework 2.0 installed. None of these will uninstall.

     

    Can somebody with a clue please point me in the right direction, i have no idea what im doing here!

     

    Thank you in advance

     

    Gary

    Thursday, January 31, 2008 6:43 PM

Answers

All replies

  •  

    Ditto...  I have exactly the same problem and can't locate a solution!  Can anyone help?
    Thursday, January 31, 2008 8:13 PM
  • Hi Gary

     

    What is your OS version?

    You can download and install .NET 2.0 sp1 from: http://www.microsoft.com/Downloads/details.aspx?familyid=79BC3B77-E02C-4AD3-AACF-A7633F706BA5&displaylang=en or http://www.microsoft.com/downloads/details.aspx?FamilyId=029196ED-04EB-471E-8A99-3C61D19A4C5A&displaylang=en

    instead.

     

    If you meet further problem, please post back.

     

    Thanks

     

    Monday, February 4, 2008 8:30 AM
  • Hi,

     

    Thanks for replying, im using a laptop with XP. Ive tried to uninstall all .net programs to start again, but it wont let me do that either! Each time my comp boots up the windows automatic update says the.net update is waiting to be installed, but as usual it fails

     

    Regards

     

    Gary

     

    Monday, February 4, 2008 6:37 PM
  • So if .NET 2.0 sp1 is in the updates list, please uninstall it first, and FYI: Updated .NET Framework cleanup tool: http://blogs.msdn.com/astebner/archive/2007/12/04/6659905.aspx

     

    Then try to download the one from web and install it again.

     

    If manually installation fails again, please follow the steps:

    What to do when you go to post a setup and deployment issue on the MSDN forums?
    http://blogs.msdn.com/aaronru/archive/2007/12/10/what-to-do-when-you-go-to-post-a-setup-and-deployment-issue-on-the-msdn-forums.aspx

     

    Thanks

    Tuesday, February 5, 2008 3:08 AM
  • I too have the same problem with Microsoft .Net Framework 2.0 Service Pack installing.  It shows as an auto update( I have OneCare that automaticly updates) and this wont install.  Can someone help me...I am not too puter savy.

    Wednesday, February 13, 2008 3:59 AM
  • Hi cdavis,

     

    the above post about using the cleanup tool first solved this problem for me. Give it a try. use the tool to remove all .net components, then reinstall what you like. Should work fine

     

    Wednesday, February 13, 2008 6:31 PM
  • Thank you for responding.  After using the tool, what should I reinstall?  This framework thing has something to do with my Onecare not opening so I need to know what I reinstall,as it affects this and many other things.

    Thank you!

    Wednesday, February 13, 2008 6:35 PM
  • I have a different problem with .NET Framework 2.0 Sevice Pack 1 than you are discussing here, but I see no other threads dealing specifically with it. .NET Framework 2.0 Sevice Pack 1 came to me as an automatic update for my laptop with WIN XP Service Pack 2, therefore I clicked install, which it did. HOWEVER, since that point I have had the issue of repeated restarts covered in article 322205. The restarts are so frequent that my laptop never gets far enough in the boot process to even activate the monitor. By unplugging all of my peripherals except my mouse, which includes 2 printers, scanner, cooling fans, numeric keypad, and backup drive, I can get it to boot normally which it did before the download. From reading the overview on .NET Framework 2.0 Sevice Pack 1 I get the impression that it is for Visual Studio on handhelds. I do not have Visual Studio on my laptop and do not currently forsee using it. Do I uninstall the .NET Framework 2.0 Sevice Pack 1, do I have a conflict I have to resolve, or is this all going over my head and I'm clueless. 

    Sunday, March 2, 2008 6:53 AM