locked
Running ASP.NET 2.0 app in IIS on Windows 7 RRS feed

  • Question

  • User-949716590 posted

    I can not get a simple ASP.NET 2.0 app to run in IIS on a Windows 7 (Build 7100) computer. The app runs fine in the Visual Studio 2008 develpment server, but in IIS I get an HTTP 500 error.

    I am running the App in a Virtual Folder in a Classic Application Pool, but I don't know what else to try or where else to look.

     Thanks.

    Monday, June 1, 2009 12:39 PM

Answers

  • User745795303 posted

    I hope then this might help you.................

    http://blogs.msdn.com/webdevelopertips/default.aspx

    If not then do let us know.....

    Regards

    Sadeed

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, June 5, 2009 11:03 AM
  • User176332441 posted

    go to internet tools options  and in advanced tab deselect show friendly error messages,

    again when you open the site, you will see the error paste it here

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, June 5, 2009 10:46 PM

All replies

  • User745795303 posted

    Hi,

    Make me clear if I am not..........I m assuming that you are ruuing things over the x64 platform..........

    The issue over here is that when you are runing your application on the local server the IIS used is the x86 and the Framework deployed is also X86 thats how you are not getting any problem.

    But when you Deploy this on the server then you might get this error.............

    Simply go to the run and Copy Paste these scripts and press ok............I hope this will make your application working on the IIS.

    First, a quick script to enable support on the system:

    cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 True

    Second, actually install the 32–bit version of ASP.NET onto IIS:

    %SYSTEMROOT%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i

    Finally, enable 32–bit ASP.NET inside the Web Server Extensions (IIS Management Console):

    Enabling x86 .NET in IIS

    Hope this helps..................try this and let me know

    Monday, June 1, 2009 1:36 PM
  • User-949716590 posted

    I should have been clearer in my original post. I am running Windows 7 32 bit.

    The site works fine when deployed to Windows 2008 Server (64 bit). I am unable to get it to run properly on IIS on my 32 bit Windows development computer.

    I like to run the application in IIS, so I can easily test various browsers in virtual machines.

    Thanks.

    Monday, June 1, 2009 1:45 PM
  • User176332441 posted

    when you try to run through IIS you should convert the virtual directory to application.

    If you want to check in different IE, use multiple IE... just google multiple IE

    Monday, June 1, 2009 4:24 PM
  • User-949716590 posted

    when you try to run through IIS you should convert the virtual directory to application.

    If you want to check in different IE, use multiple IE... just google multiple IE

    It does not make any difference if the site is a virtual folder or an application. There is nothing in the page wen I browse to it.

    Monday, June 1, 2009 5:25 PM
  • User745795303 posted

    I hope then this might help you.................

    http://blogs.msdn.com/webdevelopertips/default.aspx

    If not then do let us know.....

    Regards

    Sadeed

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, June 5, 2009 11:03 AM
  • User176332441 posted

    go to internet tools options  and in advanced tab deselect show friendly error messages,

    again when you open the site, you will see the error paste it here

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, June 5, 2009 10:46 PM