none
How to Reinstall .NETFramework on Windows 8 RRS feed

  • Question

  • When trying to open a project using VC++ Express 10, it tells me that:

    "the solution requires .NetFramework4.5, which is not installed on this computer".

    However, trying to install .NetFramework4.5, the installer tells me it can't perform the installation because .NetFramework4.5 it's already installed.

    After days trying to fix/solve the problem, I then figured the following

    [09/24/15,00:10:01] Install state for .NET Framework 4 Full: installed with no service packs.
    [09/24/15,00:10:01] Install state for .NET Framework 4.5: installed with no service packs.
    [09/24/15,00:10:01] Install state for .NET Framework 4.5.1: installed with no service packs.
    [09/24/15,00:10:01] Install state for .NET Framework 4.5.2: installed with no service packs.
    [09/24/15,00:10:01] Install state for .NET Framework 4.6: not installed.

    My question is: how do I install the missing service packs? Or how can I reinstall .NetFramework 4.5?

    Please, don't tell me to run Windows Update because I did this many times and it don't fix the problem.

    Please, don't tell me to try to uninstall it, because Windows doesn't show it on the Control Panel.

    Thanks for your help.

    Friday, September 25, 2015 1:56 PM

Answers

  • First, you cannot install or uninstall .NET 4.5 in Windows 8, because it comes as embedded in your OS. That is why it doesn't appear in the installed programs list.

    You can find it listed in Control Panel->Turn Windows features on and off...

    You can check there to be sure it is fully activated.

    To make sure your .NET 4.5 is configured properly, use this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with .NET 4.5 selected, then check the last few lines of the tool log for the test app return code. If the return code is not 0, your 4.5 is corrupt.

    However, I just noticed something strange in your post:

    You say you are using Visual C++ Express 2010?

    If that is so, VS 2010 CANNOT SEE or USE any .NET Framework > 4.0.

    To use .NET 4.5 or newer with Visual Studio, you must use a newer version, like VS 2013 or VS 2015.

    Sunday, September 27, 2015 4:23 PM