locked
Upgraded TFS 2013 to TFS 2017 Update 1 error with automatic feature configuration RRS feed

  • Question

  • Just upgraded TFS 2013 to TFS 2017 update 1 and it went ok.

    Now i want to configure features for the existing projects:

    I get this error when i try to configure features for the existing projects

    What exactly is it i need to do?

    (I've read all the links to importing wit's etc. but i can't figure out what i need to do).

    Please explain.

    Thank!


    Daniel Bugday
    Microsoft Community Answerer, Member of Microsoft Extended Expert Team, MCT, MCTS/MCPD SharePoint 2007/2010, SQL MCDBA, MCSE
    Blog: SharePoint By Bugday
    Contact:
    Please remember to mark your question as "answered" if this solves your problem

    Thursday, September 7, 2017 1:33 PM

Answers

  • Hi Daniel,

    I'm afraid your TFS 2013 process template has been customized. If you want to use TFS 2017 default process template, you would need to remove the custom parts in TFS 2013. But in this way, the custom state will be lost.

    Best regards,


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    • Marked as answer by Daniel Bugday Tuesday, September 12, 2017 7:49 AM
    Tuesday, September 12, 2017 6:35 AM

All replies

  • Hi Daniel,

    Could you repost your question? There is no error message in this post.

    You can follow the article below for your upgrade:

    https://www.visualstudio.com/en-us/docs/setup-admin/tfs/upgrade/walkthrough

    And you can upgrade to the latest TFS 2017.2 instead of TFS 2017.1.

    Best regards, 


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, September 8, 2017 9:27 AM
  • I've upgraded to TFS 2017 update 1

    and trying to configure features for every project

    Configure Feature after upgrade

    I get this error:

    My goad is to migrate to VSTS and need every project to be upgraded.

    Is there a step by step guide on how to resolve this?

    Thanks


    Daniel Bugday
    Microsoft Community Answerer, Member of Microsoft Extended Expert Team, MCT, MCTS/MCPD SharePoint 2007/2010, SQL MCDBA, MCSE
    Blog: SharePoint By Bugday
    Contact:
    Please remember to mark your question as "answered" if this solves your problem

    Friday, September 8, 2017 11:03 AM
  • Hi Daniel,

    The error indicates a TF400609 error, which means a required STATE is missing.

    I assume you have customized work item type in TFS 2013. But in the TFS 2017, there is no corresponding custom state, so you get such error.

    You need to change the States elements to match your work items states by following the article below:

    https://www.visualstudio.com/en-us/docs/work/reference/resolve-errors-received-when-configuring-features#warnings

    Best regards,


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, September 11, 2017 7:16 AM
  • What i understand of the problem is that the existing projects used a process template from TFS 2013 and not a custom process template.

    Is it possible to remove the process template and have the TFS 2017 version applied to existing projects without losing data?

    I am in the process of moving the On-prem TFS 2013 to VSTS and can't do that if i have this problems.

    Thank you


    Daniel Bugday
    Microsoft Community Answerer, Member of Microsoft Extended Expert Team, MCT, MCTS/MCPD SharePoint,SQL MCDBA, Windows MCSE, Azure Solution Architecture, Office 365 MCSA, Office 365 App Developer

    Contact:
    Facebook LinkedIn Twitter
    "Please remember to mark your question as answered if this solves your question. Thank you"!

    Monday, September 11, 2017 12:59 PM
  • Hi Daniel,

    I'm afraid your TFS 2013 process template has been customized. If you want to use TFS 2017 default process template, you would need to remove the custom parts in TFS 2013. But in this way, the custom state will be lost.

    Best regards,


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    • Marked as answer by Daniel Bugday Tuesday, September 12, 2017 7:49 AM
    Tuesday, September 12, 2017 6:35 AM