none
WSS 3.0 Sharepoints alerts are not working. RRS feed

  • Question

  • Hi,

    In our company we have problems with the sharepoints alerts (SP 2007 on windows 2003). No one receives the email alerts.

    Other mail functionality works correctly.

    When a user installs an alert he receives an email "You have successfully created an alert for ...".

    * It was a new installation so it isn't an upgrade problem.
    * The mail settings in the central administration are OK

    * Timer job status:

    Immediate Alerts oppnsps01 Succeeded 100% 1/3/2008 10:35 AM

    * In the logs i don't find errors
    * I tried the following commands: NOK

    stsadm.exe -o setproperty -url http://oppnsps01/sites/library -pn alerts-enabled -pv true
    stsadm.exe -o setproperty -url http://oppnsps01/sites/library -pn job-immediate-alerts -pv "every 5 minutes"

    * I've requested and installed the latest  hotfix package: NOK
    * It's not a permission issue -> i have the same problem and have all rights

    Can someone help?

    Thanks.

    Gr,

    Frederik
    • Moved by Mike Walsh FIN Thursday, July 8, 2010 3:13 AM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Thursday, January 3, 2008 9:52 AM

Answers

  • Found the solution for my problem - another Forum had listed this as a solution (can't recall which, been to so many):
    Go to the Central Administration tool for the affected site, click on Operations --> Access Drive Mappings

    Ensure that the URL listed for the Default Zone is the URL of your site, not the Windows Name of your Site's server.  If it is not, edit it (Click on the linked URL name).

    Hope this helps you.
    Monday, September 14, 2009 2:57 PM

All replies

  • When a new folder is created in the document library an alert is sent (not at an upload of a new document). Strange...


    Thursday, January 3, 2008 10:14 AM
  • No one?
    Sunday, January 6, 2008 8:34 PM
  •  

    I have exactly the same problem !

    no error informations in the event viewer... Sad

     

    nobody can help us ? Crying

    Thursday, January 10, 2008 2:16 PM
  • I have the exact same problem. The Timer service is running on our server and the user gets an email from the server that the alert has been created. But anytime a change is made in the the user never gets an alert.

    I have tried several different scenarios and they are all the same. No alerts.

     

     

    Thursday, January 10, 2008 4:26 PM
  • Have you checked the ULS and system logs to make sure there aren't any errors with the timer service?  I've seen this happen when the account used for the service has issues (expired password, no access, etc).

     

    Thursday, January 10, 2008 5:26 PM
  • Yeah. No errors. I spoke with our SQL admin (databases are housed on seperate SQL 2005 server) and also sent him this KB article: http://support.microsoft.com/kb/936759.

     

    Symptoms appear to be that WSS email alert services is not being notified when data changes in SQL db. Still looking into it.

     

     

    Thursday, January 10, 2008 6:39 PM
  • I've found a interesting link : http://sharepoint.microsoft.com/sharepoint/worldwide/us/southeast/Wiki/Troubleshooting%20Alerts%20in%20WSS%203.0%20-%20MOSS.aspx

     

    I haven't tested yet...

     

    maybe it can help you !

    Friday, January 11, 2008 11:24 AM
  • Ok, thanks for the link.

     

    i'll check it this afternoon.

     

    Monday, January 14, 2008 9:56 AM
  • I tried to execute this "stsadm.exe-o getproperty -url http://problemsite  -pn alerts-enabled"

     

    but then i get this error in the dos-windows:

     

    The server administration programs and the Windows SharePoint Services Web appli
    cations on this Web server are not compatible.  Ensure that the administration p
    rogram is the same version as the Web application.

     

    Can this occurs the problem?

    Normally the versions should be the same. I have installed them with the same cdrom.

     

    Gr,

    Frederik

     

     

    Monday, January 14, 2008 1:24 PM
  • I was able to resolve my alert problems by stopping and restarting both Window Time and Windows Sharepoint Services Timer services in the MMC on the server running my WSS configuration.

    Friday, January 18, 2008 12:01 AM
  • I tried it but it doesn't help. I've already restarted the server completely -> NOK

     

    Pfffff

    Friday, January 18, 2008 12:56 PM
  •  

    The problem isn't solved yet.

    It's really a strange issue. No one an idea?

     

    Frederik

    Wednesday, February 20, 2008 8:04 AM
  • Frederik,
    Have you been able to resolve this issue with the alerts not working properly yet?

    Thanks in advance!

    Tuesday, August 26, 2008 7:29 PM
  •  i have just found the same problem...

    no alert going out except the information message that alert has been set up on that library for that user. if i create a folder in the library i do get an alert it was created but not when i create or upload a document.

    alert set on new item added - anything changes- immediate email. only diffrence it my lib is a forms library.

    i get not error messages in logs cant find any trace of an alert anywhere.

    if i create a normal document library and add an alert it works as it should ! but i doubt its becuase i try on form libarary it doesnt work.

    very strange. any clues on that ?
    Thursday, November 6, 2008 12:45 PM

  • Hi,

    I had this problem with a document library also. Turns out it was a combination of security and versioning.

    If security on the document library was controlled through AD groups (ie. adding an AD group to the Sharepoint groups), nobody got alert messages. Adding users directly to the Sharepoint groups resolved this.

    Once the security was sorted, read only users received alerts for new folders, but not for files. This was because the document library was set to allow minor and major versions of files. All files being uploaded were checked in as version 0.1 -- a minor version. Even though the doc library was set to allow read access to minor versions, the alerts were not sent. When a document was published as a major version, the alerts would be sent. This would make more sense to me if the readers were not allowed to access minor versions. Anyway, you can either make sure documents are published as major versions or set the library to only store major versions. If you're only storing major versions, a document will be assigned 1.0 when uploaded and all alerts will be sent.

    Hope this helps.


    Tuesday, November 11, 2008 6:02 AM
  • Hi,

    I have the same problem on a MOSS 2007 Web site : my customer would like to receive notification emails for minor version : after few investigations I could notice that notifications were sent only when documents are published as major versions.
    Does anybody know if this is a feature of SharePoint or a bug ? To my opinion, the normal behaviour should be that the notification emails on minor version depend on the "Who can see minor version : Anybody, only contributers, only approvers" parameter of the document library...
    Did someone managed to activate notifications for minor versions ?

    Regards,

    Laurent
    LUNG
    Monday, November 24, 2008 9:53 AM
  • Hi,

    After further investigation : users need to have the "Approve elements" permission to receive notifications on minor versions. The behaviour doesn't depend on the "Who can see minor version" doclib parameter.
    I will try to post a Microsoft case on this problem...

    Regards,

    Laurent
    LUNG
    Monday, November 24, 2008 10:29 AM
  • Many thanks for the information about the Approve elements permission - it saved me a lot of investigation!
    Tuesday, December 9, 2008 7:32 AM
  • babeach said:

    I was able to resolve my alert problems by stopping and restarting both Window Time and Windows Sharepoint Services Timer services in the MMC on the server running my WSS configuration.



    Can someone please explain to me what running "WSS configuration" could mean here?

    Thanks,
    Sunday, February 22, 2009 5:45 PM
  • Hello,

    This is for Laurent... you stated you were going to post a case on Microsoft IRT this issue.  Have you received any answer?

    Thanks so much.
    Key
    Key
    Monday, March 23, 2009 8:36 PM
  • Hi,
    have you been able to resolve this issue?
    Michal Straka
    Tuesday, May 12, 2009 1:39 PM
  • Ok, for the novice users of sharepoint which includes myself.

    First off, I had the issue where I was receiving the confirmation emails for the alerts but not the actual alerts.

    1) Email server was setup correctly and was sending emails
    2) Thus the Schedule Timer OWSTIMER.EXE might be having issues.

           a) Verify Permissions (My account being used was Network Service)  Verify permissions for the OWSTIMER.EXE File and Content Database which you defined (default is wss_content) are properly set.  Best way is to do this via Service Accounts in Central Administration.
           b) Review Log Files: Mine are located at: c:\program files\common files\microsoft shared\web server extensions\12\logs
                   - review lines indicated by process OWSTIMER.EXE (Especially Category Timer under this process)

    NOTE: My issue was this, and it was stated in the log file: Alerts Job Failed to initialize site collection for subscription.........possibly incorrect siteurl http//blah.blah.  I solved this issue by ensuring my Alternate Access Mappings in Central Administration had the same listed siteurl that my Log file contained.  It happened that it wasn't the same so I had to edit the url in the mappings so the OWSTIMER.EXE could access the content Database.  Now Permissions could also affect the access to the content database, so please keep this in mind.
           c) Verify that your Anti-virus is not blocking the OWSTIMER.EXE as a Mass Email Spammer or anything else.
           d) Verify that the OWSTIMER.EXE is running in Services for your Operating System.


    If you changed any of these items, test out the alert again.
    Thursday, May 21, 2009 7:30 PM
  • I have now performed all of the above (except for the MOSS server since it is Windows Server 2003, SharePoint Services 3.0 SP1).  I am completey astonished that something has not worked.  I have exactly the same problem as mentioned in the beginning thread. 

    I sincerely appreciate all the effort those with answers have put in here and all across the web, but to no avail, I have yet to get any activity alerts...just the ones that alert me when I have signed up for alerts on a particular web part.

    Any fresh ideas? 



    Curious - I received one alert from all the stuff I tried the following morning at 7am.  My alert was set up to receive a daily account.  Interesting that it was only one and then stopped even to this day...something I did worked, but I changed it back.

    One more note that could help - my SharePoint Admin account (in which I configured it's email to go to my email account), the alerts it is configured for works.

    WPJim

    Tuesday, September 1, 2009 5:57 PM
  • Found the solution for my problem - another Forum had listed this as a solution (can't recall which, been to so many):
    Go to the Central Administration tool for the affected site, click on Operations --> Access Drive Mappings

    Ensure that the URL listed for the Default Zone is the URL of your site, not the Windows Name of your Site's server.  If it is not, edit it (Click on the linked URL name).

    Hope this helps you.
    Monday, September 14, 2009 2:57 PM
  • Found the solution for my problem - another Forum had listed this as a solution (can't recall which, been to so many):
    Go to the Central Administration tool for the affected site, click on Operations --> Access Drive Mappings


    Cool! It really works for me. So easy to fix and so hard to find. Thank you!
    • Proposed as answer by D_Elie Wednesday, July 7, 2010 1:49 PM
    • Unproposed as answer by Mike Walsh FIN Thursday, July 8, 2010 3:08 AM
    • Edited by Mike Walsh FIN Thursday, July 8, 2010 3:13 AM Don't use full quote
    Thursday, January 28, 2010 8:56 PM
  • Found the solution for my problem - another Forum had listed this as a solution (can't recall which, been to so many):
    Cool! It really works for me. So easy to fix and so hard to find. Thank you!


    And this worked for me.

    Thanks Dima JP

    • Edited by Mike Walsh FIN Thursday, July 8, 2010 3:12 AM don't use full quote
    Wednesday, July 7, 2010 2:08 PM
  • I don't have "Access Drive Mappings" under Operations unless I'm just blind. the closest thing I see is "Alternative Access Mappings". Is that the same thing? Why don't I see what you are referring to? Is our SP version/update for MOSS2007 out of date? What do you mean by Windows Name? I'm assuming if I see and https URL in both fields (presuming Alternative Access Mappings is the same as what you referenced), it's set correctly, right?
    Tuesday, September 7, 2010 1:55 PM
  • Sharepoint Central Administration Under IIS.  Enter this site. 

    Central Administration ----> Alternate Access Mappings

    NOW A LITTLE BACKGROUND INFO:

    Access mappings determine the url to use for a lot of the links built into sharepoint.  Meaning, if you want to access the sharepoint site on the network, you could only configure the mappings to be an internal address such as http://my-server:21305   Where this represents the server's computer name.  This wont function properly if you try and access it over the internet though.

    BUT, if you want to access the sharepoint site via the internet....you must ALSO configure a domain name such as http://blah.com.  To do this, click add internal URLs, and place your domain http://yourdomain.com, you should be able to leave the zone to default.  You must also setup a domain to have emails sent from sharepoint, you must also configure smtp on your server properly with your domain name.

    Any more questions please post.

    Tuesday, September 7, 2010 9:55 PM
  • Hello All,

    if you have tried all the above and nothing seems to work, here's a last ditch solution that may be of help:

    http://www.falconitservices.com/support/blog/Lists/Posts/Post.aspx?ID=26

     


    Miguel Fra / Falcon IT Services
    Computer & Network Support, Miami, FL
    Visit our Knowledgebase and Support Sharepoint Site



    • Edited by Miguel Fra Sunday, October 2, 2011 6:49 PM
    Sunday, October 2, 2011 6:48 PM
  • Sorry in advance to bother you all with my question. This question is for SharePoint 2003 Alternate Access Mappings. I am trying to find where Alternate Access Mappings are in SharePoint 2003. 
     
    I have searched high and low on the web and read all the posts in this thread however I am unable to locate 'Operations' and 'Access Drive Mappings' and 'Alternate Access Mappings' in SharePoint 2003. I am very new to SharePoint 2003 and have been working with SharePoint 2010 for sometime now. 
     
    I am a Farm Administrator for SharePoint 2003. When I go to Central Administration tool for the affected site, I see following links: 
     
    Across the top: Home, Documents and Lists, Create, Site Settings, Help, Up to IT 
     
    Administration: Manage users, Manage sites and workspaces, Configure Site and Workspace Creation, Go to Site Administration.  
       
    Customization: Change site title and description, Apply theme to site, Modify site content, Customize home page.    
        
    Manage My Information: Update my information, My alerts on this site, View information about site users.  
      
    So, where exactly is alternate access mappings?????

    Saturday, August 18, 2012 10:17 PM