Visual Studio 2015 Update 1 - can't start project with F5 - error "A component dll failed to load."


  • We observe this error on couple machines already, two of which are fresh Windows 8.1 installation, with <g class="gr_ gr_52 gr-alert gr_gramm undefined Grammar only-ins doubleReplace replaceWithoutSep" data-gr-id="52" id="52">fresh</g> VS2015 (Enterprise) installation. Once we install Update 1 and create an empty Windows Forms project, when we hit F5 to start the empty form we get the error: 

    Microsoft Visual Studio
    Error while trying to run project: Unable to start program 'C:\Users\user\documents\visual studio 2015\Projects\WindowsFormsApplication1\WindowsFormsApplication1\bin\Debug\WindowsFormsApplication1.exe'.

    A component <g class="gr_ gr_47 gr-alert gr_spell undefined ContextualSpelling ins-del multiReplace" data-gr-id="47" id="47">dll</g> failed to load. Try to restart this application. If failures continue, try disabling any installed add-ins or repair your installation.

    If we remove Update 1, it starts working normally.

    Can't see anything in the ActivityLog.xml. I have started VS with devenv.exe /Log to produce it and I am copying it from C:\Users\user\AppData\Roaming\Microsoft\VisualStudio\14.0\ActivityLog.xml.

    I have uploaded the log here for reference:

    Saturday, December 12, 2015 9:58 AM


All replies

  • Hi Stefan,

    Before you press F5, please try to update your NuGet package, I think there's some missing NuGet Package and it's not download automatically when you press F5

    Saturday, December 12, 2015 1:56 PM
  • There are no NuGet packages in the <g class="gr_ gr_11 gr-alert gr_spell undefined ContextualSpelling ins-del multiReplace" data-gr-id="11" id="11">sln</g>. It is a plain Windows Forms application with nothing in it - just the default Form.
    • Edited by stefan stefanov Monday, December 14, 2015 9:36 AM cleaned some html tags
    Saturday, December 12, 2015 2:41 PM
  • Hi Stefan stefanov,

    According to the error message in your log file, there doesn't have any error message. And I create a sample Windows Forms project with VS2015 Enterprise Update 1 on Windows 8.1, everything is ok.

    Does this problem occurs with Windows Forms project or all type of project? And does it occur randomized?

    Please try with following steps to troubleshoot this issue, please tell us the following results after testing, which can help us troubleshoot the reasons.

    1. Run Visual Studio 2015 as administrator.
    2. Run Visual Studio 2015 Community in safe mode with "Deven.exe /SafeMode" command to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution.
    3. Close all third part software, such as Antivirus.
    4. Please use  to gather the VS and .Net Frameowrk installation logs. After using it, you will find from %temp% folder. Please upload the file to Onedrive and share the link here.

    Best Regards,

    Monday, December 14, 2015 9:11 AM
  • Hi Weiwei,

    thank you for looking into this.

    I ran the studio (VS2015 <g class="gr_ gr_23 gr-alert gr_spell undefined ContextualSpelling ins-del multiReplace" data-gr-id="23" id="23">Enterprrise</g>) in safe mode as suggested and I collected the required logs. Here are they:

    I have also captured the process of reproducing the error (it reproduces in both WinForms and WPF projects) and the process of gathering the data in this short video:

    Let me know if I can provide something else.

    Monday, December 14, 2015 10:46 AM
  • Hi Stefan stefanov,

    According to the update log, I find below failed information about VS update. It seems update your Visual Studio failed because lack of the update xml file. 

    Failed to download the update xml file from Setup will not be updated.

    Please download the update 1 from below link and re-install it.

    If still has the problem, please try repair your Visual Studio 2015 after installing Update 1 through Control Panel -> Programs -> Visual Studio 2015 -> Change -> Repair.

    Best Regards,

    Tuesday, December 15, 2015 1:18 AM
  • Thank you for getting back to me.

    This is interesting, as Help > About shows I have the Update 1 installed:

    We tried with the online installer and we did not succeed, hence we downloaded the ISO and installed it from there with no error message: mu_visual_studio_2015_update_1_x86_x64_dvd_7288688.iso

    Now I downloaded the update from your link and once started it offered me Repair and Uninstall options. I choose Repair and after the process finished, I was still observing the error. Here you can find the logs at this point: After Repair logs

    Then using the same tool, I Uninstalled the Update 1. Here is the log after the uninstallation: After Uninstall

    Then I installed it again, but I am still seeing this error. Here are the logs at this point: After Reinstall

    Could you please share which file you are looking for errors as there are multiple files in the zip? Also, any other suggestions I can try?

    Tuesday, December 15, 2015 12:20 PM
  • Hi Stefan stefanov,

    >>Could you please share which file you are looking for errors as there are multiple files in the zip?

    Please check the installation and update log of your Visual Studio in Temp folder, the files also name like dd_vs_community_201512160809.log and dd_vsupdate_201512160809.log. Then please searching "error" or "failed" key words in that file to find out whether there has some installation error.

    >>Also, any other suggestions I can try?

    Please check the application.exe file in path of bin\Debug, whether it is generated in that path first. If the file exist, then run your application with Ctrl + F5, which is run the application without debug.

    Besides, please store your project in other drives, such as D:\, and make sure that drive is accessible and current user has the permission to access the folder.

    In addition, if above steps still don't resolve the problem, I suggest you download the Visual Studio 2015 with Update 1 installation package to install Visual Studio and Update 1 together.

    Before reinstall, please clear all installation log files in Temp folder, and then collect the new installation log again to check whether it installed correct.

    If the Exit code is 0x0 in dd_vs_community...log, the installation is correct and there may be something different on your computer environment, please change another computer to install VS 2015 Update 1.

    Best Regards,

    Wednesday, December 16, 2015 3:22 AM
  • Hi,

    The executable file is properly built and it is stored in the bin/Debug folder. If you double click it, it runs just fine. However, you cannot start it from within VS with Ctrl+F5 as you get the same error.

    The project is stored in the default VS location, and I don't <g class="gr_ gr_11 gr-alert gr_spell undefined ContextualSpelling" data-gr-id="11" id="11">thing</g> this has anything to do with permissions.

    It seems to me that this is not <g class="gr_ gr_16 gr-alert gr_gramm undefined Grammar only-ins doubleReplace replaceWithoutSep" data-gr-id="16" id="16">installation</g> issue, but some VS issue.

    Something that might be worth mentioning is that I am mostly testing on physical/virtual machines ALWAYS via remote desktop (with admin privileges)

    Another thing I noticed in the ActivityLog is the following error: 

    Extension will not be loaded because an extension with the same ID 'Microsoft.VisualStudio.TeamFoundation.TeamExplorer.Extensions' is already loaded at C:\PROGRAM FILES (X86)\MICROSOFT VISUAL STUDIO 14.0\COMMON7\IDE\EXTENSIONS\0WZ2MZEL.V4U\...          C:\PROGRAM FILES (X86)\MICROSOFT VISUAL STUDIO 14.0\COMMON7\IDE\COMMONEXTENSIONS\MICROSOFT\TEAMFOUNDATION\TEAM EXPLORER\

    Wednesday, December 16, 2015 12:09 PM
  • Hi Stefan stefanov,

    I also run Visual Studio 2015 Enterprise on Windows 8.1 and it works fine, so I assume there has installation issue with update 1 and the computer environment. I still recommend you download the Visual Studio 2015 with Update 1 installation package to reinstall them together.

    According to the error in ActivityLog, please remove all extensions about Team Foundation one by one to make sure whether this extension causes this issue.

    In addition, please use .NET Framework Setup Verification Tool to verify the .NET Frameworks on your machine, you can download from here:

    By using it, you will find the log file under %TEMP% folder, see the first 15 lines and the last 15 lines.

    If the exit code != 0, it means that your .NET installed incorrectly, please first use .NET Framework Repair Tool to repair it,

    Best Regards,

    Thursday, December 17, 2015 2:28 AM
  • Downloaded and installed VS2015 with the Update1 included and it finally worked. 

    Thanks for your efforts.

    Thursday, December 17, 2015 11:14 AM