locked
the remote name could not be resolved RRS feed

  • Question

  • hi,

    I have created a service hosted in iis.and a client at another computer.but when I add service reference in client ,there is error downloading :

    There was an error downloading 'http://pcitlab73.itlabserver.edu/wcftest2/service.svc'.
    The remote name could not be resolved: 'pcitlab73.itlabserver.edu'
    Metadata contains a reference that cannot be resolved: 'http://pcitlab73.itlabserver.edu/wcftest2/service.svc'.
    There was no endpoint listening at http://pcitlab73.itlabserver.edu/wcftest2/service.svc that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.
    The remote name could not be resolved: 'pcitlab73.itlabserver.edu'
    If the service is defined in the current solution, try building the solution and adding the service reference again.

    but I have not this problem  previous.
    Any help is highly appreciated.
    Tuesday, August 18, 2009 10:17 AM

Answers

  • Hi,
     there must be sothing wrong with your DNS.so it can not parse the server addesss with domain name.
      please replace it with Server IP directly.
     then try again.

    Regards
    Frank Xu Lei--谦卑若愚,好学若饥
    专注于.NET平台下分布式应用系统开发和企业应用系统集成
    Focus on Distributed Applications Development and EAI based on .NET
    欢迎访问老徐的中文技术博客:Welcome to My Chinese Technical Blog
    欢迎访问微软WCF中文技术论坛:Welcome to Microsoft Chinese WCF Forum
    欢迎访问微软WCF英文技术论坛:Welcome to Microsoft English WCF Forum
    Tuesday, August 18, 2009 10:45 AM
  • <identity>
      <dns value="pcitlab73.itlabserver.edu"/>
    </identity>
    Hi N-ghanavizi ,

    Here is some solutions to this kind of issue :

    ============================

    1). Please check if your domain name pcitlab73.itlabserver.edu is still valid. You can try other web application hosted on the IIS if they could be accessed from other machine.

    2). Check the firewall setting of the server host your WCF service. Sometimes it will deny the connection from other machines due to the special setting.

    3). Please check you setting of IIS if the WCF service application is set to the right access for URL.

    ============================

    If it still doesn't work , please post your web.config here , you can check these configuration at first :

    ============================

    1). "address" attribute of your service endpoint is configured correct.

    2). Inside your <endpoint> tag , if there exists this kind of setting :

    <identity>
      <dns value="pcitlab73.itlabserver.edu"/>
    </identity>

    ============================

    Hope this will be helpful.

    Thanks , Quan

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Wednesday, August 19, 2009 10:29 AM

All replies

  • Hi,
     there must be sothing wrong with your DNS.so it can not parse the server addesss with domain name.
      please replace it with Server IP directly.
     then try again.

    Regards
    Frank Xu Lei--谦卑若愚,好学若饥
    专注于.NET平台下分布式应用系统开发和企业应用系统集成
    Focus on Distributed Applications Development and EAI based on .NET
    欢迎访问老徐的中文技术博客:Welcome to My Chinese Technical Blog
    欢迎访问微软WCF中文技术论坛:Welcome to Microsoft Chinese WCF Forum
    欢迎访问微软WCF英文技术论坛:Welcome to Microsoft English WCF Forum
    Tuesday, August 18, 2009 10:45 AM
  • <identity>
      <dns value="pcitlab73.itlabserver.edu"/>
    </identity>
    Hi N-ghanavizi ,

    Here is some solutions to this kind of issue :

    ============================

    1). Please check if your domain name pcitlab73.itlabserver.edu is still valid. You can try other web application hosted on the IIS if they could be accessed from other machine.

    2). Check the firewall setting of the server host your WCF service. Sometimes it will deny the connection from other machines due to the special setting.

    3). Please check you setting of IIS if the WCF service application is set to the right access for URL.

    ============================

    If it still doesn't work , please post your web.config here , you can check these configuration at first :

    ============================

    1). "address" attribute of your service endpoint is configured correct.

    2). Inside your <endpoint> tag , if there exists this kind of setting :

    <identity>
      <dns value="pcitlab73.itlabserver.edu"/>
    </identity>

    ============================

    Hope this will be helpful.

    Thanks , Quan

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Wednesday, August 19, 2009 10:29 AM