none
BizTalk Adapter Pack Installation on 64-bit RRS feed

  • Question

  • Hi All,


    I have installed following things on 64-bit machine,But I try to use them from Add generated Items
    It throwing the Error. "No valid adapters installed on the machine."

    WCF LOB Adapter SDK SP2 x64
    en_biztalk_adapter_pack_2.0_x86_x64_cd_339765

    Do I need to install any thing else.

    Thanks in advance
    Krishna
    Thursday, December 3, 2009 12:41 PM

Answers

  • In a 64-bit machine, you should install both 32 bit and 64 bit adapter pack.
    Reason: devenv is a 32 bit process and it looks for the adapter information in 32 bit machine.config

    You can find detailed summary of what has to be installed in the installation guide that comes with the adapter pack installation(search for "Scenarios for Installing the BizTalk Adapter Pack on a 64-bit Platform")

    Thanks,
    Jeevitha
    • Marked as answer by krish 18 Thursday, December 3, 2009 4:05 PM
    Thursday, December 3, 2009 2:54 PM

All replies

  • In a 64-bit machine, you should install both 32 bit and 64 bit adapter pack.
    Reason: devenv is a 32 bit process and it looks for the adapter information in 32 bit machine.config

    You can find detailed summary of what has to be installed in the installation guide that comes with the adapter pack installation(search for "Scenarios for Installing the BizTalk Adapter Pack on a 64-bit Platform")

    Thanks,
    Jeevitha
    • Marked as answer by krish 18 Thursday, December 3, 2009 4:05 PM
    Thursday, December 3, 2009 2:54 PM
  • Hi Krishna,

    Check the following url off of MSDN around troubleshooting the 64-bit BizTalk Adapter Pack Installation.  It references the "No valid adapters installed on the machine."  error and a solution.

    http://msdn.microsoft.com/en-us/library/cc185532(BTS.10).aspx

    Thanks,

    William

    Thursday, December 3, 2009 2:56 PM
  • Thanks a lot Jeevitha,

    It worked finally
    Thursday, December 3, 2009 4:06 PM
  •  I have installed 32-bit & 64-bit BizTalk Adapter Pack 2.0 on 64-bit server.
        When Biztalk application is devloped & deployed which adapter pack it is used 32-bit or 64-bit?
    since adapter's where not available when I installed BizTalk Adapter Pack 2.0 64-bit.

    Thanks in Advance
    Krishna
    Friday, December 4, 2009 3:21 PM
  • If your BizTalk host instance is run as a 32 bit process, 32 bit adapter will be picked. Otherwise 64 bit will be picked.

    Thanks,
    Jeevitha

    Saturday, December 5, 2009 1:05 PM