locked
error customising sharepoint list RRS feed

  • Question

  • Hello,

    I tried to customise the view item form of a sharepoint  list in sharepoint designer 2007. I deleted the webpart and added a custom list form. However, when I try to view the item in sharepoint, i do not get the view form. Instead, I am directed to another sharepoint site. It's really weird.

    Can anyone one help me please? How do I get the original view form back?

    Wednesday, September 28, 2011 4:02 PM

Answers

All replies

  • HI,

    From your description it seems that you have not taken the backup of the form.

    Now you need to use DB backup to restore it however I would suggest you to create a new list and items by using datasheet view.

     

    Also can you confirm while adding the custom list form you have selected the correct list from options?

    I hope this will help you out.

     


    Thanks, Rahul Rashu
    Wednesday, September 28, 2011 6:07 PM
  • try to create new custom list and copy content of OTB list view form from it. Then paste it to the broken list view form.


    Blog - http://sadomovalex.blogspot.com
    CAML via C# - http://camlex.codeplex.com
    Wednesday, September 28, 2011 8:26 PM
  • Hi sadomavalex,

    I tried what you suggested but it is not working. It seems that the link is broken. I can preview the customised display form in sharepoint designer but not is sharepoint. Do you where you can specify the link for the display page when you click on view item?

    Thanks,

    Teena

    Thursday, September 29, 2011 6:19 AM
  • Hi Teena,

    Check the below link.

    http://chanakyajayabalan.wordpress.com/2009/11/30/invalid-page-url-new-item-in-sharepoint/

    Hope you are facing the issue mentioned in this post.

     


    Thanks,
    Chanakya
    Microsoft Certified Professional
    My Blog
    Thursday, September 29, 2011 9:17 AM
  • Hi Chanakya,

    I followed your advice. I haven't deleted the original web part. I added a new custom list form and I want only certain users to be able to view it. Although I added the authorised users in target audience , the web part is still appearing for all users. Target audience filtering is not working for the custom web part. Do you have any idea why?

    Thanks,

    T

    Thursday, September 29, 2011 9:26 AM
  • Hi Teena,

    Make sure the other users who are not part of the target audience group have either contribute or read rights only & not Design or Full Control rights.


    Thanks,
    Chanakya
    Microsoft Certified Professional
    My Blog
    Thursday, September 29, 2011 9:32 AM
  • it is specified in associated content type. Check the following link: http://vspug.com/smc750/2007/11/20/setting-a-custom-edit-form-for-a-content-type for example of how to reset it to default.
    Blog - http://sadomovalex.blogspot.com
    CAML via C# - http://camlex.codeplex.com
    Thursday, September 29, 2011 9:32 PM