none
Uninstall GAC Assemblies in BizTalk Application RRS feed

  • Question

  • Hi,

    I have a BizTalk application, it is using some third part assemblies and these assemblies are deployed along with MSI package into GAC. The current implementation was I added all these assemblies into BizTalk resource folder and after that only I created MSI package. 

     

    Since I have a problem when I tried to uninstall the MSI package through the Add/Remove program, it did not remove the third party GAC assemblies. I tried with script also (By the "gacutil /u AssemblyName") but it did not work still assemblies are in GAC folder.

     

    Is there any solution to remove GAC assemblies when uninstall the BizTalk application?

     

    Thanks

     

    Anslum

    Thursday, January 3, 2008 9:37 AM

All replies

  • As I quickly read your question...

     

    Are you doing a "gacutil /u "FULLY QUALIFIED ASSEMBLY NAME"

     

    In otherwords, are you also passing in the Public Key Token, and Version and Culture?  If you specify the FQN, then it should remove this file, as long as the physical file still exists in its registered location. So check to make sure that the MSIL file is physically there. The exact Version, Key and Culture that it was registered with, otherwise you'll have to manually remove it.

     

    As a hack to manually remove it, you could always just delete the file using the command prompt - going to c:\windows\assembly\GAC_MSIL\FullName(without version and pub key)\version_pubKey\Assembly.dll  (This is a hack and not recommended).

     

     

    HTH

    Thursday, January 3, 2008 8:31 PM
  • Hi Dwight,

    I passed fully qualified name in gacutil tool but it did not remove the assembly from the GAC. This is correctly working in development environment but only the problem in production environment. In the product environment, we created post scrpit under the bizTalk resource folder and which script has "gacutil /u "FULLY QUALIFIED ASSEMBLY NAME".

     

    Please advice me.

     

    Thanks

     

    Anslum

    Friday, January 4, 2008 10:32 AM
  • instead of fully qualified name just try this:

    gacutil /u AssemblyName

     

    Make sure, the assembly name is the exact name from GAC and dont mention any path or extension (.dll) simple assembly name.

     

    Even I'm using third party Dlls and uninstall from GAC using the same statement.

     

    Thanks

    Taruna

    • Proposed as answer by Sachin142 Monday, August 31, 2015 3:10 AM
    Friday, January 4, 2008 11:14 AM
  • Hi Taruna,

    What you said is correct in development environment, but in production environment it did not remove the assembly, I saw in MSDN artical it says /u switch with /r also we need to set (ie /u /r). But I am not clear how to specify the /r switch because I am installing assembly into GAC using BizTalk application MSI .

     

    Thanks

     

    Anslum

    Friday, January 4, 2008 2:22 PM