none
Stale license in VS 2013, online service not available, stuck!

    Question

  • Visual Studio 2013 no longer works. I use my MSDN account to log in to and license Visual Studio, and it's working for Visual Studio 2015, and should work for 2013. I can't be sure, but I think it stopped working ever since I installed Visual Studio 2015 alongside it.

    When I open 2013 I get a message that says:

    "Your license has gone stale..."

    When I click the Sign in button, I get a problem:

    "Sorry, we ran into a problem

    The online service is not available...."

    I get the same error if I click the "Check for an updated license" link or the "License with another Microsoft or organization account". So, I'm currently unable to use Visual Studio 2013. What the heck?!



    Monday, November 9, 2015 12:59 PM

Answers

  • Hi Zarek Marshall,

    Please try open Visual Studio 2013 through Visual Studio Online with following steps. Visual Studio Online will bootstrap Visual Studio and then sign in through the id card in the upper right corner.

    1. If you don't have a Visual Studio Online account, please create a Visual Studio Online account.
    2. Login into Visual Studio Online and create a Team project if you don't have.
    3. Open Visual Studio 2013 and click menu Team -> Connect to Team Foundation Server.
    4. Add your Visual Studio Online account and select a Team project. It will prompted to sign in to the proxy server.
    5. Click on Sign in in the upper right corner.

    If above steps still don't work, I suggest you uninstall and reinstall Visual Studio 2013 again.

    Best Regards,
    Weiwei

    Wednesday, November 11, 2015 3:07 AM
    Moderator

All replies

  • Hi Zarek Marshall,

    Please try run the Developer Command prompt installed with Visual Studio 2013 as administrator and run devenv /resetuserdata command. Then restart Visual Studio 2013 and sign in again.

    In addition, please try Change the Visual Studio proxy settings in C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\devenv.exe.config as below.

    <system.net>
        <defaultProxy useDefaultCredentials="true" enabled="true">
            <proxy usesystemdefault="True" />
        </defaultProxy>
        <settings>
            <ipv6 enabled="true"/>
        </settings>
    </system.net>

    If above steps don't work, please try repair Visual Studio 2013 through Control Panel -> Visual Studio 2013 -> Change -> Repair.

    Best Regards,
    Weiwei

    Tuesday, November 10, 2015 5:03 AM
    Moderator
  • Unfortunately, I've been through *all* of these steps and the problem still exists. I'm unable to use a product that I should be able to use, this is terrible.
    Tuesday, November 10, 2015 11:30 AM
  • Hi Zarek Marshall,

    Please try open Visual Studio 2013 through Visual Studio Online with following steps. Visual Studio Online will bootstrap Visual Studio and then sign in through the id card in the upper right corner.

    1. If you don't have a Visual Studio Online account, please create a Visual Studio Online account.
    2. Login into Visual Studio Online and create a Team project if you don't have.
    3. Open Visual Studio 2013 and click menu Team -> Connect to Team Foundation Server.
    4. Add your Visual Studio Online account and select a Team project. It will prompted to sign in to the proxy server.
    5. Click on Sign in in the upper right corner.

    If above steps still don't work, I suggest you uninstall and reinstall Visual Studio 2013 again.

    Best Regards,
    Weiwei

    Wednesday, November 11, 2015 3:07 AM
    Moderator