none
Does custom 2006 adapter run on 2010? RRS feed

  • Question

  • In the past we developed an Exchange 2007 adapter for our BizTalk 2006 environment.

    Now we're moving to BizTalk 2010 and as far as I know there are no changes in the adapter framework for custom build adapters.

    However, when I run the installer on my BizTalk 2010 box to copy the assemblies and import the registry settings, the drop down in the 'add adapter' dialog only shows the LOB adapters from the adapter pack.

    Is it true that custom adapters from BizTalk 2006 should run on BizTalk 2010 without modifications?

    What steps can I take to fix this?

    Thanks!


    Didago IT Consultancy "Connecting People and Systems Using Microsoft Technology"
    Wednesday, September 21, 2011 9:28 AM

Answers

  • Found it!

    You need to enter the registry keys to both the 32-bit as well as the default 64-bit registry, I found this here:

    http://msdn.microsoft.com/en-us/library/aa578370(v=bts.70).aspx

    But it didn't say the how and what of the 32/64 bit version of the registry editor, this helped a lot:

    http://support.microsoft.com/kb/305097

    So by default you open the 64-bit registry editor (using regedit.exe), and my keys were in there. But since the BizTalk management console is in 32 bit, it reads 32-bit keys from the registry. Obviously this couldn't be found in my case.

    By starting the 32-bit registry editor via "%systemroot%\syswow64\regedit" and importing my key's it worked!


    Didago IT Consultancy "Connecting People and Systems Using Microsoft Technology"
    • Marked as answer by Jean-Paul Smit Wednesday, September 21, 2011 1:32 PM
    Wednesday, September 21, 2011 11:23 AM