none
Urgent, help needed. Does Biztalk 2006 (not R2) sharepoint adapter support WSS 3.0 (MOSS 2007)? RRS feed

  • Question

  • Hi,

    Urgent,  help needed.
    My company uses SharePoint 2007 (WSS 3.0), and also use Biztalk 2006 (not the R2 version).
    Recently there is a proposal to implement a workflow integrates with sharepoint site.

    I did research for days and did not find any information on the topic of Biztalk 2006 SharePoint adapter officially supports the WSS 3.0.   Can someone here verify this?

    Alternatively, if someone successfully configured the biztalk 2006 sharepoint adapter with wss 3.0 , could you please direct me to the resource that I can look at?

    I know the Biztalk R2 works with WSS 3.  but I doubt our company will buy a new license for a Biztalk 2006 R2 or Biztalk 2009, because of the budgets reason.


    Thanks

    Fghxu

    Friday, August 21, 2009 3:06 PM

Answers

  • Yes, the BizTalk 2009 install guide mentions supporting WSS 3 and MOSS 2007 for the WSS adapter. WSS 3 for BAM is not supported. I have used BizTalk 2006 R2 with MOSS 2007 and the WSS adapter successfully. You can send in a document over the WSS adapter and have a workflow kicked off.

    You can look at the BizTalk install guides and just search for WSS in it. Here is the link to the install guide: http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=9c697e02-d1bc-4684-8748-28b3a292d5bf. I checked in the Windows Server 2003 one.

    Thanks,
    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Friday, August 21, 2009 8:30 PM
    Moderator
  • WSS 3.0 is fully supported by BizTalk 2009 except we cannot use it with BAS. Furthermore, so far I haven't seen anybody reported a case that BizTalk 2009 has problem to work with the new released WSSv3 SP2. However since SP2 is quite new, I prefer to recommend you follow the installation guide to use WSSv3 SP1 with BizTalk 2009 currently.

    Thanks.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Monday, August 24, 2009 10:34 AM
    Moderator
  • I found an old BizTalk 2006 [R1] install guide and it only mentions that WSS 2 SP2 is supported, so I do not think it will work with MOSS 2007 or WSS 3.

    FYI, BAS was deprecated with BizTalk 2009.

    Thanks,
    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Monday, August 24, 2009 3:48 PM
    Moderator

All replies

  • Thanks, KiranMP!

    I have looked at this post before, and as it states, this is a personal work around. Microsoft does not officially support this approach at the time it was written (2006).

    So, I wish to know what is the stautus for the biztalk 2006 sharepoint adapter now (2009)?

    I am wondering does anyone use this unsupport approaches on production servers? I saw some people reporting errors on the same link.

    Thanks
    Friday, August 21, 2009 3:38 PM
  • Yes, the BizTalk 2009 install guide mentions supporting WSS 3 and MOSS 2007 for the WSS adapter. WSS 3 for BAM is not supported. I have used BizTalk 2006 R2 with MOSS 2007 and the WSS adapter successfully. You can send in a document over the WSS adapter and have a workflow kicked off.

    You can look at the BizTalk install guides and just search for WSS in it. Here is the link to the install guide: http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=9c697e02-d1bc-4684-8748-28b3a292d5bf. I checked in the Windows Server 2003 one.

    Thanks,
    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Friday, August 21, 2009 8:30 PM
    Moderator
  • WSS 3.0 is fully supported by BizTalk 2009 except we cannot use it with BAS. Furthermore, so far I haven't seen anybody reported a case that BizTalk 2009 has problem to work with the new released WSSv3 SP2. However since SP2 is quite new, I prefer to recommend you follow the installation guide to use WSSv3 SP1 with BizTalk 2009 currently.

    Thanks.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Monday, August 24, 2009 10:34 AM
    Moderator
  • Thanks for everyone's input!  but there is no indication of Biztalk 2006's (the 2006 version) sharepoint adapter will be able to communicate with SharePoint 2007 (or WSS 3.0)


    I know The Biztalk Server's Sharepoint adapter supports WSS 3.0 since the version Biztalk 2006 R2. 

    I would think there is no answer to my questions.

    Thank's again, guys!


    fghxu
    • Edited by Homesicker Monday, August 24, 2009 1:18 PM
    Monday, August 24, 2009 1:14 PM
  • I found an old BizTalk 2006 [R1] install guide and it only mentions that WSS 2 SP2 is supported, so I do not think it will work with MOSS 2007 or WSS 3.

    FYI, BAS was deprecated with BizTalk 2009.

    Thanks,
    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Monday, August 24, 2009 3:48 PM
    Moderator