none
Windows8.1 MDM_EASPolicy throw 404 RRS feed

  • Question

  • Hi guys:

      I set the deviceid as the key value of MDM_EASPolicy. MDM_EASPolicy ever executed successfully. After I reset the password policy in the control pannel, my MDM_EASPolicy always throw the 404 exception.  I want to know how to resolve this problem and how to reset the mdm password policy in the right way.

    request:

    <SyncML xmlns="SYNCML:SYNCML1.2">
    	<SyncHdr>
    		<VerDTD>1.2</VerDTD>
    		<VerProto>DM/1.2</VerProto>
    		<SessionID>1</SessionID>
    		<MsgID>1</MsgID>
    		<Target>
    			<LocURI>01</LocURI>
    		</Target>
    		<Source>
    			<LocURI>http://localhost:8000/handler.ashx</LocURI>
    		</Source>
    	</SyncHdr>
    	<SyncBody>
    		<Status>
    			<CmdID>1</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>0</CmdRef>
    			<Cmd>SyncHdr</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Status>
    			<CmdID>2</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>2</CmdRef>
    			<Cmd>Alert</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Exec>
    			<CmdID>3</CmdID>
    			<Item>
    				<Target>
    					<LocURI>./cimv2/MDM_EASPolicy/MDM_EASPolicy.Key=%2201%22/Exec=SetValues
    					</LocURI>
    				</Target>
    				<Meta>
    					<Format xmlns="syncml:metinf">chr</Format>
    					<Type xmlns="syncml:metinf">text/plain</Type>
    				</Meta>
    				<Data>NamedValuesList=MinPasswordLength,5</Data>
    			</Item>
    		</Exec>
    		<Final />
    	</SyncBody>
    </SyncML>

    response:

    <SyncML xmlns="SYNCML:SYNCML1.2">
    	<SyncHdr>
    		<VerDTD>1.2</VerDTD>
    		<VerProto>DM/1.2</VerProto>
    		<SessionID>1</SessionID>
    		<MsgID>2</MsgID>
    		<Target>
    			<LocURI>http://localhost:8000/handler.ashx</LocURI>
    		</Target>
    		<Source>
    			<LocURI>01</LocURI>
    		</Source>
    	</SyncHdr>
    	<SyncBody>
    		<Status>
    			<CmdID>1</CmdID>
    			<MsgRef>2</MsgRef>
    			<CmdRef>0</CmdRef>
    			<Cmd>SyncHdr</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Status>
    			<CmdID>2</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>1</CmdRef>
    			<Cmd>Status</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Status>
    			<CmdID>3</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>2</CmdRef>
    			<Cmd>Status</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Status>
    			<CmdID>4</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>3</CmdRef>
    			<Cmd>Exec</Cmd>
    			<Data>404</Data>
    		</Status>
    		<Final />
    	</SyncBody>
    </SyncML>

    Monday, August 24, 2015 2:37 AM

Answers

  • Ok... I checked the doc. and Key type is not string but it is Uint32 type.

    So could you try MDM_EASPolicy.key=1   (remove %22) ?

    • Marked as answer by 林毅衡 Wednesday, August 26, 2015 6:06 AM
    • Unmarked as answer by 林毅衡 Wednesday, August 26, 2015 6:42 AM
    • Marked as answer by 林毅衡 Sunday, August 30, 2015 1:30 PM
    Tuesday, August 25, 2015 3:11 AM

All replies

  • Try removing 0 from (only 1 instead of 01)
    =%2201%22
    Monday, August 24, 2015 8:20 AM
  • Thanks for your reply, but I got the same result.

    The request xml:

    <SyncML xmlns="SYNCML:SYNCML1.2">
    	<SyncHdr>
    		<VerDTD>1.2</VerDTD>
    		<VerProto>DM/1.2</VerProto>
    		<SessionID>1</SessionID>
    		<MsgID>1</MsgID>
    		<Target>
    			<LocURI>01</LocURI>
    		</Target>
    		<Source>
    			<LocURI>http://localhost:8000/handler.ashx</LocURI>
    		</Source>
    	</SyncHdr>
    	<SyncBody>
    		<Status>
    			<CmdID>1</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>0</CmdRef>
    			<Cmd>SyncHdr</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Status>
    			<CmdID>2</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>2</CmdRef>
    			<Cmd>Alert</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Exec>
    			<CmdID>3</CmdID>
    			<Item>
    				<Target>
    					<LocURI>./cimv2/MDM_EASPolicy/MDM_EASPolicy.Key=%221%22/Exec=SetValues
    					</LocURI>
    				</Target>
    				<Meta>
    					<Format xmlns="syncml:metinf">chr</Format>
    					<Type xmlns="syncml:metinf">text/plain</Type>
    				</Meta>
    				<Data>NamedValuesList=MinPasswordLength,5</Data>
    			</Item>
    		</Exec>
    		<Final />
    	</SyncBody>
    </SyncML>

    the response xml:

    <SyncML xmlns="SYNCML:SYNCML1.2">
    	<SyncHdr>
    		<VerDTD>1.2</VerDTD>
    		<VerProto>DM/1.2</VerProto>
    		<SessionID>1</SessionID>
    		<MsgID>2</MsgID>
    		<Target>
    			<LocURI>http://localhost:8000/handler.ashx</LocURI>
    		</Target>
    		<Source>
    			<LocURI>01</LocURI>
    		</Source>
    	</SyncHdr>
    	<SyncBody>
    		<Status>
    			<CmdID>1</CmdID>
    			<MsgRef>2</MsgRef>
    			<CmdRef>0</CmdRef>
    			<Cmd>SyncHdr</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Status>
    			<CmdID>2</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>1</CmdRef>
    			<Cmd>Status</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Status>
    			<CmdID>3</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>2</CmdRef>
    			<Cmd>Status</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Status>
    			<CmdID>4</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>3</CmdRef>
    			<Cmd>Exec</Cmd>
    			<Data>404</Data>
    		</Status>
    		<Final />
    	</SyncBody>
    </SyncML>

    Tuesday, August 25, 2015 2:03 AM
  • Can you try one more thing ?  Try with K -> k (small)

    MDM_EASPolicy.Key

    Tuesday, August 25, 2015 2:09 AM
  • Thanks, but I got the same result.

    request:

    <SyncML xmlns="SYNCML:SYNCML1.2">
    	<SyncHdr>
    		<VerDTD>1.2</VerDTD>
    		<VerProto>DM/1.2</VerProto>
    		<SessionID>1</SessionID>
    		<MsgID>1</MsgID>
    		<Target>
    			<LocURI>01</LocURI>
    		</Target>
    		<Source>
    			<LocURI>http://localhost:8000/handler.ashx</LocURI>
    		</Source>
    	</SyncHdr>
    	<SyncBody>
    		<Status>
    			<CmdID>1</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>0</CmdRef>
    			<Cmd>SyncHdr</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Status>
    			<CmdID>2</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>2</CmdRef>
    			<Cmd>Alert</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Exec>
    			<CmdID>3</CmdID>
    			<Item>
    				<Target>
    					<LocURI>./cimv2/MDM_EASPolicy/MDM_EASPolicy.key=%221%22/Exec=SetValues
    					</LocURI>
    				</Target>
    				<Meta>
    					<Format xmlns="syncml:metinf">chr</Format>
    					<Type xmlns="syncml:metinf">text/plain</Type>
    				</Meta>
    				<Data>NamedValuesList=MinPasswordLength,5</Data>
    			</Item>
    		</Exec>
    		<Final />
    	</SyncBody>
    </SyncML>

    response:

    <SyncML xmlns="SYNCML:SYNCML1.2">
    	<SyncHdr>
    		<VerDTD>1.2</VerDTD>
    		<VerProto>DM/1.2</VerProto>
    		<SessionID>1</SessionID>
    		<MsgID>2</MsgID>
    		<Target>
    			<LocURI>http://localhost:8000/handler.ashx</LocURI>
    		</Target>
    		<Source>
    			<LocURI>01</LocURI>
    		</Source>
    	</SyncHdr>
    	<SyncBody>
    		<Status>
    			<CmdID>1</CmdID>
    			<MsgRef>2</MsgRef>
    			<CmdRef>0</CmdRef>
    			<Cmd>SyncHdr</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Status>
    			<CmdID>2</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>1</CmdRef>
    			<Cmd>Status</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Status>
    			<CmdID>3</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>2</CmdRef>
    			<Cmd>Status</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Status>
    			<CmdID>4</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>3</CmdRef>
    			<Cmd>Exec</Cmd>
    			<Data>404</Data>
    		</Status>
    		<Final />
    	</SyncBody>
    </SyncML>

    Tuesday, August 25, 2015 2:56 AM
  • Thanks, but I got the same result.

    request:

    <SyncML xmlns="SYNCML:SYNCML1.2">
    	<SyncHdr>
    		<VerDTD>1.2</VerDTD>
    		<VerProto>DM/1.2</VerProto>
    		<SessionID>1</SessionID>
    		<MsgID>1</MsgID>
    		<Target>
    			<LocURI>01</LocURI>
    		</Target>
    		<Source>
    			<LocURI>http://localhost:8000/handler.ashx</LocURI>
    		</Source>
    	</SyncHdr>
    	<SyncBody>
    		<Status>
    			<CmdID>1</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>0</CmdRef>
    			<Cmd>SyncHdr</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Status>
    			<CmdID>2</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>2</CmdRef>
    			<Cmd>Alert</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Exec>
    			<CmdID>3</CmdID>
    			<Item>
    				<Target>
    					<LocURI>./cimv2/MDM_EASPolicy/MDM_EASPolicy.key=%221%22/Exec=SetValues
    					</LocURI>
    				</Target>
    				<Meta>
    					<Format xmlns="syncml:metinf">chr</Format>
    					<Type xmlns="syncml:metinf">text/plain</Type>
    				</Meta>
    				<Data>NamedValuesList=MinPasswordLength,5</Data>
    			</Item>
    		</Exec>
    		<Final />
    	</SyncBody>
    </SyncML>

    response:

    <SyncML xmlns="SYNCML:SYNCML1.2">
    	<SyncHdr>
    		<VerDTD>1.2</VerDTD>
    		<VerProto>DM/1.2</VerProto>
    		<SessionID>1</SessionID>
    		<MsgID>2</MsgID>
    		<Target>
    			<LocURI>http://localhost:8000/handler.ashx</LocURI>
    		</Target>
    		<Source>
    			<LocURI>01</LocURI>
    		</Source>
    	</SyncHdr>
    	<SyncBody>
    		<Status>
    			<CmdID>1</CmdID>
    			<MsgRef>2</MsgRef>
    			<CmdRef>0</CmdRef>
    			<Cmd>SyncHdr</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Status>
    			<CmdID>2</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>1</CmdRef>
    			<Cmd>Status</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Status>
    			<CmdID>3</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>2</CmdRef>
    			<Cmd>Status</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Status>
    			<CmdID>4</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>3</CmdRef>
    			<Cmd>Exec</Cmd>
    			<Data>404</Data>
    		</Status>
    		<Final />
    	</SyncBody>
    </SyncML>

    Tuesday, August 25, 2015 2:56 AM
  • Ok... I checked the doc. and Key type is not string but it is Uint32 type.

    So could you try MDM_EASPolicy.key=1   (remove %22) ?

    • Marked as answer by 林毅衡 Wednesday, August 26, 2015 6:06 AM
    • Unmarked as answer by 林毅衡 Wednesday, August 26, 2015 6:42 AM
    • Marked as answer by 林毅衡 Sunday, August 30, 2015 1:30 PM
    Tuesday, August 25, 2015 3:11 AM
  • Hi Biz_M:

       Now, my laptop works fine on setting password policy. My surface pro3 always return 500. I am not sure whether Surface Pro 3 not support MDM_EASPolicy.

    response to surface:

    <SyncML xmlns="SYNCML:SYNCML1.2">
    	<SyncHdr>
    		<VerDTD>1.2</VerDTD>
    		<VerProto>DM/1.2</VerProto>
    		<SessionID>1</SessionID>
    		<MsgID>1</MsgID>
    		<Target>
    			<LocURI>01</LocURI>
    		</Target>
    		<Source>
    			<LocURI>http://localhost:8000/handler.ashx</LocURI>
    		</Source>
    	</SyncHdr>
    	<SyncBody>
    		<Status>
    			<CmdID>1</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>0</CmdRef>
    			<Cmd>SyncHdr</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Status>
    			<CmdID>2</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>2</CmdRef>
    			<Cmd>Alert</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Exec>
    			<CmdID>3</CmdID>
    			<Item>
    				<Target>
    					<LocURI>./cimv2/MDM_EASPolicy/MDM_EASPolicy.Key=1/Exec=SetValues
    					</LocURI>
    				</Target>
    				<Meta>
    					<Format xmlns="syncml:metinf">chr</Format>
    					<Type xmlns="syncml:metinf">text/plain</Type>
    				</Meta>
    				<Data>NamedValuesList=MinPasswordLength,7</Data>
    			</Item>
    		</Exec>
    		<Final />
    	</SyncBody>
    </SyncML>

    surface request:

    <SyncML xmlns="SYNCML:SYNCML1.2">
    	<SyncHdr>
    		<VerDTD>1.2</VerDTD>
    		<VerProto>DM/1.2</VerProto>
    		<SessionID>1</SessionID>
    		<MsgID>2</MsgID>
    		<Target>
    			<LocURI>http://localhost:8000/handler.ashx</LocURI>
    		</Target>
    		<Source>
    			<LocURI>01</LocURI>
    		</Source>
    	</SyncHdr>
    	<SyncBody>
    		<Status>
    			<CmdID>1</CmdID>
    			<MsgRef>2</MsgRef>
    			<CmdRef>0</CmdRef>
    			<Cmd>SyncHdr</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Status>
    			<CmdID>2</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>1</CmdRef>
    			<Cmd>Status</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Status>
    			<CmdID>3</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>2</CmdRef>
    			<Cmd>Status</Cmd>
    			<Data>200</Data>
    		</Status>
    		<Status>
    			<CmdID>4</CmdID>
    			<MsgRef>1</MsgRef>
    			<CmdRef>3</CmdRef>
    			<Cmd>Exec</Cmd>
    			<Data>500</Data>
    		</Status>
    		<Final />
    	</SyncBody>
    </SyncML>

    Wednesday, August 26, 2015 6:42 AM
  • What is your current password's length in Surface Pro ?
    Wednesday, August 26, 2015 6:50 AM
  • Hi Biz_M:

    My current password length of My Surface Pro3 is three and the password is "123". My surface's current policy may be the default policy, Because I reset the security policy in cotrol pannel->user account and home security -> user account -> reset security policy.


    • Edited by 林毅衡 Wednesday, August 26, 2015 7:40 AM
    Wednesday, August 26, 2015 7:39 AM