locked
Error building web deployment project. RRS feed

  • Question

  • User-359574157 posted

     Hi all,

    Im creating a web deployment project for a website I'm working on. I followed the instructions i found on the MSDN. I haven't made any customization to the build process but I get the following error when I try to do the build.

     Task "ToggleDebugCompilation"

    Updateing web.config compilation debug = 'True' ...

    C:\Program Files\MSBuild\Microsoft\WebDeployment\v8.0\Microsoft.WebDeployment.targets(442,9): error : Unable to save config to file 'C:\....\QA\web.config'.

    C:\Program Files\MSBuild\Microsoft\WebDeployment\v8.0\Microsoft.WebDeployment.targets(442,9): error MSB4018: The "ToggleDebugCompilation" task failed unexpectedly.

    C:\Program Files\MSBuild\Microsoft\WebDeployment\v8.0\Microsoft.WebDeployment.targets(442,9): error MSB4018: System.ArgumentNullException: Parameter "message" cannot be null.

    C:\Program Files\MSBuild\Microsoft\WebDeployment\v8.0\Microsoft.WebDeployment.targets(442,9): error MSB4018: at Microsoft.Build.Shared.ErrorUtilities.VerifyThrowArgumentNull(Object parameter, String parameterName)

    C:\Program Files\MSBuild\Microsoft\WebDeployment\v8.0\Microsoft.WebDeployment.targets(442,9): error MSB4018: at Microsoft.Build.Utilities.TaskLoggingHelper.LogMessage(MessageImportance importance, String message, Object[] messageArgs)

    C:\Program Files\MSBuild\Microsoft\WebDeployment\v8.0\Microsoft.WebDeployment.targets(442,9): error MSB4018: at Microsoft.WebDeployment.Tasks.ToggleDebugCompilation.Execute()

    C:\Program Files\MSBuild\Microsoft\WebDeployment\v8.0\Microsoft.WebDeployment.targets(442,9): error MSB4018: at Microsoft.Build.BuildEngine.TaskEngine.ExecuteTask(ExecutionMode howToExecuteTask, Hashtable projectItemsAvailableToTask, BuildPropertyGroup projectPropertiesAvailableToTask, Boolean& taskClassWasFound)

    Done executing task "ToggleDebugCompilation" -- FAILED.

    Any idea as to what Im doing wrong?

    Any help wold be greatly appreciated. 

    -Satish. 

    Monday, May 28, 2007 8:56 PM

All replies

  • User-233570146 posted

    You need to make sure that your ASPNET user account has permission to write that file - it's probably being denied access.

    Tuesday, May 29, 2007 3:17 AM
  • User-359574157 posted

    I added the aspnet user account to the administrator group and still getting the same error. 

    Tuesday, May 29, 2007 11:23 AM
  • User-233570146 posted

    I would check the specific permission (read and write) on the 'C:\....\QA\web.config' file - rather than add ASPNET to the administration group.

    Wednesday, May 30, 2007 3:18 AM