none
Bing Map Problem in windows store apps RRS feed

  • Question

  • Hello everyone,

    I am new in bing map,I am trying to implement bing map in my app. But the problem is it shows me only white page. I am create key of bing map (basic & trial for windows store). But the problem is same.So what i am do?

    Here is the image:

    And i am create both key (trial,basic) without ApplicationURL. I am using vs2012 pro.

    Tuesday, July 30, 2013 10:33 AM

Answers

  • Hi Khant,

    It seems as you see blank map because your region is not supported.  You can see details at A list of supported regions and Support for India Region. This is a bug that we show blank map instead of image (with stop sign), which we will investigate.

    To workaround, you can set Home region to supported region like US.  In xaml, set HomeRegion and Culture properties for Map like below.

    <bm:Map HomeRegion="US" Culture="en-US"
    Once you update, you have to restart your app twice (the first time you see the same issue but from the second time, you should see English map).
    • Marked as answer by Khant Nipun Thursday, August 8, 2013 6:09 AM
    • Unmarked as answer by Khant Nipun Thursday, August 8, 2013 11:12 AM
    • Marked as answer by Khant Nipun Thursday, August 8, 2013 11:27 AM
    Wednesday, August 7, 2013 6:25 PM

All replies

  • I haven't seen the keys image in the corner before. Are you using the Bing Maps Windows 8 or 8.1 map control? The Windows 8.1 map control can only be used in Visual Studios 2013.

    http://rbrundritt.wordpress.com

    Tuesday, July 30, 2013 10:34 AM
  • I am using bing maps for windows 8.

    I am download sdk from:

    http://visualstudiogallery.msdn.microsoft.com/ebc98390-5320-4088-a2b5-8f276e4530f9

    Tuesday, July 30, 2013 10:39 AM
  • Very odd. When the Windows 8 version does not load with proper credentials it has an error message across the map. The Windows 8.1 control says beta under the Bing logo so I suspect you are using the correct Bing Maps control. A couple of questions:

    Are you using JavaScript or .NET (C# or VB)?

    If using .NET have you added a reference to the C++ runtime?

    If using .NET have you changed the configuration manager from Any CPU to x86, or x64?


    http://rbrundritt.wordpress.com

    Tuesday, July 30, 2013 11:33 AM
  • Hello Ricky,

    thanks for reply. I am using c#. I am add both file Bing Maps for C#, C++, or Visual Basic & Microsoft Visual C++ Runtime Package in my application. I am also change configuration manager to x64. But the problem is same as early. My Bing Maps for C#, C++, or Visual Basic is 1.113.601.1.

    • Edited by Khant Nipun Tuesday, July 30, 2013 12:20 PM
    Tuesday, July 30, 2013 11:45 AM
  • Ok, I'll ping someone on our Bing Maps Windows 8 team to look into this.

    http://rbrundritt.wordpress.com

    Tuesday, July 30, 2013 1:35 PM
  • Ok Ricky, Thanks for your help. It is for key problem? If this i am create & use both key (basic,trial).

    This is my code:

    <Grid Width="1024" Height="768" Background="{StaticResource ApplicationPageBackgroundThemeBrush}">
            <bm:Map HorizontalAlignment="Left" Width="1000" Height="700" Credentials="My_Key" MapType="Aerial" ZoomLevel="16">
                <bm:Map.Center>
                    <bm:Location Latitude="37.806029" Longitude="-122.407007"/>
                </bm:Map.Center>
            </bm:Map>
             </Grid>

    • Edited by Khant Nipun Wednesday, July 31, 2013 5:01 AM
    Wednesday, July 31, 2013 4:09 AM
  • I don't think it is the key, but if you email them to me at ricky_brundritt at Hotmail.com I can do some tests to verify they are fine.

    http://rbrundritt.wordpress.com

    Wednesday, July 31, 2013 10:10 AM
  • Do you still see this issue?  In screenshot, Navigation bar show Road map style but your code in xaml map style is set to Aerial.  Do you have additional code in CS file?   Can you replace your <bm:Map/> tag with below (do not replace credentials with your credentials. leave as is).

    <Grid Width="1024" Height="768" Background="{StaticResource ApplicationPageBackgroundThemeBrush}">
       <bm:Map Credentials="A"/>
    </Grid>

    If you don't see invalid credentials error, it could be network issue. 

    Tuesday, August 6, 2013 12:44 AM
  • Yes i am still see this issue. I tried that but the result is same. I hope that issue could be network related.
    Tuesday, August 6, 2013 4:11 AM
  • I could repro similar issue when change region setting.  Could you let me know what is home region on your system (to check current region, open control panel, select clock, languages, and region, then check Location tab in Region)?

    Tuesday, August 6, 2013 6:01 PM
  • Hello Kazuko,

    My Home Region is India.

    Wednesday, August 7, 2013 4:05 AM
  • Hi Khant,

    It seems as you see blank map because your region is not supported.  You can see details at A list of supported regions and Support for India Region. This is a bug that we show blank map instead of image (with stop sign), which we will investigate.

    To workaround, you can set Home region to supported region like US.  In xaml, set HomeRegion and Culture properties for Map like below.

    <bm:Map HomeRegion="US" Culture="en-US"
    Once you update, you have to restart your app twice (the first time you see the same issue but from the second time, you should see English map).
    • Marked as answer by Khant Nipun Thursday, August 8, 2013 6:09 AM
    • Unmarked as answer by Khant Nipun Thursday, August 8, 2013 11:12 AM
    • Marked as answer by Khant Nipun Thursday, August 8, 2013 11:27 AM
    Wednesday, August 7, 2013 6:25 PM
  • Hello Kazuko,

    Thanks for reply, I tried that property & my problem is solved.



    • Edited by Khant Nipun Thursday, August 8, 2013 11:28 AM
    Thursday, August 8, 2013 6:09 AM