none
Intellisense not working in CS interactive

    Question

  • With Update 1 of VS2015, I have the new C# Interactive window--I'm not, however, seeing intellisense completions when I enter statements, expressions or #-statements. Any instructions on how to turn that on?
    Sunday, December 20, 2015 11:08 AM

Answers

  • Thanks for [Kamlesh Kumar]'s help.

    Hi dhendricks,

    >>this is the new C# Interactive window which isn't working.

    Could you share me a screen shot about your test result? For example, I test it in my side using the simple "#", it works well in my side using the VS2015 Enterprise version with update 1 on my windows 10 machine.

    So it works well in my side, as you said that if it doesn't work in your side, maybe we would think about the VS IDE Environment.

    (1) Please reset your VS settings:

    TOOLS->Import and Export Settings Wizard->Reset all settings->select “No, just reset settings, overwriting my current settings”->Choose a Default Collection of settings. Check it again. Hope it could help.

    (2) If still no help, please repair your VS, and then re-open your VS, check the result. 

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Tuesday, December 22, 2015 9:34 AM
    Moderator

All replies

  • Hi,

    Thank you for posting in MSDN forum.

    If only one file/window appears to be affected, close/reopen that file. If that doesn't work, try below.

    In Visual Studio:

    1. Click Tools->Options->Text Editor->All Languages->General
    2. Uncheck "Auto list members"
    3. Uncheck "Parameter information"
    4. Check "Auto list members" (yes, the one you just unchecked)
    5. Check "Parameter information" (again, the one you just unchecked)
    6. Click OK

    If this doesn't work, here's a few more steps to try:

    1. Close all VS documents and reopen
    2. If still not working, close/reopen solution
    3. If still not working, restart VS.

    For C++ projects:
    MSDN has a few things to try: MSDN suggestions

    The corrupt .ncb file seems most likely.

    From MSDN:

    1. Close the solution.
    2. Delete the .ncb file.
    3. Reopen the solution. (This creates a new .ncb file.)

    Notes:

    • Tested in VS 2013/2015

    Logging possible causes:

    • Copy/pasting controls in a source page. I found that my designer.vb file didn't update from this, either.
    • Copy/pasting code from another page that caused an error because the code copied referred to a control that wasn't on the page I was pasting to.
    • C++ project has corrupt .ncb file

    Reference: http://stackoverflow.com/questions/13982526/why-does-intellisense-and-code-suggestion-stop-working-when-visual-studio-is-ope


    Thanks,

    If my reply is helpful please mark as Answer or vote as Helpful.

    My blog | Twitter | LinkedIn

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Monday, December 21, 2015 7:20 AM
  • Hi, thanks.  Tried this but it didn't work for me.  Keep in mind that Intellisense is working fine for C# editor windows--this is the new C# Interactive window which isn't working.
    Monday, December 21, 2015 11:26 PM
  • Thanks for [Kamlesh Kumar]'s help.

    Hi dhendricks,

    >>this is the new C# Interactive window which isn't working.

    Could you share me a screen shot about your test result? For example, I test it in my side using the simple "#", it works well in my side using the VS2015 Enterprise version with update 1 on my windows 10 machine.

    So it works well in my side, as you said that if it doesn't work in your side, maybe we would think about the VS IDE Environment.

    (1) Please reset your VS settings:

    TOOLS->Import and Export Settings Wizard->Reset all settings->select “No, just reset settings, overwriting my current settings”->Choose a Default Collection of settings. Check it again. Hope it could help.

    (2) If still no help, please repair your VS, and then re-open your VS, check the result. 

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Tuesday, December 22, 2015 9:34 AM
    Moderator
  • I'll soon try your suggestions.  Here, however, is a picture of the current situation.  Neither the script commands or std code expansion show up.  After I've reset everything I'll report back.

    Wednesday, December 23, 2015 3:36 AM
  • Hi dhendricks,

    I look forward to hearing from you:)

    If you get any latest information, please feel free to let me know.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, December 23, 2015 6:19 AM
    Moderator
  • As you suggested, reinitializing the VS settings fixed the problem.  Thanks for your help.

    Wednesday, December 23, 2015 10:38 PM