locked
Trying to get PDO_SQLSRV working on a 2003R2 box RRS feed

  • Question

  • I seem stuck in a loop I can not get out of.

    We have a Windows Server 2003R2 server running IIS V6.0. I know it is old, I know it has issues, but I am stuck with it and I do not see it being upgraded anytime in the near future. They have some applications running on the server that work, but they do not have any idea how and why they work, they just work and they want to keep it that way. The scope of my work does not include gaining an understanding of this application and upgrading them to newer server version.

    Here is the issue.

      • I downloaded the SQL drivers for PHP V3.0.
      • V3.0 requires the SQL Server 2012 native client which won't load on 2003.
      • I see that I could load the SQL Drivers for PHP V2.0.
      • V2.0 requires the SQL Server 2008 native client... which I have loaded.

    The problem is I can't find the V2 of the PHP drivers. Every V2 link I have found redirects me to V3. I need a way to either load the 2012 native client on 2003r2 or find a site where the V2 drivers are located.

    Thanks

    Wednesday, September 19, 2012 3:35 PM

Answers

  • Hi wava-

    There is a link for the 2.0 driver on this page: http://php.net/manual/en/ref.pdo-sqlsrv.php. Let us know if using the 2.0 driver doesn't work.

    Thanks.

    -Brian


    This posting is provided "AS IS" with no warranties, and confers no rights. http://blogs.msdn.com/brian_swan

    • Marked as answer by wava Wednesday, September 19, 2012 5:28 PM
    Wednesday, September 19, 2012 4:08 PM

All replies

  • Hi wava-

    There is a link for the 2.0 driver on this page: http://php.net/manual/en/ref.pdo-sqlsrv.php. Let us know if using the 2.0 driver doesn't work.

    Thanks.

    -Brian


    This posting is provided "AS IS" with no warranties, and confers no rights. http://blogs.msdn.com/brian_swan

    • Marked as answer by wava Wednesday, September 19, 2012 5:28 PM
    Wednesday, September 19, 2012 4:08 PM
  • We are working on deprecating support for the 2.0 driver. You can still find the download located at the following link, but this will eventually go away:
    http://download.microsoft.com/download/C/D/B/CDB0A3BB-600E-42ED-8D5E-E4630C905371/SQLSRV20.EXE

    Cheers,

    Jonathan


    This posting is provided 'AS IS' with no warranties, and confers no rights.

    Monday, September 24, 2012 8:39 PM
  • You can also use Robert's modified version of the PHP 3.0 driver which allows you to select the SQL Server Native Client, but please keep in mind that this is not supported by Microsoft:

    http://social.msdn.microsoft.com/Forums/en-US/sqldriverforphp/thread/52549866-649a-4aa4-938b-e964c18fbccc/

    Cheers,

    Jonathan


    This posting is provided 'AS IS' with no warranties, and confers no rights.

    Monday, September 24, 2012 9:56 PM