none
IIS Application Pool - Error RRS feed

  • Question

  • Hi Team,

    We are sometimes facing one issue in Production server. We are not able to open the page and we get "System.Runtime.InteropServices.COMException" error. This is resolved after restarting the IIS application pool. But again the issue occurs after sometime.  There is no such issue in development server.  Code is same in both Dev and Prod environments . We have used Visual studio 2010  and WCF for development.Please suggest.



    Seema Thakur

    Wednesday, September 23, 2015 7:31 AM

Answers

All replies

  • Please go through below link, it i already fixed

    https://support.microsoft.com/en-us/kb/973746

    Cheers

    Dinesh

    • Proposed as answer by Dinesh Gabhane Wednesday, September 23, 2015 7:49 AM
    Wednesday, September 23, 2015 7:49 AM
  • Hi seema.thakur,

    According to your description, I guess that is a time out issue.

    So, from my experience, I suggest you can set the maxtimeout in the

    machine config file. Open the Config folder :C:\Windows\Microsoft.NET\Framework\v4.0.30319\Config

    Config it, like below:

    <system.transactions>
    
       <machineSettings maxTimeout="01:00:00" />
    
     </system.transactions>

    For more information, please refer to the following articles:

    Accessing windows application through WCF service under IIS

    I hope that will be helpful to you.

    Best Regards,

    Grady

    Thursday, September 24, 2015 2:02 AM
    Moderator
  • Hi,

    I also suggest that you can enable Failed Request Tracing in IIS or check event log to narrow down the issue. And If the working time is above 1 day, I think you can consider setting IIS application pool recycle to resolve the issue.

    # why to choose ‘Recycling AppPool’

    https://fullsocrates.wordpress.com/2012/07/25/iisreset-vs-recycling-application-pools/

    Thursday, September 24, 2015 2:13 AM
  • Hi All,


    Thanks for the reply. We found that the We are not able to open the page and we get "System.Runtime.InteropServices.COMException" error, when a batch job is running. Actually we have a batch job which reads data from database ( around 10k records). When this bach job is run, we are not able to open any page from my application. Once we restart the application pool, the page starts working Please suggest.

    Regards,

    Seema Thakur.


    Seema Thakur

    Tuesday, October 6, 2015 1:44 AM