locked
Windows 10 IIS Express HTTP/1.1 New Application Failed RRS feed

  • Question

  • User-749939588 posted

    Trying to get Classic ASP to work in Windows 10.  IIS Manager says IIS, but I'm sure I have IIS Express.   Windows 10 IIS 10.0.10586.0   

    Followed Youtube:  @Microsoft @Windows 10 Lesson 7 - Installing and Configuring #IIS Web Hosting.  Enabled:
    .Net Framework 3.5 and 4.6 (already enabled)
    Extensibility 3.5 and 4.6
    ASP 
    ISAPI Extensions, ISAPI Filters
    ASP.Net 3.5 , 4.6  

    Using Default Web Site wwwroot,  
    Set IIS Manager setting:  
    1) Send errors to browser = True, enable client-side and server-side debugging = true
    C:\inetpub\wwwroot\web.config =
    <httpErrors errorMode="Detailed" />
    <asp appAllowClientDebug="true" appAllowDebugging="false" scriptErrorSentToBrowser="true" />

    2) Set AppPool to:  classic .net apppool

    Changed:
    C:\Program Files\IIS Express\AppServer\applicationhost.config
    <sectionGroup name="system.webServer">
    <section name="asp" overrideModeDefault="Allow" />

    Restarted IIS at top level, restarted Default Web Site (just to be sure).

    HTTP extension works,  ASP extension gets:   HTTP/1.1 New Application Failed
    on this file:
    <html>
    <head>
    <title>ASP HTML works</title>
    </head>

    C:\inetpub\wwwroot\web.config is:

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
    <system.webServer>
    <defaultDocument>
    <files>
    <clear />
    <clear />
    <add value="default.asp" />
    <add value="default.htm" />
    <add value="index.htm" />
    <add value="default.aspx" />
    <add value="index.html" />
    <add value="index.asp" />
    <add value="index.php" />
    </files>
    </defaultDocument>
    <httpErrors errorMode="Detailed" />
    <asp appAllowClientDebug="true" appAllowDebugging="false" scriptErrorSentToBrowser="true" />
    </system.webServer>
    </configuration>

     

    Thursday, May 19, 2016 8:45 PM

All replies

  • User1278090636 posted

    Hi,

    Have you tried the steps in the following link?

    https://support.microsoft.com/en-us/kb/210842

    And please check C:\Program Files\IIS Express\config\templates\PersonalWebServer\applicationhost.config

    Best Regards,

    Jean

    Friday, May 20, 2016 2:04 AM
  • User-749939588 posted

    I'm on Windows 10, IIS 10.0.10586.0
    Everything seems to be totally different than this link.

    Quick question:
    I am just a PC, My “computer name” and “full computer name” are the same. So I take it that “<domain>\<computer_name>$” would just be “mycomputername” with no backslash and no “$”.

    <<Link says:
    The IUSR account is a domain account. However, this account is not being authenticated correctly against a domain controller. >>

    <<Instructions at link:
    Open the properties of the Default Web Site and choose Directory Security.
    Click the Edit button for Authentication.
    Click the Edit button for Anonymous and edit the account listed to read "Domain-name\Anonymous."
    Disable Password Synchronization.>>

    Closest thing I can think of to instructions is:
    Double-click Default Web Site
    Double-click Authentication
    Click Anonymous Authentication, Click Edit
    Application Pool Identity is selected

    * No account is listed (you can create one but it must have a
    password) Using Anonymous or mycomputername\Anonymous gives:
    The specified user name does not exist.”

    IUSR/no password = bad Authentication and Authorization – see below

    * No options (like “Disable...” above are shown)

    Looking around, I find:
    Authentication >> Basic Settings >> <Connect As> button
    this shows the same dialog as previous Edit step

    There is also: <Test Settings> button which gives:
    Authentication (green check mark):
    >>> The application pool identity is valid.

    Authorization (yellow exclamation point):
    >>The server is configured to use pass-through authentication with a built-in account to access the specified physical path. However, IIS Manager cannot verify whether the built-in account has access. Make sure that the application pool identity has Read access to the physical path. If this server is joined to a domain, and the application pool identity is NetworkService or LocalSystem, verify that <domain>\<computer_name>$ has Read access to the physical path. Then test these settings again.
    <<<

    Default Web Site>> Authentication>> Edit Permissions
    only shows Groups, no Users.

    Like: Users and IIS_IUSRS – both have Read and Execute for object: C:\inetpub\wwwroot

    What do I do next?
    How do I know what User is used for the pass-through Authentication?
    How do I see Users like IUSR or mycomputername?

    Wednesday, June 8, 2016 8:21 PM
  • User1278090636 posted

    Hi,

    What do I do next?

    Please set the Anonymous Authentication identity to your local account or use the Application Pool Identity(when you set your application pool identity with your local account).

    How do I know what User is used for the pass-through Authentication?

    With pass-through authentication, it uses the authenticated user. That will either be the anonymous user, the application pool identity, or the passed credentials if using basic or integrated auth.

    http://technet.microsoft.com/en-us/library/cc730708(WS.10).aspx

    How do I see Users like IUSR or mycomputername?

    The IUSER is a build-in user, you can think of it as being the same as the NETWORKSERVICE or LOCALSERVICE accounts.

    http://www.iis.net/learn/get-started/planning-for-security/understanding-built-in-user-and-group-accounts-in-iis

    Best Regards,

    Jean

    Thursday, June 9, 2016 8:24 AM
  • User-749939588 posted

    Still getting same error after changing and restarting IIS and WebSite:              HTTP/1.1 New Application Failed
    Same file with .html gets a trace because it can't recognize the asp code in the page. That seems normal.

    IIS Manager
    Top Level – I set Anonymous Authentication (Enabled) to “myusername” with my password

    In Default Web Site
    - Did the same as above
    Basic Settings – set “Connect As” to “myusername” with my password
    Test Settings Button gives:
    Authentication and Authorization are both GREEN – better than before !!!
    Messages are:
    The specified user credentials are valid.
    The specified user credentials are authorized to access the specified physical path.

    Using “Classic .Net AppPool”
    Applicationhost.config:
    <security>
      <authentication>
        <anonymousAuthentication enabled="true" userName="" />             ?? Blank a problem??

    These Denys mean anything ??
    <sectionGroup name="security"> ...
      <sectionGroup name="authentication">
        <section name="anonymousAuthentication" overrideModeDefault="Deny" />
        <section name="basicAuthentication" overrideModeDefault="Deny" /> ...
        <section name="windowsAuthentication" overrideModeDefault="Deny" />

    What next?

    Thursday, June 9, 2016 10:39 PM
  • User-749939588 posted

    And please check C:\Program Files\IIS Express\config\templates\PersonalWebServer\applicationhost.config

    What should I be looking for?  I quote a couple of pertinent sections in the main thread.  What do I need to have / not have?

    Thursday, June 16, 2016 7:35 PM
  • User1278090636 posted

    Hi,

    Find you IIS Express applicationhost.config and find the line:

    <section name="asp" overrideModeDefault="Deny" />

    Change Deny to Allow.

    Best Regards,

    Jean

    Friday, June 17, 2016 8:07 AM