none
Console Application not running when scheduled RRS feed

  • Question

  • Hi,
        I have .NET console application scheduled to run every minute. When am logged in to the system, the console application is running fine, but when i log off the application is not working.

    Any help would be appreciated.

    Thanks
    Roopesh
    Roopesh
    Thursday, August 14, 2008 8:17 PM

Answers

  • I'm not sure what you're going to do, but you can consider building a Windows Service instead of console app.

    Thanks.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Marked as answer by Roopesh Kumar Tuesday, December 15, 2009 5:11 PM
    Monday, August 18, 2008 3:42 AM
  • Move to Windows Service and solved the issue.

    Thanks
    Roopesh
    • Marked as answer by Roopesh Kumar Tuesday, December 15, 2009 5:11 PM
    Tuesday, December 15, 2009 5:11 PM

All replies

  • I'm not sure what you're going to do, but you can consider building a Windows Service instead of console app.

    Thanks.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Marked as answer by Roopesh Kumar Tuesday, December 15, 2009 5:11 PM
    Monday, August 18, 2008 3:42 AM
  • It's out of my scope. The app. was built and running for couple of months.I did gave the suggestion to move to windows service application, but the client doesn't want to change the existing app. Where as about the application, the app. triggers emails to subscribed customers if there is any change in the weather rain fall.So the app. is scheduled to run every minute to check the weather. I have scheduled the appl. to run every minute and expired never. I have created a user under admin account to run the application even when logged off. Unfortunately the application doesn't pop up when logged off. I did check in the local security policy, the user account which is being used to schedule was under service account also.How i can say that the application is not running is, when ever the application pops up, i'm logging the time to text file. When i log off from the server, there is no time logged in the text file.I have no clue why it's not being poped up. Currently network admin is using the one of the service account to schedule it for time being, and it's running. When i created a new user it is not working.

    Any help is appreciated.

    Thanks


    Roopesh
    Monday, August 18, 2008 2:28 PM
  • Hi,
           I have found this error in my log files

    The attempt to retrieve account information for the specified task failed; therefore, the task did not run. Either an error

    occurred, or no account information existed for the task. The specific error is: 0x8004130f: No account information could be found in the Task Scheduler security database for the task indicated.

    My Server Windows server 2003.

    I guess there should be hotfix for windows 2000 server. But i don't find any hotfix for windows 2003 server.

    Any help pls..


    Roopesh
    Monday, August 18, 2008 8:59 PM
  • Try resetting the .profsetlig to default to =null
    Tuesday, August 19, 2008 2:53 AM
  • Hi Steve,
            Where can i find this setting?

    Thanks
    Roopesh
    Roopesh
    Tuesday, August 19, 2008 4:50 PM
  • Move to Windows Service and solved the issue.

    Thanks
    Roopesh
    • Marked as answer by Roopesh Kumar Tuesday, December 15, 2009 5:11 PM
    Tuesday, December 15, 2009 5:11 PM