none
.Net Framework Rolls Back Install of Versions 4.0+ on Windows 7 RRS feed

  • Question

  • The latest log is below for review.  I need version 4.x due to some software I recently purchased.

    I've used the NetFxRepair Tool as well as the cleanup tool.  They seem pointless since they are not able to remove version 3.5 that is part of Windows 7.

    I've cleaned out the temp folder, rebooted, disabled the Panda antivirus I have and tried a fresh install using both Windows Update as well as the offline solution.  Both give me error 643.  I tried in safe mode but it won't allow me to install in safe mode.  The install always rolls back.

    If there's anything else I forgot to do, someone please let me know.

    ============================

    OS Version = 6.1.7601, Platform 2, Service Pack 1
    OS Description = Windows 7 - x64 Home Premium Edition Service Pack 1
    CommandLine = C :\7456be915a7af9218cfbd1dbb1\\Setup.exe /x86 /x64 /ia64 /web
    TimeZone = Eastern Daylight Time
    Initial LCID = 4105
    Using Simultaneous Download and Install mechanism
    Operation: Installing
    Package Name = Microsoft .NET Framework 4 Setup
    Package Version = 4.0.30319
    User Experience Data Collection Policy: AlwaysUploaded
    Number of applicable items: 11
    Exe (C :\7456be915a7af9218cfbd1dbb1\SetupUtility .exe) succeeded.
    Exe Log File: dd_SetupUtility .txt
    ServiceControl operation succeeded!
    ServiceControl operation succeeded!
    Exe (C :\Users\EDANDK~1 \AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\Windows6.1-KB958488-v6001-x64 .msu) failed with 0x240006 - (null).
    Exe Log File: CBS.log
    Exe (C :\7456be915a7af9218cfbd1dbb1 \SetupUtility .exe) succeeded.
    Exe Log File: dd_SetupUtility .txt
    MSI (C :\Users\EDANDK~1\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20150320_134637780-MSI_netfx_Core_x64.msi .txt
    Exe (C :\7456be915a7af9218cfbd1dbb1\SetupUtility .exe) succeeded.
    Exe Log File: dd_SetupUtility .txt
    MSI (C :\Users\EDANDK~1\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\ netfx_Core_x64 .msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20150320_134637780-MSI_netfx_Core_x64. msi .txt
    Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation. " (Elapsed time: 0 00:01:56).

    Friday, March 20, 2015 6:29 PM

All replies

  • It appears that you are attempting to use the web installer. Please try the steps below:

    Follow these steps exactly:

    Before trying to install .NET Framework 4.0, execute this command from an ELEVATED Command Prompt provided by the .NET Framework Team:

    "This issue is likely caused by a bad ACL on assembly\tmp folder. After installing updates, the ACL propagates to installed assembly folders in both 4.0 & legacy GAC.  If those updates were installed by WU or another user, the propagated ACL will prevent install of the same assembly by the current user.

    A work around would be to reset the ACL on GAC dirs.

    for /F %D in ('dir %WINDIR%\assembly %WINDIR%\Microsoft.NET\assembly /s /b /a:d') do takeown /F %D && icacls %D /reset /T"

    After running that command, follow these steps:

    Please follow these instructions exactly:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/en-us/download/details.aspx?id=17718

    2. Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    Note: Just using an administrator account is NOT enough. To activate full privileges, you must right-click the installer, then select Run as administrator.

    If the install fails, provide complete install logs as follows:

    Please collect your install logs with this:

    http://aka.ms/vscollect

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like OneDrive, and post the link here.

    Friday, March 20, 2015 9:32 PM
  • Hello EJo,

    First you may need to know the relationship between .NET 3.5 and .NET 4.0, they are totally standalone packages. So your installation does not related to that .NET 3.5 on your OS. If you insist on thinking .NET 3.5 is the reason, run this too to verify http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    And if it says .NET 3.5 doesnot work well, run sfc /scannow command from command prompt to scan and repair the .NET 3.5 feature.

    Now I think we need to focus on your .NET 4 installation error. 0x80070643 is a general error and may contains so many other info about your issue. So it is better for us to check the Msi Log: Microsoft .NET Framework 4 Setup_20150320_134637780-MSI_netfx_Core_x64. msi .txt

    The log is located under %temp% folder, please upload it to us. Or if you are not sure, you can follow MVP's advice to use http://aka.ms/vscollect tool to collect the whole vslogs.cab file.

    By the way, here is an KB article about this error 0x80070643 https://support.microsoft.com/en-us/kb/976982

    Best regards,



    Barry
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, March 23, 2015 2:12 AM
    Moderator