locked
Writing applications for multiple versions RRS feed

  • Question

  • I wrote an application that I've tested on my phone.  I beamed it to my buddys phone to see how it behaves.  It came up and gave a .NET version error.

    That brings me to the question.  When trying to get these apps out to the public via Marketplace mobile i assume that when they install Marketplace it gets them up to date on the latest versions to accept these apps?

     

    Monday, March 29, 2010 12:13 AM

Answers

  • Yes, if App requires - say CF 3.5, before the App is installed, CF3.5 is installed first then the App
    • Proposed as answer by dayjur Monday, March 29, 2010 2:18 AM
    • Proposed as answer by dayjur Monday, March 29, 2010 2:18 AM
    • Marked as answer by warrentang Thursday, April 1, 2010 6:30 AM
    Monday, March 29, 2010 2:17 AM
  • Hi,

    The best way is include all the prerequiesites to your application cab file, so that user need not to search or worry about these errors.

    You can try building multi cab file

    Regards,

    Malleswar

    • Marked as answer by warrentang Thursday, April 1, 2010 6:29 AM
    Monday, March 29, 2010 5:05 AM
  • Note: for the Marketplace you do *not* want to include the CAB for the .Net framework. When you are specifying your requirements you can specify which version of the .Net framework your application needs (if any) and the Marketplace client will ensure the proper version gets isntalled.
    It takes all the running you can do to stay in one place.If you want to get somewhere else,you must try to run at least twice as fast as that.
    • Marked as answer by warrentang Thursday, April 1, 2010 6:29 AM
    Monday, March 29, 2010 11:56 AM
  • Please read this FAQ: How do I redistribute .NET CF with my CAB and install it when it’s not present on the device?  
    Please mark the post that helps you, and unmark that does not. This benefits our community.
    • Marked as answer by warrentang Thursday, April 1, 2010 6:30 AM
    Thursday, April 1, 2010 6:30 AM

All replies

  • Yes, if App requires - say CF 3.5, before the App is installed, CF3.5 is installed first then the App
    • Proposed as answer by dayjur Monday, March 29, 2010 2:18 AM
    • Proposed as answer by dayjur Monday, March 29, 2010 2:18 AM
    • Marked as answer by warrentang Thursday, April 1, 2010 6:30 AM
    Monday, March 29, 2010 2:17 AM
  • Hi,

    The best way is include all the prerequiesites to your application cab file, so that user need not to search or worry about these errors.

    You can try building multi cab file

    Regards,

    Malleswar

    • Marked as answer by warrentang Thursday, April 1, 2010 6:29 AM
    Monday, March 29, 2010 5:05 AM
  • Note: for the Marketplace you do *not* want to include the CAB for the .Net framework. When you are specifying your requirements you can specify which version of the .Net framework your application needs (if any) and the Marketplace client will ensure the proper version gets isntalled.
    It takes all the running you can do to stay in one place.If you want to get somewhere else,you must try to run at least twice as fast as that.
    • Marked as answer by warrentang Thursday, April 1, 2010 6:29 AM
    Monday, March 29, 2010 11:56 AM
  • Ok, but for testing purposes I want to  install on my old Blackjack II with WM 6.1 Standard build 5.2.19208.1.0.1

    I get these errors on this phone but works fine on my Samsung Epix  WM 6.1 Professional Build 5.2.20276.1.3.3

    I guess in this case I need to add the CF 3.5 into my cab file.   Any tutorials on how to do this?

     

    Thanks for all the help guys?  You're getting me up to speed very quickly.

     

     

    Tuesday, March 30, 2010 11:58 AM
  • Please read this FAQ: How do I redistribute .NET CF with my CAB and install it when it’s not present on the device?  
    Please mark the post that helps you, and unmark that does not. This benefits our community.
    • Marked as answer by warrentang Thursday, April 1, 2010 6:30 AM
    Thursday, April 1, 2010 6:30 AM