none
Visual Studio 2015 crashes when I attempt to "Create App Packages..."

    Question

  • VS 2015 crashes when I attempt to perform any action from the "Store" context menu for my project.  This always happens, even after a checking for an applying all available OS updates and after a fresh reboot.  My app runs flawlessly on my Windows 10 Pro x64 system when debugging in VS and also from a deployment.  Its only when I attempt to "Create App Packages..." or "Associate App with the Store..." that VS 2015 crashes.

    Please help!  Thanks.


    Thanks for the outstanding help.

    Wednesday, April 13, 2016 5:02 PM

Answers

  • Hi Ron S Wright,

    Please tell us which version of Visual Studio 2015 are you using? Do you have installed the Update 2 for your Visual Studio 2015? If not, please try download and install from below link.

    https://www.visualstudio.com/en-us/news/vs2015-update2-vs.aspx

    If installed, please try with following steps to troubleshoot this problem.

    1. Run your Visual Studio as administrator to make sure it has enough permissions to do any operations.
    2. Run your Visual Studio in safe mode to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution.
    3. Backup the extension.vsixmanifest, then delete it and repair your Visual Studio to see the result.

    In addition, please check the ActiveLog.xml under the path of %AppData%\Microsoft\VisualStudio\14.0. This file will log all operations when you operate Visual Studio.

    Best Regards,
    Weiwei

    Thursday, April 14, 2016 7:37 AM
    Moderator

All replies

  • Hi Ron S Wright,

    Please tell us which version of Visual Studio 2015 are you using? Do you have installed the Update 2 for your Visual Studio 2015? If not, please try download and install from below link.

    https://www.visualstudio.com/en-us/news/vs2015-update2-vs.aspx

    If installed, please try with following steps to troubleshoot this problem.

    1. Run your Visual Studio as administrator to make sure it has enough permissions to do any operations.
    2. Run your Visual Studio in safe mode to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution.
    3. Backup the extension.vsixmanifest, then delete it and repair your Visual Studio to see the result.

    In addition, please check the ActiveLog.xml under the path of %AppData%\Microsoft\VisualStudio\14.0. This file will log all operations when you operate Visual Studio.

    Best Regards,
    Weiwei

    Thursday, April 14, 2016 7:37 AM
    Moderator
  • My original problem was with Visual Studio 2015 Community (base). I've since upgraded to Visual Studio 2015 Community Update 2. The problem does not occur with Update 2.

    However, upgrading to Update 2 was a very lengthy process.  At first left Visual Studio 2010, 2012 and 2013 in place and just tried to upgrade 2015, but I ran into a number of problems with the Platform SDK (10.0.10240.0).  After a number of attempts to repair Update 2 (with no success) I finally decided to completely uninstall VS 2010, 2012, 2013 and 2015 (and even Update 2) and start from scratch.  This worked, but was very time consuming, taking over 2 days.

    Anyway, all is now well and good. Except for one minor problem which should not get in my way.  The (Azure?) Resource Manager Package cannot be found.  I do not have any immediate plans which will require the use of the Resource Manager Package, so all is good.


    Thanks for the outstanding help.

    Tuesday, April 19, 2016 3:06 PM