none
Document sets - shared number column - fractional part disappears when updating the document - Regional settings RRS feed

  • Question

  • Hi,

    I have a strange behavior with documents in documentsets that share a number column with the document set. When editing the properties of the document and saving, the fractional part of my shared number columns "disappears".

    I have the same behavior on SharePoint 2013 on premise and on SharePoint on line.

    One important remark, my regional settings are set to "Dutch - Belgium". This means the decimal separator is not the point, but the comma. When I change my regional settings to "English - US", it all works, but this is not possible for my customer

    Any ideas to solve it ? For now I do no longer share these columns and I write a workflow to copy these values from the document set to the document ...

    Best regards,

    Marc


    • Edited by nemegeerm Thursday, February 5, 2015 9:42 AM More testing done
    Thursday, February 5, 2015 9:10 AM

Answers

  • Hi Marc,

    When I add a Number type column to a Document Set content type and shared to Document content type in my environment (SharePoint2013 SP1), then switch to region "Dutch(Belgium)" option from region English(US) option, and then edit a document item property, the existed decimal separator "," will disappear, I am going to submit this issue internally, currently as a workaround as you mentioned is to use workflow to copy the Document Set shared column value to each document item.

    For SharePoint Online issue, you can post in O365 SharePoing online forum for a better assistance, if they can also reproduce this issue, you may be able to provide a private message to involve the SharePoint Online back-end support engineer to look into this issue in O365 forum like the approach mentioned in the following post. 

    http://community.office365.com/en-us/f/148/t/246036.aspx

    Thanks,
    Daniel Yang
    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Daniel Yang
    TechNet Community Support

    • Marked as answer by nemegeerm Monday, February 9, 2015 8:36 AM
    Friday, February 6, 2015 11:07 AM
    Moderator

All replies

  • Hi Marc,

    When I add a Number type column to a Document Set content type and shared to Document content type in my environment (SharePoint2013 SP1), then switch to region "Dutch(Belgium)" option from region English(US) option, and then edit a document item property, the existed decimal separator "," will disappear, I am going to submit this issue internally, currently as a workaround as you mentioned is to use workflow to copy the Document Set shared column value to each document item.

    For SharePoint Online issue, you can post in O365 SharePoing online forum for a better assistance, if they can also reproduce this issue, you may be able to provide a private message to involve the SharePoint Online back-end support engineer to look into this issue in O365 forum like the approach mentioned in the following post. 

    http://community.office365.com/en-us/f/148/t/246036.aspx

    Thanks,
    Daniel Yang
    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Daniel Yang
    TechNet Community Support

    • Marked as answer by nemegeerm Monday, February 9, 2015 8:36 AM
    Friday, February 6, 2015 11:07 AM
    Moderator
  • Hi Daniel,

    Ok, message understood, so it's a bug, there is no other workaround  ;-)

    Best regards,

    Marc

    Monday, February 9, 2015 8:36 AM