none
FSLogix and Printers on printserver RRS feed

  • Question

  • Perhaps someone has come across this already and has a fix, here's my situation.

    Running w10 1809 ltsc with latest FSL build 2.9.7117.27413, non persistent citrix desktops

    using only profile containers, users get their profile just fine, however they map printers themselves by going to \\printerserver and installing it, so no gpp's are pushing printers.  when they connect the first time, they can print with no issues, on the second logon (next day), the printer shows installed but is un-available.  seems like the profile is loading before the printer can be connected perhaps?  this does not exist in our upm setup.  i can replicate this at will, anyone else come across this lately?

    the fix for the user is to remove the printer and re-install it from \\printserver  

    Monday, August 19, 2019 9:33 PM

Answers

  • yes i did actually, sorry i didn't update this post, however this was caused by a gpo that was enabled.  the gpo was for kernel mode print drivers, i believe it was something left over from our xp/w7 vdi days.  i just set it to not config'd and the problem went away.  
    Wednesday, October 2, 2019 12:09 PM

All replies

  • I found the following article in the legacy KB's. Please let us know if this resolves your issue or if you still need more information.
    - Micah Adamson

    Default printer setting will not save in FSLogix profile

    When using FSLogix profiles in a Citrix environment, settings which should be persisted in the users profile are not being saved

     

    FSLogix does not persist printers, it can only hide printers. So, you will need to setup default printers in Citrix the same way you would without using FSLogix profiles.

    To resolve issues where the default printer will not save in an FSLogix profile, please update the following printer settings in the Citrix configuration:

    • PROBLEM: The "Default Printer" configuration option: "Not Configured Setting" by default is to: "Set Default printer to the Client's Main printer".
      • So, by default Citrix will try to set the printer to something other than what the user has configured (unless the Citrix default printer is already the same as the user's printer setting).
    • RESOLUTION: Make a new policy and set it to "Do not adjust the user's default printer".

     

     

    Helpful links

    Citrix Default Printer Won't Retain: http://www.sagelike.com/2015/07/citrix-default-printer-wont-retain.html
    Wednesday, August 21, 2019 6:42 PM
    Owner
  • Thank you, however that is not my problem.  Please re-read my post. 
    Thursday, August 22, 2019 1:20 AM
  • I once had a case similar, was the printer added by DNS name? or by IP address?

    Thursday, August 22, 2019 5:53 PM
    Moderator

  • Thanks for posting.  This is a pretty common problem in a lot of environments where users switch machines.  I believe the problem is caused by printer drivers.

    When a user adds a printer from the print server it also installs the driver that goes with that printer.  So it works in that session.  Print drivers don't install in the profile, so when they log out and get a new machine, the profile brings over all the settings for that printer, but the print driver isn't on that machine yet so it can't be used.  

    I've worked with a lot of environments where they pre-install all the print drivers in the base image.  You may be able to find a universal print driver to help streamline this process, but not all universal print drivers are really universal.  If the drivers are already there, then the profile should handle the settings just fine.

    If you don't think this is a driver issue then please open a support case. We'd be glad to look into this more deeply with you.  https://social.msdn.microsoft.com/Forums/en-US/14ea5f6f-760b-4ad2-83cf-23c3cbc1bcc4/how-to-open-an-fslogix-support-request?forum=FSLogix

    Thursday, August 22, 2019 6:03 PM
    Moderator
  • printes are installed on the print server by ip address, then users go to \\printserver\print to connect to them
    Thursday, August 22, 2019 6:15 PM
  • Users are on non-persistent vm's, however all of this worked fine for 10 years with UPM.  In addition, if the user is mapped to 10 printers, perhaps only 1 or 2 exhibit this behavior.  There are no drives in the base image, never have been and we have over 100 printers and users on CVAD for years and years now.  Why this is a problem with FSLogix is beyond me.  I have uploaded logs to my case and am waiting for analysis.

    If all printers exhibited this behavior i could understand why, but not 10 or 20% the user is connected too.  

    Thank you for your reply though, I hope to find a solution shortly.  

    Thursday, August 22, 2019 6:17 PM
  • Hi,

    Same problem - did you resolve this? 

    Wednesday, October 2, 2019 9:18 AM
  • yes i did actually, sorry i didn't update this post, however this was caused by a gpo that was enabled.  the gpo was for kernel mode print drivers, i believe it was something left over from our xp/w7 vdi days.  i just set it to not config'd and the problem went away.  
    Wednesday, October 2, 2019 12:09 PM