none
.NET Framework 4 has not been installed because: Access is denied. RRS feed

  • Question

  • I've been trying over and over to install this package. I believe it is because of our proxy server, but I've searched for resolution to this for quite some time without success.

    Here is the log:

    [6/3/2010, 9:51:33] Action: Downloading http://go.microsoft.com/fwlink/?LinkId=164166&clcid=0x409 using WinHttp ...

    [ 6/3/2010 , 9:51:33 ] Auto detecting proxy information
    [
    6/3/2010 , 9:51:33 ] WinHttpDetectAutoProxyConfigUrl failed with error: 12180
    [
    6/3/2010 , 9:51:33 ] Auto detection of proxy failed, try to retrieve proxy information via IE.
    [
    6/3/2010 , 9:51:33 ] Retrieving proxy information using WinHttpGetIEProxyConfigForCurrentUser
    [
    6/3/2010 , 9:51:33 ] Using WINHTTP_ACCESS_TYPE_NAMED_PROXY
    [
    6/3/2010 , 9:51:33 ] Session Created
    [
    6/3/2010 , 9:51:33 ] Connection Created
    [
    6/3/2010 , 9:51:33 ] Request Created

    [ 6/3/2010 , 9:51:33 ] Action complete

    [6/3/2010, 9:51:33] C:\DOCUME~1\mlafleur\LOCALS~1\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\TMP255B.tmp: Verifying signature for Windows6.0-KB956250-v6001-x86.msu ...

    [ 6/3/2010 , 9:51:33 ] Possible transient lock. WinVerifyTrust failed with error: 2148204800
    [
    6/3/2010 , 9:51:33 ] Possible transient lock. WinVerifyTrust failed with error: 2148204800
    [
    6/3/2010 , 9:51:33 ] C:\DOCUME~1\mlafleur\LOCALS~1\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\TMP255B.tmp - Signature verification for file Windows6.0-KB956250-v6001-x86.msu (C:\DOCUME~1\mlafleur\LOCALS~1\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\TMP255B.tmp) failed with error 0x800b0100 (No signature was present in the subject.)

    [ 6/3/2010 , 9:51:33 ] C:\DOCUME~1\mlafleur\LOCALS~1\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\TMP255B.tmp Signature could not be verified for Windows6.0-KB956250-v6001-x86.msu

    [ 6/3/2010 , 9:51:33 ] No FileHash provided. Cannot perform FileHash verification for Windows6.0-KB956250-v6001-x86.msu
    [
    6/3/2010 , 9:51:33 ] Download failed at attempt 4 of 4 for http://go.microsoft.com/fwlink/?LinkId=164166&clcid=0x409 using Http
    [
    6/3/2010 , 9:51:39 ] Starting download attempt 4 of 4 for http://go.microsoft.com/fwlink/?LinkId=164166&clcid=0x409 using UrlMon

    [6/3/2010, 9:51:39] Action: Downloading http://go.microsoft.com/fwlink/?LinkId=164166&clcid=0x409 using UrlMon ...

    [ 6/3/2010 , 9:51:39 ] UrlMon download failed with 80070005

    [ 6/3/2010 , 9:51:39 ] Action complete

    [ 6/3/2010 , 9:51:39 ] Download failed at attempt 4 of 4 for http://go.microsoft.com/fwlink/?LinkId=164166&clcid=0x409 using UrlMon

    [ 6/3/2010 , 9:51:39 ] Action complete

    [ 6/3/2010 , 9:51:39 ] Action complete

    [ 6/3/2010 , 9:50:15 ] calling PerformAction on an installing performer

    [6/3/2010, 9:50:15] Action: Performing actions on all Items ...

    [ 6/3/2010 , 9:50:15 ] Wait for Item (clr_optimization_v2.0.50727_32) to be available
    [
    6/3/2010 , 9:50:15 ] clr_optimization_v2.0.50727_32 is now available to install
    [
    6/3/2010 , 9:50:15 ] Creating new Performer for ServiceControl item

    [6/3/2010, 9:50:15] Action: ServiceControl - Stop clr_optimization_v2.0.50727_32 ...

    [ 6/3/2010 , 9:50:15 ] ServiceControl operation succeeded!

    [ 6/3/2010 , 9:50:15 ] Action complete

    [ 6/3/2010 , 9:50:15 ] Error 0 is mapped to Custom Error:
    [
    6/3/2010 , 9:50:15 ] Wait for Item (Windows6.0-KB956250-v6001-x86.msu) to be available
    [
    6/3/2010 , 9:51:40 ] Final Result: Installation failed with error code: (0x80070005), "Access is denied. " (Elapsed time: 0 00:01:32 ).

     

    Thursday, June 3, 2010 2:16 PM

Answers

All replies

  • BTW: I have the proxy server address set correctly in IE. We usually use a script, but I hardcoded the address with the correct port and tested it by access outside websites. The proxy server will ask for a username and password.
    Thursday, June 3, 2010 2:23 PM
  • Hi Mplafleur,

    Thank you for your post.

    Some clarification with you:
    What's your OS?

    To install .NET Framework 4.0, you could try the following steps for further troubleshooting.

    1. Download .NET Framework 4.0 Standalone installer
        Note: You can try some download manager software to help downloading.

    2. Run the installer to install .NET 4.0 with Administrator Privilege
        Note: If you're running Windows Vista or later OS, please right-click the installer >> "Run as Administrator"

    3. If any problem occurs during the installation, use Collect tool to collect the log files for further troubleshooting.

    The steps to collect the log:
    - Try to clean your "%temp%" folder (Start Menu >> Run >> Type "%temp%")
    - Install .NET Framework 4.0 Standalone installer
    - Collect the logs from "%temp%" folder
       Collect tool: http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx
    - Diagnose the cause of failure installation
       Option 1:
       Try the points mentioned here: http://social.msdn.microsoft.com/forums/en-US/vssetup/thread/0376db8f-4761-4ae5-9af2-98c53216318a#How_to_diagnoseVS2008_NETFramework_logs to diagnose the cause of failure installation.
       Option 2:
       Send vslogs.cab file to me (v-yicche@microsoft.com)
       Note: Please attach the link of this post in the mail.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Thursday, June 10, 2010 3:03 AM
    Friday, June 4, 2010 10:50 AM
  • Window XP; I am the Administrator.

    There was no problem running the full install. It downloaded in less that a minute and installed in about 5 minutes.

    This however does not give us root cause for the original problem. Although I had my proxy server set up correctly. I was getting through the firewall.  I had removed any anti-virus software. EI was set up to use the proxy server and the IP and ports were correct.

    These were the key errors logged in my original post:

    [ 6/3/2010 , 9:51:33 ] Auto detecting proxy information
    [
    6/3/2010 , 9:51:33 ] WinHttpDetectAutoProxyConfigUrl failed with error: 12180
    [
    6/3/2010 , 9:51:33 ] Auto detection of proxy failed, try to retrieve proxy information via IE.
    [
    6/3/2010 , 9:51:33 ] Retrieving proxy information using WinHttpGetIEProxyConfigForCurrentUser
    [
    6/3/2010 , 9:51:33 ] Using WINHTTP_ACCESS_TYPE_NAMED_PROXY
    [
    6/3/2010 , 9:51:33 ] Session Created
    [
    6/3/2010 , 9:51:33 ] Connection Created

    I was able to use IE to download the installation file (dotNetFx_Full_setup.exe) from Microsoft.com and run it, but it was unable to do the same.

    The installation package was unable to get the correct proxy information and use it. It failed and retried 3 more times and then quit.


    Why did the proxy authorization fail? Did it try as an anonymous user?

    Mike

     

     

    Monday, June 7, 2010 9:57 PM
  • Hi Mike,

    Thank you for your reply.

    Firstly, I'm so glad to hear that you have installed .NET Framework 4.0 successfully on your machine. Thus, I've marked my last reply as answer here. I believe that this post will benefit other community members who have similar concern as you.

    Secondly, I need to do some explanation on the failure that you came across previously.

    I guess that you tried to install .NET Framework 4.0 via web installer instead of full package.

    Referring to the difference between web installer and full package:
    - Web install is a very lightweight setup package, which determines what needs to be installed and attempts to download these required components from the web during installation.
    - Full package is a stand-alone installer package that contains all required components to deploy different platforms.

    As you mentioned, the log file show that the cause might be related to proxy settings. It is related to network.
    The error occurred when web installer tried to download the required components. That's why I suggested you to try .NET Framework 4.0 Standalone installer to install .NET Framework 4.0.

    To be honest, I'm not quite familiar with network. Thus, if it is the environment in the office, you could try to discuss it with network administrator to get more useful help.

    Hope this helps!

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Thursday, June 10, 2010 3:03 AM
  • ) Downloaded the  standalone installer for .Net Framework 4.0 from the official Microsoft website  and try the installation.

    http://www.microsoft.com/download/en/details.aspx?id=17718

    2)  Extracted it using the command line:

            “dotNetFx40_Full_x86_x64.exe /x”

    3) Installed .NET framework 4.0 Client Profile by running the command line on the administrator command prompt:  

          msiexec /I netfx_Core_x64.msi EXTUI=1

    4) Installed .NET Framework 4.0 Extended by running the command line on the administrator command prompt:
          msiexec /I netfx_Extended_x64.msi EXTUI=1

    Tuesday, July 16, 2013 2:20 PM
  • Hi, you can to verify your configuration and access to IE.  This work for me.

    Could have an add in blocking your download and no your computer.

    Good luck!

    Wednesday, October 8, 2014 10:42 PM