none
crystal report windows forms viewer: Failed to load database information.

    Question

  • Hi,

    I hav a problem here....

    I hav create a report that hav subreport in it. when i try to run it on my computer (the one i use to develop program), its run smoothly no error of anything.  When I deploy it to other computer, it work fine as long as the data of the subreport is filled, but if the subreport data were not filled, it throw an exception:

    ---------------------------
    Crystal Report Windows Forms Viewer
    ---------------------------
    Failed to load database information.
    Details: The database DLL 'crdb_fielddef.dll' could not be loaded.
    Error in File C:\DOCUME~1\User\LOCALS~1\Temp\LaboratoryResult {E4384A87-C57C-4FEF-BE2B-65558ACEE41D}.rpt:
    Failed to load database information.
    ---------------------------
    OK   
    ---------------------------

    Then I try it on my computer with the same data its work just fine.

    Can anybody tel me what i am wrong at? Deployment method is wrong? what should i do?

    Thanks in advance.

    Saturday, June 30, 2012 9:58 AM

All replies

  • I realize this is one year ago but will just reply anyway.

    In my case i had the exact same error; My deployment machine was a 64 bit machine: This is what i did:

    1. Installed the 64 bit Crystal runtime on the deployment machine.

    2. On the devt machine, I recompiled my source for 64 bit CPU, then deployed.

    It worked.

    Monday, July 15, 2013 11:11 AM