locked
Crash : Azure Storage Explorer 0.8.16 in Win10x64Pro on VirtualBox RRS feed

  • Question

  • I have upgraded the Azure Storage Explorer to the latest version (0.8.16) and it crashes on startup.

    The only error i can find is "A problem caused Storage Explorer to stop working correctly (the GPU process crashed). Please close and restart the application"

    I am using ASE inside a Win10x64 VM via Virtual Box. The old version (0.8.13).

    As far as i can tell the main difference between the versions is the upgrade of Electron to 1.7.2.

    I am also using the latest version of Visual Studio Code (also Electron based) in the same VM and have no problems with it.

    Let me know how can i provide more info on this.


    Best,

    Razvan


    • Edited by urweiss Sunday, August 27, 2017 8:00 AM typo
    Sunday, August 27, 2017 7:46 AM

All replies

  • Hello,

    0.8.16 is in preview yet.

    Please check the below link of release notes of 0.8.16, it might helps you - 

    https://docs.microsoft.com/en-us/azure/vs-azure-tools-storage-explorer-relnotes?toc=%2fazure%2fstorage%2fblobs%2ftoc.json

    Regards

    Kapil


    Please Mark as Answer if my post works for you or Vote as Helpful if it helps you. Kapil Singh


    Sunday, August 27, 2017 10:08 AM
  • Hi,

    I have the latest version you can download from here : https://azure.microsoft.com/en-us/features/storage-explorer/

    It installed version 0.8.16 (NOT 26).

    1. Nowhere on this page does it say it is preview.
    2. 0.8.16 does not work
    3. 0.8.14 does not work (same error)
    4. 0.8.13 works (old Electron version)
    5. 0.8.13 updates itself automatically to 0.8.16 (preview....) which does not work

    Razvan

    Sunday, August 27, 2017 10:56 AM
  • Hi, 

    I am facing the same issue (GPU process crashed) using version 0.8.16

    Is there a solution for this?

    Ortwin

    Tuesday, September 19, 2017 6:43 AM
  • FYI: same GPU crashes for me.

    Just downloaded ASE, says 0.8.16 (51266.2.0.0)

    I happen to be using an older VirtualBox (4.3.r12)

    Win 7 SP1 client on a Win 7 SP1 host

    Giving the VM 256MB of GRAM on just 1 monitor and have 2D and 3D acc enabled.

    Tuesday, September 26, 2017 6:03 PM
  • Running the Explorer like this fixed it for me:

    "C:\Program Files\Microsoft Azure Storage Explorer\StorageExplorer.exe" --disable-gpu

    • Proposed as answer by Md Shihab Monday, November 13, 2017 10:10 AM
    Thursday, November 9, 2017 1:58 PM
  • The Electron shell used by Storage Explorer has trouble with some GPU (graphics processing unit) hardware acceleration. If Storage Explorer is displaying a blank (empty) main window, you can try launching Storage Explorer from the command line and disabling GPU acceleration by adding the --disable-gpu switch: ./StorageExplorer.exe --disable-gpu

    Refer: Microsoft Azure Storage Explorer (Preview) release notes

    -----------------------------------------------------------------------------------------------------

    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

    • Proposed as answer by Md Shihab Monday, November 13, 2017 10:15 AM
    Monday, November 13, 2017 10:15 AM
  • Thanks.

    This works for me using the latest version 0.9.3.

    Sunday, December 17, 2017 7:53 PM
  • I have the issue on a VDI as well, with 0.9.3, disabling the hardware excelleration through the command line works, but it still needs to be addressed
    Tuesday, January 2, 2018 8:53 PM
  • @schmak: You can submit your issue through the feedback tool with your email and as many details about the issue included as you can, so that we can contact you for fixing the issue.

    To do this, from the Azure Storage Explorer tool click Help menu, and then click Send Feedback.

    -----------------------------------------------------------------------------------------------------

    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

    Wednesday, January 3, 2018 4:39 AM