none
visual studio 2010 Tools for Office runtime install error RRS feed

  • Question

  • I am trying to install the visual studio runtime for 2010 on a windows 7 machine to support an outlook addin from Icewarp mail server. It is blowing up with a file access error indicating I don't have access to a file, yet I am an administrator on the local computer. The installer was included in the Icewarp client install. I also downloaded it manually from Microsoft with the same result. I also cleaned all the temp files and tried it again with no luck. Any ideas would be greatly appreciated. This client package has installed successfully on at least 15 other computers with similar configurations.

    Here is the error I get whether I use the Icewarp installer or if I download the installer from here:http://www.microsoft.com/en-us/download/details.aspx?id=20479

    "Error 1310:Error writing to file: Microsoft.VisualStudio.Tools.Applications.Contract.v10.0.dll. Verify that you have access to that directory."

    Options are retry or cancel.

    I am running on an id that is in the administrators group and I have downloaded the installer and tried it using "Run as administrator" with no luck.

    Please give me an idea what folder it is trying to write this file to.


    • Edited by Forrest GuoModerator Wednesday, August 15, 2012 3:23 AM VSTO 2010 runtime install error
    • Moved by Forrest GuoModerator Wednesday, August 15, 2012 3:24 AM vsto runtime install (From:Visual Studio Setup and Installation)
    Wednesday, August 1, 2012 10:06 PM

All replies

  • Hi Scomage,

    Thanks for your post.

    After a research of this issue, it seems the file location is like this:

    x86:

    C:\Program Files\Common Files\Microsoft Shared\VSTA\Pipeline.v10.0\Contracts\Microsoft.VisualStudio.Tools.Applications.Contract.v10.0.dll

    x64:

    C:\Program Files (x86)\Common Files\microsoft shared\VSTA\Pipeline.v10.0\Contracts\Microsoft.VisualStudio.Tools.Applications.Contract.v10.0.dll

    Could you please refer to that folder to see if you have that dll file or if you have full permission to that dll file.

    I've also read Prerequisites: you must have both .NET Framework and at list one OFFICE 2010 or OFFICE 2007 product installed, please check it.

    Hope this info can help you.

    Best regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us



    • Edited by Barry Wang Monday, August 6, 2012 1:53 AM
    Friday, August 3, 2012 5:22 AM
  • There is no VSTA folder under the microsoft shared folder.  Also, this computer has Office 2007 not 2010.  The runtime package installs fine on other computers with 2007.  .Net is installed through .Net 4.
    Friday, August 3, 2012 5:29 PM
  • Hi Scomage,

    From your description, your error may be clear.

    Please have a look at this article http://msmvps.com/blogs/sundar_narasiman/archive/2008/05/20/how-to-install-vsta-visual-studio-tools-for-applications.aspx

    You need to install VSTA for programming but you do not have it on your OS.

    Please enable .NET Programmability Support by solution from the blog.

    Then reinstall that runtime.

    Regards,

    Note: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites; therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software from the Internet.


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us


    • Edited by Barry Wang Monday, August 6, 2012 9:42 AM
    Monday, August 6, 2012 9:41 AM
  • Sorry - it took a while to get access to the workstation again.

    The .Net programmability support was already enabled for all modules in Office 2007 Standard.  I even went in to modify the installation and did a repair, removed the .Net support, then added it again to see if I could get it to recreate the VSTA folder with no luck.

    Any more ideas on how I can get this?  What if I copy the folder from another workstation with the same version of office?

    Thursday, August 9, 2012 3:18 PM
  • Hi Scomage,

    I'm sorry I may made a mistake about this issue.

    From http://en.wikipedia.org/wiki/Visual_Studio_Tools_for_Applications we can see "Visual Studio Tools for Applications (VSTA) is based on the .NET Framework and is built on the same architecture as Visual Studio Tools for Office (VSTO)"

    So you issue may actually due to permission.

    Have you tried "run as adminitrator"?

    What about follow the following steps below:

    1. Use 7-zip or some applications to extract the exe to a folder

    2. Right click install.exe and choose run as administrator

    3. Install the products

    Additionally, could you please check security property of C:\Program Files (x86)\Common Files\microsoft shared.

    Have a look at the folder Advance Security Setting. Check TrustedInstaller have Special Pemission?

    Regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us




    • Edited by Barry Wang Friday, August 10, 2012 7:58 AM
    Friday, August 10, 2012 7:40 AM
  • OK.  I tried the following:

    1. Ran the base install as administrator - same error.

    2. Copied VSTA and VSTO from a working computer to this computer and set the permissions to full for the user.

    3. Ran the base install as administrator - same error.

    4. Unpacked the install to a folder.

    5. Ran the msi - same error.

    6 Tried to run install.exe as administrator - received error install.exe not a valid win32 application.

    Is there a registry key that might have bad permissions or not exist?  I don't believe the error has anything to do with the VSTA folder or the file system.  I have accounted for all the permissions issues there.

    Friday, August 10, 2012 3:36 PM
  • Hi Scomage,

    Sorry for the late track. I was on my holiday.

    From the error "install.exe not a valid win32 application", it means the file was corrupt.

    What's your OS version? x86 or x64?

    Have you download the right file for your OS?

    Could you please try the following to download the file again:

    1. Open Internet Options in the Control Panel to delete temporary internet files
    2. Download and save the file
    3. When the download completes, double click the file to begin installing

    If you have any updates, please feel free to let me know.

    Regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us


    • Edited by Barry Wang Tuesday, August 14, 2012 2:16 AM
    Tuesday, August 14, 2012 2:16 AM
  • I am running W7 Pro 32 bit.  I have definitely downloaded the x86 32 bit version.  I retried the installs as before and got the same results.  It has nothing to do with folder permissions.  Please let me know what registry keys are added/updated for this install so I can check the permissions for them.
    Wednesday, August 15, 2012 12:33 AM
  • Scomage,

    The error message is:

    "Error 1310:Error writing to file: Microsoft.VisualStudio.Tools.Applications.Contract.v10.0.dll. Verify that you have access to that directory."

    You have excluded the possibility of lacking admin previlege. This issue could also happen while Windows Installer becomes unregistered during the installation process. Solution is to unregister and reregister Windows Installer:

    • Click Start, and then click Run.
    • In the Open box, type msiexec /unreg, and then press ENTER.
    • Click Start, and then click Run.
    • In the Open box, type msiexec /regserver, and then press ENTER.

    Refer to: http://support.microsoft.com/kb/296175

    Hope this helps.

    thanks.


    Forrest Guo | MSDN Community Support | Feedback to manager

    Wednesday, August 15, 2012 3:46 AM
    Moderator
  • No luck. Ran it from the run menu and also from a cmd prompt run as administrator. Also checked that SYSTEM has full permission to the VSTA folder.

    Registry???

    Thursday, August 16, 2012 5:26 PM
  • The VSTO 2010 runtime could work with .NET 3.5 and .NET 4.0, in this case, I don't get proof which .NET you required. Given both of them are on machine, please

    • Uninstall .NET 4.0, then reinstall .NET 4.0
    • Turn off .NET 3.5 feature on OS, then turn on the fearure.
    • Then install the VSTO runtime.

    There was a similar problem reported and fixed in this way, please try it.

    The VSTA folder is created by VSTO runtime installer, so the message you see results from the VSTO runtime installation failure.

    Troubleshooting VSTO runtime installation.  The installer itself provides logging, you can run it in command and enable the logging:

    • Run the installer in command, with option:  vstor40_x64.exe /l c:\temp\vstor4.txt
    • Collect log in specified location, and from %temp% folder.   Log files like dd_vsto_xxxxxx.txt

    Hope this gets you started.

    thanks.


    Forrest Guo | MSDN Community Support | Feedback to manager

    Tuesday, August 21, 2012 6:14 AM
    Moderator
  • Just for further reference (I realize it's an older thread, but it's still searchable), the "permalink" for the VSTO Runtime download is http://go.microsoft.com/fwlink/?LinkId=140384.  The other link unfortunately had to be retired, so please use the permalink instead.

    Michael Zlatkovsky | Program Manager, Visual Studio Tools for Office & Apps for Office

    Wednesday, December 5, 2012 6:58 PM
    Moderator
  • http://go.microsoft.com/fwlink/?LinkId=140384
    http://www.microsoft.com/zh-cn/download/confirmation.aspx?id=39290

    The answer is waiting for you

    Believe me,you can do it,

    Good luck for you!

    Tuesday, September 24, 2013 5:28 AM