locked
publish XBAP with prerequisite, but setup.exe returns with "The page cannot be found" RRS feed

  • Question

  •  Hej, 

    I've published an XBAP to the webserver (on my own machine) that requires .NET 3.5 (i copy paisted what the published page looks like  below).

    On the publish.htm page there is a link directly to setup.exe.    I click it.

    But i keep on getting  "The page cannot be found" error. 

    I tried everything thinkable and more.

    What to do?

    I tried setting the mime types as instructed at these links:
    IIS 6.0 does not serve unknown MIME types
    Server and Client Configuration Issues in ClickOnce Deployments
    ClickOnce Deployment Overview
    Handling MIME Types in Internet Explorer

    Since the website is configured via my Win XPs own IIS 6, i allowed low security.  But this didnt help.
    The strategy being (if it did help), to increase security restrictions until i could replicate the symptom.

    Thanks,
    Paul
    Name: MyApp Browser Version
     
    Version: 1.0.0.166
     
    Publisher: MyCompany
     
    The following prerequisites are required:
     
    • .NET Framework 3.5
    If these components are already installed, you can launch the application now. Otherwise, click the button below to install the prerequisites and run the application.
     
    Run
     

    Paul
    Tuesday, October 28, 2008 7:21 PM

Answers

  • Hi Paul,
        I don't know why you're having IIS troubles but we all have them sometimes.  Usually for me this problem is the file permissions for the "anonymous" user on my IIS setup.   Since I can't troubleshoot your machine and an IIS problem isnt that interesting from a WPF standpoint, here's an idea that also improves installation speed and reduces the bandwidth your server has to use... consider editing publish.htm (or whatever you've named it) to point to this:

     http://download.microsoft.com/download/0/6/1/061F001C-8752-4600-A198-53214C69B51F/dotnetfx35setup.exe

    ... instead of setup.exe.   This is the redist for 3.5 SP1.  That way, so long as your server will serve up .xbap, .exe.manifest, and .exe files of some sort, your bootstrapping publish page should work.    Please update the thread either way if you figure out why IIS isnt behaving for you though... may be useful to others.

    Hope this helps,
    Matt


    SDET : Deployment/Hosting
    • Marked as answer by Schwartzberg Friday, October 31, 2008 1:13 PM
    Wednesday, October 29, 2008 12:18 AM
  • That was a good work-around.

    I replaced the link to the .NET 3.5 SP1 with the one you gave above and it relieved the pain.

    When i find the setting(s) (more likely - understanding) for what i should do on my own localhost website, lack of which has been driving me bananas, i'll update this thread.

    Thanks!

    Update:  I am marking Matt's post as an answer.  There is something wierd concerning my IIS and its virtual directories (nope: not over a network - also on my machine) ... i'll update this thread when i find out why it doesnt let *.exe, *.bat and *.config through.

    Update(3 Feb 09): I haven't found out yet why my local IIS doesnt let the *.bat, *.config, etc., files through .   As a temp solution until i find the right way to do it, I made a hack, where i renamed the files IIS doesnt like to hand over to something innocent like *.txt.  After my client code downloads these, it  renames them back to *.bat, or *.config (as appropriate, the renaming is hardcoded), and then saves them to the local client machine.  As i indicate this is
    (hopefully :-)) just a temp thing.

    Paul
    Wednesday, October 29, 2008 1:35 PM

All replies

  • Hi Paul,
        I don't know why you're having IIS troubles but we all have them sometimes.  Usually for me this problem is the file permissions for the "anonymous" user on my IIS setup.   Since I can't troubleshoot your machine and an IIS problem isnt that interesting from a WPF standpoint, here's an idea that also improves installation speed and reduces the bandwidth your server has to use... consider editing publish.htm (or whatever you've named it) to point to this:

     http://download.microsoft.com/download/0/6/1/061F001C-8752-4600-A198-53214C69B51F/dotnetfx35setup.exe

    ... instead of setup.exe.   This is the redist for 3.5 SP1.  That way, so long as your server will serve up .xbap, .exe.manifest, and .exe files of some sort, your bootstrapping publish page should work.    Please update the thread either way if you figure out why IIS isnt behaving for you though... may be useful to others.

    Hope this helps,
    Matt


    SDET : Deployment/Hosting
    • Marked as answer by Schwartzberg Friday, October 31, 2008 1:13 PM
    Wednesday, October 29, 2008 12:18 AM
  • That was a good work-around.

    I replaced the link to the .NET 3.5 SP1 with the one you gave above and it relieved the pain.

    When i find the setting(s) (more likely - understanding) for what i should do on my own localhost website, lack of which has been driving me bananas, i'll update this thread.

    Thanks!

    Update:  I am marking Matt's post as an answer.  There is something wierd concerning my IIS and its virtual directories (nope: not over a network - also on my machine) ... i'll update this thread when i find out why it doesnt let *.exe, *.bat and *.config through.

    Update(3 Feb 09): I haven't found out yet why my local IIS doesnt let the *.bat, *.config, etc., files through .   As a temp solution until i find the right way to do it, I made a hack, where i renamed the files IIS doesnt like to hand over to something innocent like *.txt.  After my client code downloads these, it  renames them back to *.bat, or *.config (as appropriate, the renaming is hardcoded), and then saves them to the local client machine.  As i indicate this is
    (hopefully :-)) just a temp thing.

    Paul
    Wednesday, October 29, 2008 1:35 PM