locked
Cannot access third-party app over LAN RRS feed

  • Question

  • User-733680851 posted

    Problem summary: I installed a third-party http-based application on a Windows 7 Pro ‘server’. Due to the presence of another application that uses port 80, I changed the default port for IIS to 8080. I can access the application from the server, but not from another machine on the same network. This is not a firewall issue – the problem persists when the firewall is disabled.

    Details: The server’s IP address is 10.1.100.1. Bindings for the default web site have been set to:

    • http, *, 8080
    • http, 10.1.100.1, 8080

    The third party app is a .NET application (framework version 3.5) that resides in C:\Program Files\myApp\web. I believe that file permissions have been appropriately set.

    Using IE on the server, if I enter either

    the application launches and functions normally.

    When I try http://10.1.100.1:8080/myApp from another computer on the network, I get the following message:

    Unable to connect. Firefox can’t establish a connection to the server at 10.1.100.1:8080.

    Using WireShark, I did see communication between the machines – it is not a firewall problem.

    Based on various posts, I have tried:

    • Adding a line for port 8080 to c:\Windows\System32\drievrs\etc\services
    • Issuing the command: netsh http add urlacl url=http://10.1.100.1:8080/ user=everyone
    • Rebooting the computer

    What do you suggest that I try next. Thx!

    Saturday, February 4, 2017 5:17 AM

All replies

  • User-1315512054 posted

    Hello,

    You could check your server and IIS error logs for more clues.

    Regards

    Saturday, February 4, 2017 6:17 AM
  • User-2057865890 posted

    Hi Groston,

    For this issue, you could refer https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can.

    Best Regards,

    Chris

    Monday, February 6, 2017 5:38 AM
  • User-733680851 posted

    Based on the suggestions, I dug in further:

    • The logs did not provide useful information
    • The issue is not limited to Firefox

    Using WireShark, I did see communication between the server and an other machine. The other machine sends a ACK request and the server replies with a RST, ACK response. Based on my reading, this means that the port is closed. Note that this is not a firewall issue - I see the same behavior whether the firewall is active (a rule has been created) or not.

    When I run nmap on the other computer, it responds with:

    8080/tcp closed http-proxy.

    This confirms the above. However, when I run netstat –ab on the server, I see

    TCP 0.0.0.0:8080 <servername>:0  LISTENING  Can not obtain ownership info
    

    When I run netstat –an, I see

    TCP 0.0.0.0:8080 0.0.0.0:0  LISTENING
    

    Thus, the output of the netstat command seems to suggest that the port is open.

    What do you suggest that I try next. Thx!

    Wednesday, February 8, 2017 2:13 PM
  • User-2057865890 posted

    Hi Groston,

    Try flushing the DNS cache (IPCONFIG /FLUSHDNS) or adding the name to the hosts file on you machines.

    reference: http://stackoverflow.com/a/10105540

    Best Regards,

    Chris

    Friday, February 17, 2017 8:25 AM
  • User-733680851 posted

    Chris,

    Thanks for replying. The issue is not an inability to access the server, the issue is accessing the app on port 8080. Accessing the server via the port 80 app works fine, thus the issue is not DNS-related.

    Friday, February 17, 2017 2:34 PM