Export/Import not working for a Enterprise Wiki Site




    I have a requirement of migrating a Enterprise wiki site from one environment to another. When I tried to import the files i could see the files getting imported, but at the end, an error occured and operation did not complete successfully.

    I got the following error.

    [List] [Pages]   Error: A duplicate field name "f863c21f-5fdb-4a91-bb0c-5ae889190dd7" was found.

    FatalError: A duplicate field name "f863c21f-5fdb-4a91-bb0c-5ae889190dd7" was found.

    It looks like the GUID id pointing to Wiki_x0020_Page_x0020_CategoriesTaxHTField0.

    I tried both STSADM and PowerShell commands but same error I am getting. As per the MSDN documentation, I have the target site created with the same enterprise wiki template.

    When I tried with another fresh wiki site, it worked. I am sure the problem is with my customized wiki site but I am not able to find the cause.

    EDIT: Both source site and destination site are sub sites. Another interesting thing is, if the source site doesn't exist then the STSADM -O IMPORT works fine. But Import-SPWeb doesn't since it checks for the existence of the destination site.

    I also observed that this is a problem with Managed Metadata columns. If I remove managed metadata columns like Wiki Category from my destination site's content type, import process works fine again.

    Please help



    Arun D Gangadharan

    Friday, December 16, 2011 9:42 AM


  • had a similar problem, i found the field's name and got into it via browser


    then i just deleted it.
    Friday, November 29, 2013 10:00 AM