none
Problem with How do you want to open this website?

    Question

  • In Visual Studio 2015 community with update 3 when i click on Help or install for a Visual Studio Extension  I get How do you want to open this website? with OK grayed out. Use the default browser is highlighted. If I click on Use an app nothing happens (it is not highlighted and Use the default browser remains highlighted). If i click Always use this app to open msdn.microsoft,com the checkbox gets a check. 

    I am using Windows 10 with the Anniversary Update. I first noticed this after the Anniversary Update. 

    This entire How do you want to open this website? box stays on top of anything displayed (always on top). I cannot move it, delete it, or anything. A mouse right-click does nothing. The only way to get rid of it is to restart the computer. 

    Thursday, September 1, 2016 8:27 PM

Answers

  • Hi Ben,

    In our computer, there are two methods to set the default program. We could set the default program through Control Panel. Please refer to the following step:

    Open the Control->All Control Panel Item->Click default Programs->Set your default programs->Click Internet Explorer->Choose default for this program->Select All->Save

    Please refer to the following screenshots:

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.


    Friday, September 9, 2016 11:57 AM
    Moderator

All replies

  • Hi Mr Benjamin,

    According to your description, this issue may be caused by the default programs setting in your computer. You could refer to the following steps to set default application:

    Start->Settings->System->Default apps->Web browser set as Edge

    Then do your actions again to observe whether this issue occurs again.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Friday, September 2, 2016 6:05 AM
    Moderator
  • I have tried Edge, Google Chrome, Opera, and Firefox as the default browsers each  with the same results. I get the same results when I click on any thing on the Visual Studio Start Page except New Project, or anything in Recent projects list.
    Friday, September 2, 2016 2:57 PM
  • Hi Mr Benjamin,

    I updated my surface to the latest version and I have not encountered this issue.

    You could try to restore Visual Studio default settings and automatically launches the Visual Studio IDE (Devenv /ResetSettings).

    If this method does not work for you, I suggest you should repair your VS.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    • Marked as answer by Mr Benjamin Friday, September 2, 2016 7:24 PM
    • Unmarked as answer by qing__Moderator Monday, September 5, 2016 1:22 AM
    Friday, September 2, 2016 3:23 PM
    Moderator
  • Thank you. Devenv /ResetSettings did the trick. Help and other links on the Start Page now work fin..

    Friday, September 2, 2016 7:24 PM
  • It turns out that I was premature in declaring the problem solved. When I invoked Visual Studio with Devenv /ResetSettings the problem appeared to be solved. However, when I later brought Visual Studio up in Administrator mode, which I must do to access SQL an dataset, the problem was still there.

    If I bring Visual Studio up in normal mode it is fine, but in Administrator mode the problem persists. While this gives me a work around, this is a problem that should be fixed. I have been a Software Engineer long enough to expect it to disappear sometime in the future when Visual Studio or  some other application is updated in the future!

    To further isolate this problem, I have uninstalled and reinstalled Visual Studio which made no difference. It appears to be something inherent in Administrator mode causing the problem.

    Thanks for listening, Ben

    Sunday, September 4, 2016 12:36 PM
  • Hi Mr Benjamin,

    Thanks for your response.

    Has this issue appeared in other application? According to your description, this issue was appeared when you start VS in administrator mode now.

    Just like you said, this issue may be caused by some settings in administrator mode. So you could try the following step to further troubleshoot this issue:

    Please open an administrative CMD window and navigate to C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE and run devenv /resetsettings command again.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    • Proposed as answer by qing__Moderator Tuesday, September 6, 2016 7:35 AM
    • Unproposed as answer by qing__Moderator Wednesday, September 7, 2016 7:40 AM
    Monday, September 5, 2016 1:42 AM
    Moderator
  • Hi Mr Benjamin,

    Has your issue been solved? Please feel free to let me know your latest result.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Tuesday, September 6, 2016 8:24 AM
    Moderator
  • Oscar,

    I ran the ResetSettings command from an administrator CMD window using the path you suggested. Visual Studio came up and I selected the "New to Visual Studio? Check out ..." link and the "How do you want to open this website?" window came up. As usual, the window would not close and would not go away without a restart.

    I brought up Visual Studio in normal mode and clicking the same link brought up the website.

    I have not seen this "How do you ..." window in any other context except for Visual Studio in administrator mode. If you have a technique to bring it up in normal mode let me know and I will try it.

    Thanks, Ben

    Tuesday, September 6, 2016 10:27 AM
  • Hi Ben,

    After updating win10, Microsoft has made more changes in security. 

    Please do a setting in registry, the registry keys are found in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

    Enable FilterAdministratorToken, please refer to the following screenshot:

    Then restart the computer.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Wednesday, September 7, 2016 8:05 AM
    Moderator
  • Oscar,

    I added FilterAdimistratorToken to the location in the Registry you noted and set it to 1. I rechecked several times that it was correct. I restarted the computer. Unfortunately, it made no difference. 

    I am running Windows 10 Version 1607 for x64-based Systems. The update status is: Your device is up to date. Last checked: Today, ‏‎7:13 AM.

    Thanks for your information. 

    Ben

    Wednesday, September 7, 2016 11:27 AM
  • Hi Ben,

    If possible, please share us some screenshots about this issue, which could help me to further troubleshoot this issue.

    You could upload the screenshots to OneDrive and share a link here. Thank you very much.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Wednesday, September 7, 2016 12:55 PM
    Moderator
  • Oscar,

    Please see the screenshots in the following link:

    https://1drv.ms/w/s!ArHHMH_mpTvliWh5MwIDj9HcLdXB

    Ben

    Wednesday, September 7, 2016 4:54 PM
  • Hi Ben,

    Please following the following steps to troubleshot your issue:

    1). According to the above reply, you could set IE as a default browser in your machine. Because Visual Studio access the internet through IE by default. So refer to the following step to set IE as default browser:

    Start->Settings->System->Default apps->Web browser set as Internet Explorer

    2). Please check the permission of Administrator in iexplorer.exe. Right click the iexplorer.exe and choose Properties. Set as the following screenshot, and path of iexplorer.exe please refer to the following screenshot:

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Thursday, September 8, 2016 9:07 AM
    Moderator
  • Hi Ben,

    Because VS would call IE by default, please reset the IE and restart your computer.

    To reset the IE please refer to this step, click Tools->Internet options->choose Advanced tag-> Reset->enable Delete personal settings-> Reset-> then restart your computer.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Thursday, September 8, 2016 11:31 AM
    Moderator
  • Oscar,

    I set IE as default browser, reset it as you outlined, and tried Visual Studio in administrator mode again. Clicking the link resulted in the same problem. See screenshots in this link:

    https://1drv.ms/u/s!ArHHMH_mpTvliXLwO7pso4ESKGpH

    Thanks for your support.

    Ben

    Thursday, September 8, 2016 2:26 PM
  • Hi Ben,

    I am sorry that this issue is always exist after above steps. And according to your word file, the most likely solution is set the default browser. And in my side I could not to repro this issue, and my surface does not appear this issue after update Win10.

    This issue only appeared in Administrator mode, so I suggest you log in your computer in Administrator mode, then set the default browser as IE again.

    Please feel free to let me know you latest result.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Friday, September 9, 2016 11:42 AM
    Moderator
  • Hi Ben,

    In our computer, there are two methods to set the default program. We could set the default program through Control Panel. Please refer to the following step:

    Open the Control->All Control Panel Item->Click default Programs->Set your default programs->Click Internet Explorer->Choose default for this program->Select All->Save

    Please refer to the following screenshots:

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.


    Friday, September 9, 2016 11:57 AM
    Moderator
  • Oscar,

    We finally have the solution! As you suggested, I logged on as Administrator, set Internet Explorer as default, and clicked select all for permissions. While still logged on as administrator, I brought Visual Studio in normal mode and in Administrator mode, clicked on multiple links and they all worked. 

    I then logged off Administrator mode and logged on my normal account and repeated the same scenario. In both normal and Administrator mode each of these links works correctly. Internet Explorer is brought up even though another browser is set as the default.

    Thank you so much for your perseverance and technical expertise.

    Ben 

    Friday, September 9, 2016 4:36 PM
  • Hi Ben,

    Glad to know we have resolved this issue, please mark  my reply as answer, which could help others who have the same issue. Thank you very much.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Friday, September 9, 2016 5:56 PM
    Moderator
  • Hi, I have the same identical issue but only if I run devenv.exe as administrator ('cause otherwise I cannot edit directly websites hosted on IIS).

    The solution to remove the modal window is pressing escape on the keyboard. How to make it works I don't know.

    Thursday, February 16, 2017 10:56 AM