locked
TFS 2010 can't create a 'Schedule' build definition - object reference not set to an instance of an object RRS feed

  • Question

  • i'm having an unusual time (no pun intended) with creating a Scheduled Build in TFS2010.  Each time a create a new build definition (regardless of whether i base it from a clone of a working build definition create a new one from scratch) and set the trigger to

     

    Schedule - build every week in the following days

    ...when i attempt to save Visual Studio 2010 displays a stop error with:

     

    Team Foundation Error

    Object reference not set to an instance of an object

     

    like i said, I had no problem earlier when i created:

    • Manual
    • Gated
    • CI

     

    prior to applying TFS 2010 SP1 I did have a working Nightly but im trying to re-create it because at the time i did not check

    Build even if nothing has changed ....

    any ideas?  thanks in advance

     


    MickyD | http://mickyd.wordpress.com/ Help others by voting my post as 'Helpful' if you think it is so.
    Saturday, May 28, 2011 6:07 AM

Answers

  • hmmm how come alerts for forums dont work anymore??

    anyway, thanks for your reply john.  i found a workaround as follows

    • change client machine time zone from GMT +8 Perth to GMT+8 Taipei
    • edit build settings, however this time there is no error

     

    it seems that TFS, just like Vista, seems to think Perth has daylight savings which we dont.

    there is a related bug with TFS and Reporting Services that both must be installed with the timezone NOT set to GMT+8 Perth that is reported elsewhere


    MickyD | http://mickyd.wordpress.com/ Help others by voting my post as 'Helpful' if you think it is so.
    Friday, June 10, 2011 3:10 PM

All replies

  • how to reproduce

    1. clone an existing working build definition
    2. edit the clone, leave the name as it is
    3. on the trigger page, select schedule and check build even if nothing has changed
    4. click  save 
    5. "Object reference not set to an instance of an object"

    MickyD | http://mickyd.wordpress.com/ Help others by voting my post as 'Helpful' if you think it is so.
    Monday, May 30, 2011 2:20 AM
  • Hi Micky,

     

    Thanks for your post.

     

    I reproduced this scenario follow your steps on my machine(VS2010SP1, TFS2010SP1), and the cloned Build Definition can be edited and saved it completely.

     

    In order to resolve this issue I want to confirm some information with you:

    1        Try to reproduce this scenario on other clients.

    2        Try to reproduce this scenario on other TFS Server machine.

     

    Additionally, please clean the Cache manually:

    1.       Clean the Cache folder on client computer. The folder path is: C:\Users\username(Team Explorer user name)\AppData\Local\Microsoft\Team Foundation\3.0\Cache(os: Windows Server 2008 R2)

    2.      Clean the Cache folder on Server machine. The folder path is: C:\Users\username(Web access user name)\AppData\Local\Microsoft\Team Foundation\3.0\Cache(os: Windows Server 2008 R2)

    3.      After cleaned, on Server machine, click Start and select Run… to open the dialog box, then input iisreset.exe and click OK, wait it run completely.


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.


    Monday, May 30, 2011 8:44 AM
    Moderator
  • Hi Micky, 

     

    What about the progress for this issue? 


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, May 31, 2011 4:14 AM
    Moderator
  • hmmm how come alerts for forums dont work anymore??

    anyway, thanks for your reply john.  i found a workaround as follows

    • change client machine time zone from GMT +8 Perth to GMT+8 Taipei
    • edit build settings, however this time there is no error

     

    it seems that TFS, just like Vista, seems to think Perth has daylight savings which we dont.

    there is a related bug with TFS and Reporting Services that both must be installed with the timezone NOT set to GMT+8 Perth that is reported elsewhere


    MickyD | http://mickyd.wordpress.com/ Help others by voting my post as 'Helpful' if you think it is so.
    Friday, June 10, 2011 3:10 PM
  • Hi Micky

     

    Thanks for your reply.

     

    And thank you for sharing your experience here. It will be very beneficial for other community members having the similar questions.

     

    All your participation and support are very important to build such harmonious/ pleasant / learning environment for MSDN community.

     


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, June 13, 2011 2:33 AM
    Moderator
  • thanks john.  very pleasant post too :)

    i found out why my Social alerts weren't working too - somehow my e-mail was entered incorrect. doh!


    MickyD | http://mickyd.wordpress.com/ Help others by voting my post as 'Helpful' if you think it is so.
    Monday, June 13, 2011 3:44 AM
  • Hi Micky,

    Thanks for this; I was trying to work out why my builds would not run (when you click save, even though there is an error it saves the selected schedule!).

    However, another issue I have come across, which may help others:-

    If you have created a build, scheduled it and saved while in GMT +8 Perth, you will receive the above error and the schedule will save. If you then remove the schedule and save the build it will do so without an error. However, it will still remain in TFS Collection database (tbl_Schedule) with timezone of W.Australia Standard time. So when you try and schedule the build again (after following Micky's advice of changing your timezone) it does not update the timezone in the schedule, just the time - so you get an error again as it still thinks it is using W. Australia time.

    You can't even clone the build definition to get around this issue (as the disabled schedule is also cloned), you have to recreate the build definition and then schedule it with your new timezone.

    I assume you could delete the entries causing an issue in tbl_Schedule in the TFS database, but I assume this would not be a good thing in the eyes of Microsoft...

    Will


    Will BSc (Hons), ACS Certified Technologist MCTS, MCPD



    • Edited by WillFoster Wednesday, February 22, 2012 7:43 AM typo
    Tuesday, February 21, 2012 2:57 AM