none
question to the kiosk mode in WEC7 RRS feed

  • Question

  • Dear Community,

    I have some questions about kiosk mode today.
    I am working on a single board computer with Windows Embedded Compact 7.
    On this computer I assigned a username and a password. So I can log in via Telnet and FTP. Anonymous connections are prohibited. I also get a message about a locked device as soon as I connect it to the PC via USB. So far so good.
    Now I have connected a display. Also here I have a login screen after booting. 
    This results in the following problem for me at the moment.
    If I want to start my own application instead of the explorer (I have simply created a window application as an example, and stored it in the flash memory and changed it from Explorer to my app in the registry Launch50), I still get the login screen after booting. Only after entering the password, you can see the application. Is it possible to bypass this login screen somehow?

    Best regards

    Ralf

    Wednesday, October 2, 2019 7:29 AM

All replies

  • I am not sure of the exact steps because I haven't done anything with username/password, but I think what you need to do is replace the Explorer shell (a common suggestion in discussions of kiosk mode)

    Bruce Eitman
    Senior Enginer
    Bruce.Eitman AT Synopsys DOT com
    My BLOG http://geekswithblogs.net/bruceeitman
    I work for
    Synopsys

    Wednesday, October 2, 2019 2:00 PM
    Moderator
  • Hello, Bruce,
    Thank you for pointing that out.
    I have already replaced the Explorer with my own app, as I mentioned before.
    The login screen still appears.
    Wednesday, October 2, 2019 2:21 PM
  • That brings up two questions:

    1. What did you replace it with?  That is, are you sure that your replacement doesn't do the login screen?  (I think the answer is no, but you should confirm)

    2. Check the Launch keys to see what starts before Explorer.  Is there something there that could be the login screen?

    I no longer have PB or devices, so the best that I can do is ask questions and have you check things.


    Bruce Eitman
    Senior Enginer
    Bruce.Eitman AT Synopsys DOT com
    My BLOG http://geekswithblogs.net/bruceeitman
    I work for
    Synopsys

    Wednesday, October 2, 2019 2:37 PM
    Moderator
  • Hello Bruce, 

    here the answer to question 1.) i just created a win32 smart device project (windows application), saved and compiled it. and replaced the executable in the flash, with the explorer.exe (not seen in the screenshot)

    to question 2.)  the screenshot above shows, what is started before the explorer.exe. i will additionally ask the manufacturer of the board, what could influence the login screen.

    even if i remove all like this. still the loginscreen comes up.

    if it is important:

    the password i setup with a function taken from the ntlm (SetPassword). 


    Monday, October 7, 2019 5:56 AM
  • Hello,

    If I am not mistaking, it is GWES which is displaying the startui password window at boot. The best solution is to ask the BSP maker to help you.

    Please post here if you get a solution to this problem, I think a lot of people would be interested.


    Maxime T. Embedded System Engineer

    Tuesday, October 15, 2019 9:03 AM