Pivot Viewer for SSRS - How do I unblock the PS1 file? RRS feed

  • Question

  • I am trying to install the CTP of the PivotViewer for SSRS and am having some trouble trying to unblock the script file.  I watched the video here and tried to do the same thing but when I right-click on the file I do not see the security options that he sees and do not see where I can unblock the file.

    Please advise.

    Saturday, July 17, 2010 7:28 PM


All replies

  • Alternatives: 1. Copy the content of the file into a new ps1 script inside the directory. This way it's like the script has been created by you 2. Relax (temporary) the execution policy of ps1 scripts on the machine to unrestricted: see the original value with get-executionpolicy and use the set-executionpolicy cmdlet to relax it. Again, CTP2 will have this fixed, let me know if the above worked for you!
    Sunday, July 18, 2010 7:18 AM
  • I believe you might also be able to run PowerShell as Admin and then set the executionpolicy to remotesigned.  Once you do that you should be able to run it.  I had to do this before to run a ps1 file that was provided to me.


    Dan English's BI Blog
    • Marked as answer by Dan_Meyers Monday, July 19, 2010 12:24 AM
    Sunday, July 18, 2010 11:14 AM
  • Thanks.  I did not have to copy the contents into a new file.  I just ran set-executionpolicy remotesigned then it worked.  I did have to add '.\' before it would find the script even though I was in the same directory.  So to run the script I had to use this command;

    .\installBIPivot.ps1 "-whttp://localhost" -oi -y

    Thanks for the help.


    Monday, July 19, 2010 12:24 AM