locked
Issue with creating package through TFS Build RRS feed

  • Question

  • User-1739260477 posted

    HI

    I'm using TFS Build in deployment process.

    I need to generate package for which I have used  "/P:DeployOnBuild=true;DeployTarget=Package" as MSBuildArguments in build preocess template.

    The package is getting generated properly.

    I did Web Deploy Parameterization by adding Parameters.xml to the root of the project folder and I have added

    <parameter name="email" description="Email" defaultValue="test@ggg.com" tags="">
           <parameterEntry kind="XmlFile" scope="\\web.config$" match="/configuration/appSettings/add[@key='email']/@value" />
    </parameter>

    which should reflect in SetParameters.xml in the package as   

    <setParameter name="email" value="test@ggg.com" />

      but there is no entry as such in Setparameters.xml.

    When I publish the package every thing is working fine. i.e., I have an entry of <setParameter name="email" value="test@ggg.com" /> in Setparameters.xml. in publish folder.

    When I'm doing the same with TFS build it is not  working.

    I unzipped the package.zip (created by TFS build), I can see a parameters.xml file but it different from what I have defined in the project root folder.

    which has the following entries  

    <parameters>
        <parameter name="IIS Web Application Name" defaultValue="Default Web Site/WebAPI_deploy" tags="IisApp">
          <parameterEntry kind="ProviderPath" scope="IisApp" match="^C:\\Builds\\2\\{some path}\\obj\\x64\\Release\\Package\\PackageTmp$" />
          <parameterEntry kind="ProviderPath" scope="setAcl" match="^C:\\Builds\\2\\{some path}\\obj\\x64\\Release\\Package\\PackageTmp$" />
        </parameter>
        <parameter name="ConnectionString-Web.config Connection String" description="" defaultValue="{Connection string mentioned in Web.config}" tags="SqlConnectionString">
          <parameterEntry kind="XmlFile" scope="C:\\Builds\\2\{some path}\\obj\\x64\\Release\\Package\\PackageTmp\\Web\.config$"                  match="/configuration/connectionStrings/add[@name='PrimaryString']/@connectionString" />
       </parameter>
    </parameters>

    I guess this is the default parameters file which will be added if I dont add any Parameters.xml.

    Why is my parameters.xml not getting picked up through TFS build process.

    Thursday, April 10, 2014 5:27 AM

Answers

  • User-166373564 posted

    Hi Ravi

    Thanks for your feedback.

    I noticed that there is same post in Team Foundation Server - Build and release management forum, our TFS support engineer has given some suggestions, you could give a quick response.

    Best regards

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, April 15, 2014 10:32 PM

All replies

  • User-166373564 posted

    Hi Ravi

    Thanks for your feedback in asp.net forum.

    When I'm doing the same with TFS build it is not  working.

    For this issue, I think we should look into it first. Please refer to the procedure of using Web Deploy parameters in a web deployment package here, and check it on your side.

    In addition, I notice that similar TFS build questions are discussed in Team Foundation Server - Build and release management forum, I think you could also post this issue to it, you can get quick response there.

    Best regards

    Angie Xu

    Thursday, April 10, 2014 11:24 PM
  • User-1739260477 posted

    @Angie xu Thanks for your reply.

    I'm having issue only when I go through the TFS Build. Am I missing something like proper MSBuild arguments in the build process ??? I donno.....    

     

    Friday, April 11, 2014 12:59 AM
  • User-166373564 posted

    Hi Ravi

    Thanks for your feedback.

    I noticed that there is same post in Team Foundation Server - Build and release management forum, our TFS support engineer has given some suggestions, you could give a quick response.

    Best regards

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, April 15, 2014 10:32 PM