none
C# dot addin was not loaded when UAC enabled of windows 7 RRS feed

  • Question

  • Hi Sir,

                                     I have created shared Addin in C# .net for outlook and created installer using setup and deployment project in vs2008. On machines with UAC disabled, the installation worked fine,addin was loaded in outlook. However, if the machine had UAC enabled, the MSI appeared succesful, but addin was not loaded in outlook. I also had manually registered .net dll as follows when UAC was enabled -

    C:\Windows\Microsoft.NET\Framework\v2.0.50727/regasm.exe OutlookAddin.dll /register /codebase /tlb

    But it didn't worked.

    Please help.



    Suraj


    • Edited by Suraj Shaha Friday, January 18, 2013 7:06 AM
    Friday, January 18, 2013 7:06 AM

Answers

  • you have to determine what was not deployed. Check:

    1. are all files deployed to target location?

    2. are all registry keys created/updated?

    • Marked as answer by Suraj Shaha Friday, January 18, 2013 2:10 PM
    • Unmarked as answer by Suraj Shaha Friday, January 18, 2013 2:10 PM
    • Marked as answer by Suraj Shaha Friday, January 18, 2013 2:10 PM
    Friday, January 18, 2013 8:20 AM

All replies

  • you have to determine what was not deployed. Check:

    1. are all files deployed to target location?

    2. are all registry keys created/updated?

    • Marked as answer by Suraj Shaha Friday, January 18, 2013 2:10 PM
    • Unmarked as answer by Suraj Shaha Friday, January 18, 2013 2:10 PM
    • Marked as answer by Suraj Shaha Friday, January 18, 2013 2:10 PM
    Friday, January 18, 2013 8:20 AM
  • Hi DamianD,

    Thanks for the replay. I got the solution. I had created registry keys under local machine registry hive location instead of current user. 

    Regards

    Suraj


    Suraj

    Friday, January 18, 2013 2:10 PM