locked
Connect to Azure file share timed out on mac RRS feed

  • Question

  • Here is the article that I'm following to mount the azure file share to my mac:

    https://docs.microsoft.com/en-us/azure/storage/files/storage-how-to-use-files-mac

    I first disabled the SMB packet signing and then confirmed my mac's firewall was not on (so no port is blocked).

    Then I tried both the method - connect to server in Finder and use mount_smbfs in Terminal, either works. 

    Finder: There was a problem connecting to the server "dummy.file.core.windows.net"

    The server may not exist or it is unavailable at this time. Check the server name or IP address, check your network connection, and then try again.

    Terminal: mount_smbfs: server connection failed: Operation timed out

    I didn't get the chance to type in storage account and access key.

    Some other approaches I've tried:

    1. open port 445 on mac by following this post: https://gauravsohoni.wordpress.com/2015/04/14/mac-osx-open-port/.

    2. I have google wifi router, so I set up port forwarding for port 445.

    Neither worked.

    Can some expert please help with this issue?

    Thanks

    Sunday, November 11, 2018 10:12 PM

All replies

  • 1. May I know which version of MacOS are you using?

    2. Can you try to mount on Windows 10 on the same network (if possible)?

     

    Try to ping the dummy.file.core.windows.net and let me know the status.

    You may also install PowerShell and check the Port connection “TCPTestSucceeded”. Run the below mentioned command in PowerShell and Share me the outcome. PS P:\> Test-NetConnection -ComputerName dummy.file.core.windows.net -Port 445

     ComputerName     : t3fileshares.file.core.windows.net

    RemoteAddress    : 5*.2*9.***.*2

    RemotePort       : 445

    InterfaceAlias   : Ethernet 2

    SourceAddress    : 1*.16.2**.7*

    TcpTestSucceeded : True   Additional information:  Refer to the suggestions mentioned in the below article. https://social.msdn.microsoft.com/Forums/en-US/d8662247-37ee-44ef-9457-9a15a42c0464/mount-an-azure-file-storage-account-from-mac?forum=windowsazuredata

     

    Disclaimer: This response contains a reference to a third-party World Wide Web site. 

    Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites; therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. 

     

    Monday, November 12, 2018 4:01 PM
  • thanks for the reply.

    1. I have macOS High Sierra 10.13.6. I did try ping the ip of file share endpoint, but couldn't connect to it.

    2. I don't have windows system in my home network. But I do have windows 10 at work. I tried the command and this is the outcome:

    ComputerName           : xxxxxx.file.core.windows.net
    RemoteAddress          : 5x.1x1.xxx.x8
    RemotePort             : 445
    InterfaceAlias         : Ethernet
    SourceAddress          : 1x.31.1xx.5
    PingSucceeded          : False
    PingReplyDetails (RTT) : 0 ms
    TcpTestSucceeded       : False

    Seems like both my home network and work network cannot connect to the endpoint. I did try storage azure storage explorer on my mac. It works in that case.


    • Edited by FeiyuS Tuesday, November 13, 2018 10:51 PM
    Tuesday, November 13, 2018 8:10 PM
  • Can you check with your ISP provider at home network to unblock 445 and in office need to contact the network administrator?

    Refer to the section Port 445 is blocked in the below mentioned article.

    https://docs.microsoft.com/en-us/azure/storage/files/storage-troubleshoot-windows-file-connection-problems  

     
    Kindly let us know if the above helps or you need further assistance on this issue.

    • Proposed as answer by Alex Dud Friday, November 16, 2018 5:47 PM
    Wednesday, November 14, 2018 3:00 PM
  • As I mentioned in my last post, I did make it work with azure storage explorer in my home network, which suggests that port might not be a problem.

    The guide you pointed is also a troubleshooting guide for windows, which I cannot use directly. Please have something for mac. 

    Thursday, November 15, 2018 7:25 PM
  • I was able to access my file share at organization's network after contacting my IT team to enable port 445. 


    -ALEX D



    • Edited by Alex Dud Monday, November 19, 2018 4:49 AM Incorrect link
    Friday, November 16, 2018 5:46 PM
  • @FeiyuS Storage Explorer uses REST, not SMB, so it will be accessible anywhere you can use a browser with HTTP/HTTPS. If you cannot access the storage account on port 445 with a TCP test, you won't be able to mount either.

    For Mounting requires port 445 to be open to the internet.

    Thursday, November 29, 2018 3:43 PM