locked
Issues with EW3 FTP RRS feed

  • Question

  • I've just moved from a hosted shared server (1&1) to a virtual private server (Vario). I cannot get EW3 to connect to my new VPS no matter what I do. I can upload files using CuteFTP, but when I enter the exact same settings into EW3, it tells me that there is no directory with that name on the destination server and asks if I want to create one.

    Any suggestions?


    Thanks


    James Gotcher
    Thursday, August 26, 2010 5:52 PM

Answers

  • You have a folder named "www/mysite.com"?  (The ftp folder isn't "www"?)

    At any rate, if that's the case, the folder name in EW's publishing settings under Location Directory would not be /www/mysite.com .  It would be www/mysite.com without the leading slash.  Is that what you tried?

    And if that doesn't work, try "www".  (E.g., in a shared host system, while the physical locations of the various sites is certainly different, the same FTP destination is used (e.g. "www" or other), and the ftp login credentials point to the right site directory.) While I don't know how your server is set up, a ftp directory name including "mysite.com" in the path is rather unusual

    • Marked as answer by Ron Gotcher Monday, August 30, 2010 1:42 PM
    Sunday, August 29, 2010 5:27 PM
  • Connect to your root folde in EW without any folder name specified. Look at what folders show up. From there pick the next level and copy/paste that folder name into the publishing directory setting.

    Then reconnect and look again, then copy/paste the folder name. Repeat as needed but I'll bet you have an extra space or other typo in the folder path. I've seen it happen where it looks like you are typing things correctly and really aren't. PIA but it happens,

    Kathy, I have used hosting that has the full domain name including a period in the folder structure. It isn't common but it does happen.


    MS MVP Expression Tutorials & Help http://by-expression.com
    • Marked as answer by Ron Gotcher Monday, August 30, 2010 1:41 PM
    Sunday, August 29, 2010 6:37 PM

All replies

  • Change the ftp:// setting in Tools > Application Options > FTP tab.
    If passive is checked uncheck it, if unchecked check it.
    You may also have to change the setting in Internet Explorer > Tools > Application options > Advanced.
    Scroll about half way down the advanced listing.


    Expression Web MVP
    Thursday, August 26, 2010 7:33 PM
  • Thank you, that got me into the new site. The issue that I now have is that when I connect I now get the dialog box advising me that the site contains folders used by the ForntPage Server Extensions but that I am editing it via FTP or WebDAV, etc.

    I can publish my entire site to the new server, but I can't navigate beyond the second level. That is, I can go to the main page in a folder, but I can't navigate beyond that, to pages that are in sub folders.

    Any suggestions?


    Thaanks


    James Gotcher
    Thursday, August 26, 2010 8:58 PM
  • If the site has extensions installed, you need to either uninstall them and use ftp:// or repair them and use http:// publishing.

    When you say can't navigate, do you mean in EW folder view, or in a browser?


    Expression Web MVP
    Thursday, August 26, 2010 9:02 PM
  • The VPS does not have extensions installed,  nor will I be able to have them installed. How can I switch to http:// publishing? If I do, will it remove the need for FPSE?

    Also, when I speak of not being able to navigate, I mean through IE. When I click on links to "interior" pages, I get a file no found error.


    James Gotcher

    Friday, August 27, 2010 12:00 AM
  • As to the first, http publishing in this case refers to publishing with the FPSE, so if you can't install them, you'll need to use FTP. If you use FTP, you will need to disable/remove the FPSE, because publishing with FTP will break them.

    As to your navigation problem, that is because your links are broken. Check your online files and you will find that the hyperlinks that are pointing to your interior pages are not actually pointing to the relative path where they are located. If a Linux server, this could also be caused by a casing issue (Linux is case-sensitive, so gallery.htm and Gallery.htm are different files to Linux).

    cheers,
    scott


    C'mon, folks. This isn't rocket science, nor neurosurgery. It's "Expression" (singular) "Web" (singular), in that order, followed by a version numeral if you wish to be specific. It is often abbreviated "EW." It is not "Web Expression," "Expressions Web," "Web Expressions," or plain "Expression" or "Expressions." Not using the correct name indicates either ignorance or laziness. Most folks would rather avoid the appearance of either.
    Friday, August 27, 2010 12:09 AM
  • Thank you for your patience. I am using EW3 includes on almost all pages. Am I correct in assuming that if I give up FPSE I won't be able to use these? The VPS is a Linux server. Finally, how do I remove FPSE?


    Thanks


    James Gotcher
    Friday, August 27, 2010 9:23 PM
  • Thank you for your patience. I am using EW3 includes on almost all pages. Am I correct in assuming that if I give up FPSE I won't be able to use these? The VPS is a Linux server. Finally, how do I remove FPSE?


    Thanks


    James Gotcher

    Actually include pages do not use the extensions. Just make sure that EW is set to manage the site using hidden metadata, in site > Site settings > general tab.
    Metadata is how EW maintains the relationship between includes and the pages that use them.
    Plus some other functions.
    Expression Web MVP
    Friday, August 27, 2010 9:36 PM
  • EW includes are design side.  The are put into the page before you publish, and don't require anything on the server.  Try opening a page that has an EW include outside of EW, say in Notepad.  You'll see that all the included content is there.  EW hides it in Code View, which keeps you from trying to edit it in the using files rather than in the include file itself.
    Friday, August 27, 2010 10:43 PM
  • I checked my settings and found that the settings are as you described. They were set that way before I initiated this thread. What I don't understand is why I am getting  the dialog box advising me that the site contains folders used by the ForntPage Server Extensions but that I am editing it via FTP or WebDAV, etc.? Is that something that comes up in all instances, or because of the content of my web?


    Thanks


    James Gotcher
    Friday, August 27, 2010 11:49 PM
  • Do you have FPSE's installed on that site?  Did you ever edit the site with FrontPage?
    Saturday, August 28, 2010 12:09 AM
  • No and no. I've never used FrontPage for this site and I never had FPSE on the site where the software is located. I've solved all of the other problems, but the inability to publish through EW3 is driving me nuts. I can get in using an FTP client, but when I put those precise settings into EW3, I am unable to connect.
    James Gotcher
    Saturday, August 28, 2010 12:15 AM
  • What do you mean you can't get into your site?  Just ignore the warning.  Doesn't it connect?

    Also, I'm not sure what you mean by "I never had FPSE on the site where the software is located".  The question is: have you ever had FPSE's on the hosting account where you are trying to publish it?  When you look at the site using a third party FTP program, do you see _vti* folders on the remote site?

    Saturday, August 28, 2010 12:58 AM
  • No and no. I've never used FrontPage for this site and I never had FPSE on the site where the software is located. I've solved all of the other problems, but the inability to publish through EW3 is driving me nuts. I can get in using an FTP client, but when I put those precise settings into EW3, I am unable to connect.
    James Gotcher


    Did you ever use a 3rd party ftp:// program to publish the site, or did you ever drag and drop the root folder for your site from your computer to the server using windows explorer ftp:// ?
    If so, the hidden _vti folders have been published to the server, and that is why EW is giving you the warning.

    Browse to your copy of your site on your computer using windows explorer, and you will see the hidden _vti folders and files.


    Expression Web MVP
    Saturday, August 28, 2010 2:06 AM
  • Yes, I used WiseFTP to upload the files and I made sure to bring over the hidden files as a I thought they were necessary. Should I delete them from the remote site?

    I had to use WiseFTP because I can't connect to the remote site via EW3. That's the real problem for me.


    James Gotcher
    Saturday, August 28, 2010 2:40 AM
  • Use WiseFTP to remove the _vti folders. Those folders are used locally to maintain your site's meta data which is what allows EW to update links when you rename files or folders.

    The only time those should be on the server is if you FPSE to publish since then they will maintain syncronization information and contain the code required for the forms processors and navigation bots to function.

    By uploading them with WiseFTP you have confused Expression Web, making it think that the FPSE are in use. As a result you get the warning that bots will break if you use FTP to publish. Once you have removed those _vti folder (and if you see a post_info.htm file remove it as well) you should be able to publsh normally with Expression Web.

    (This forum is driving me batty, booted me out when I went to post this reply and it took 3 attempts to get logged back in.)


    MS MVP Expression Tutorials & Help http://by-expression.com
    Saturday, August 28, 2010 2:17 PM
  • Also remove the page _vti_inf.html - this describes the FPextensions version.


    Ron Symonds
    Microsoft MVP (Expression Web)

    www.rxs-enterprises.org/fp
    Saturday, August 28, 2010 2:28 PM
  • Thanks to everyone for the tips. Now all I have to do is solve the problem that is preventing me from using EW3's publish function to conntect to the remote site. I use the precise same settings in both WiseFTP and EW3. It works for WiseFTP, but EW3 tells me there is no directory with that name on the remote site and asks if I want it to create one. 


    James Gotcher
    Sunday, August 29, 2010 12:56 AM
  • Which directory?  The FTP directory in the publishing settings?  Or something else?  [And what happens if you say yes, go ahead and create it?]

    Sunday, August 29, 2010 2:50 AM
  • It is the destination directory on the remote server. It doesn't follow the path to the directory there that already exists and seem to want to create one.
    James Gotcher
    Sunday, August 29, 2010 3:40 AM
  • Again, what do you mean? (What destination?) The FTP directory in the publishing settings, or something else - any directory beneath that one in the site?

    And repeating my second question: what happens if you go ahead and let it try to create the directory?

    Sunday, August 29, 2010 5:06 AM
  • I suspect that OP may be opening his local web using a ligher level heirarchy and that is confusing the application. Let me try to explain the structure I suspect is being used:

    local website location: "~/My Documents/My Web/site"

    Expression Web opens "~/My Docuemtns/ My Webs" as the web root.

    FTP settings: ftp://site.tld & folder "public_html"

    In WiseFTP OP navigates to "~/My Documents/My Web/site" for the local site and "public_html" in the hosted site.

    In EW "~/My Documents/My Web/" is open for the local and when "public_html" for the remote. Attempting to publish the "site" folder makes EW want to create a folder named "site" in the "public_html" folder.

    I've had this senario show up inmy classes half a dozen times.


    MS MVP Expression Tutorials & Help http://by-expression.com
    Sunday, August 29, 2010 3:43 PM
  • When I go into my site visa the control panel and look at the files I have uploaded through FTP, the path shown there is:

    All Files / home / myname / www / mysite.com

    Here are the WiseFTP settings that work:

    Host name:  myname.securesites.net

    Initial folder: /www/mysite.com

    When I enter those same settings into EW3, I get a popup box that tells me that the directory does not exist on the remote server and asks if I want to create one. If I click yes, I then get a second popup box that informs me:

    No such file or directory (550)


    James Gotcher
    Sunday, August 29, 2010 5:19 PM
  • You have a folder named "www/mysite.com"?  (The ftp folder isn't "www"?)

    At any rate, if that's the case, the folder name in EW's publishing settings under Location Directory would not be /www/mysite.com .  It would be www/mysite.com without the leading slash.  Is that what you tried?

    And if that doesn't work, try "www".  (E.g., in a shared host system, while the physical locations of the various sites is certainly different, the same FTP destination is used (e.g. "www" or other), and the ftp login credentials point to the right site directory.) While I don't know how your server is set up, a ftp directory name including "mysite.com" in the path is rather unusual

    • Marked as answer by Ron Gotcher Monday, August 30, 2010 1:42 PM
    Sunday, August 29, 2010 5:27 PM
  • Connect to your root folde in EW without any folder name specified. Look at what folders show up. From there pick the next level and copy/paste that folder name into the publishing directory setting.

    Then reconnect and look again, then copy/paste the folder name. Repeat as needed but I'll bet you have an extra space or other typo in the folder path. I've seen it happen where it looks like you are typing things correctly and really aren't. PIA but it happens,

    Kathy, I have used hosting that has the full domain name including a period in the folder structure. It isn't common but it does happen.


    MS MVP Expression Tutorials & Help http://by-expression.com
    • Marked as answer by Ron Gotcher Monday, August 30, 2010 1:41 PM
    Sunday, August 29, 2010 6:37 PM
  • Thank you. Both of those techniques work. I deleted what I had previously uploaded using WiseFTP and then uploaded the enitre site via EW3. Another problem cropped up, however. When I now visit the site with IE, I can see my index.html page. When I click on a link there, it takes me to the main page in a subfolder. When I then click on a link on that page to go into a sub-sub-folder, I get a page not found error. The URL shows that the local path from my computer has been inserted. That is, it is trying t find the folder where the file is stored on my local computer. I tried running recalculate hyperlinks to no effect. If I go back and manually re-set the link on my computer, then upload it again, it works.
    James Gotcher
    Sunday, August 29, 2010 7:18 PM
  • Before anyone wastes their valuable time trying to figure out this last problem, I think I found the issue. I think that it was an error that I made in transferring the site to my computer. I did at global replace, removing the local directory, deleted the site on the remote server, reloaded it, and now everything works fine. I apologize if anyone wasted their time trying solve the problem.

    All of my issues are now solved. Thanks to everyone who helped me  with these problems.


    James Gotcher
    Sunday, August 29, 2010 8:50 PM
  • You should mark the post (or posts) that helped you as helpful or as the answers.  This helps others searching the forum for similar issues.
    Sunday, August 29, 2010 9:08 PM
  • I believe I marked all of the responses as helpful.
    James Gotcher
    Sunday, August 29, 2010 11:10 PM
  • Mark one or some of them as answers - the thread remains listed as unanswered otherwise.
    Monday, August 30, 2010 1:42 AM