none
Weird Window Focus problem RRS feed

  • General discussion

  • I'm having an issue with my application's windows being focused when they appear. It shows a weird little icon on one of the controls, and the window won't respond to the first click until you have clicked on the window. When you first click on the window the icon goes away and then it behaves normally. It does this for both the main application window and some other windows.

    Here's a portion of my window showing the icons: Just below the button.

    Everything was created using Blend 2 and VS 2008 on version 3.5 of the framework. Does it any computer the application is run on.

    Any help would be greatly appreciated.
    Beardo
    • Changed type Marco Zhou Monday, June 2, 2008 9:44 AM issue resolved by OP
    Monday, May 26, 2008 4:40 PM

All replies

  • Beardo,

     

    From the image, it looks like the TreeView is causing the problem.

     

    Try adding a top margin of 20 to the TreeView and see if those little icons follow down, I suspect they will.

     

    I've seen this strange behavior with ListBoxes too.  To get around it, I set the SelectedIndex property and the ListBox started working.  Play around with this.

     

    You may want to have a good look at how and when the TreeView is being populated.

     

    Hope this helps.

    Monday, May 26, 2008 7:07 PM
  • I'll play around with the populating and selection, but I don't think that's the problem. It happens on another window except the little boxes are over a toolbar, but it still has the same behavior, first click removes the boxes, next clicks act normally.

    Update:

    Just checked it, even removed the tree view, same behavior... Maybe I'll check just an empty window.
    Tuesday, May 27, 2008 4:47 AM
  • Please post a repro sample here, so that I can give further research on it.

    Thanks
    Thursday, May 29, 2008 7:28 AM
  • I would, except that I completely erased the toolbartray and the toolbars, then when I put them back on, the problem went away.

    If it happens again, I'll post it.
    Thursday, May 29, 2008 2:40 PM
  • I Commented this thread since your issue has been temporarily resolved.

    Thanks
    Monday, June 2, 2008 9:43 AM