locked
401 Unauthorized Error when Registering Workflow Manager RRS feed

  • Question

  • I have installed the workflow manager successfully. However, when I try to run Register-SPWorkflowService I get a 401 Unauthorized error. I am running SharePoint 2013 Management Shell as administrator.

    When I use internet explorer to browse to https://FQDNofServer:12290 I get prompted for my password 3 times and then get the Not Authorized Error here as well. I have tried this from the local host as well as remote machines with the same result therefore, I don't think I need to disable loopback check.

    My user is a member of the Workflow AdminGroup as well as a local admin, farm administrator and I also added my account as an administrator for the Workflow Service Application in Central Administration. I also tried giving the workflow service account full read on the web application.

    I cannot find anything in the ULS logs or windows event viewer logs when the login fails. Any help would be appreciated.

    Thank You.


    • Edited by Michael505 Wednesday, July 9, 2014 7:32 PM
    Wednesday, July 9, 2014 6:59 PM

Answers

  • I figured it out.

    I had to go into IIS, click on the Workflow Management Site. Then double click on Authorization Rules. I had to add Allow All users to the authorization rules. After that, I was able to register the site.

    By default this permissions is inherited from the IIS site. In my case this setting was changed for security reasons.

    • Marked as answer by Michael505 Wednesday, July 9, 2014 8:19 PM
    Wednesday, July 9, 2014 8:19 PM

All replies

  • I figured it out.

    I had to go into IIS, click on the Workflow Management Site. Then double click on Authorization Rules. I had to add Allow All users to the authorization rules. After that, I was able to register the site.

    By default this permissions is inherited from the IIS site. In my case this setting was changed for security reasons.

    • Marked as answer by Michael505 Wednesday, July 9, 2014 8:19 PM
    Wednesday, July 9, 2014 8:19 PM
  • Hi,

    Glad to hear that you solve this issue, thanks for your sharing.

    Thanks,

    Linda Li                

    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Linda Li
    TechNet Community Support

    Thursday, July 10, 2014 8:04 AM