locked
SignalR Windows iot + WebApi works fine in debug but not at all using a release package RRS feed

  • Question

  • User1128832889 posted

    Hi, 

    I hope you someone can help me here because I have no idea on what going on.

    I'm creating an iot app that is supposed to exchange data with a WebApi using SignalR. I have been doing it for a while in debug and had no problem releated to SignalR until I decided to create a proper release package. The app starts properly on my iot device (RbPi) but once a send a request to my WebApi server  it is not forwatded to the RbPi.

    I tried to look if the firewall was blocking any traffic so I add a rule to open every TCP port and in vain: (may I did it wrong)

    netsh advfirewall FIREWALL add rule name="Allow any In 2" dir=in localport=1-65535 protocol=TCP action=allow

    I also tried to monitor net traffic using the ETW of Windows iot ...nothing.

    I have now no idea on where to look now, hope you can help.

    David

    Sunday, March 13, 2016 9:16 PM

Answers

All replies