locked
The notification platform does not have the proper privileges to complete the request.

    Question

  • We have tried everything, but when we call:

    PushNotificationChannelManager.CreatePushNotificationChannelForApplicationAsync(); 

    We are always getting the error below:

    The notification platform does not have the proper privileges to complete the request. (Exception from HRESULT: 0x803E0208)

    Can this be related to the fact that our Identity.Name is "4ward" and it starts with a number?

    Wednesday, June 27, 2012 3:00 PM

All replies

  • That error shouldn't have anything to do with your Identity.Name. As its description states, it means that the app is running in a context that doesn't have sufficient privileges to create the channel.

    How are you running the app when you get this error? Do you get this when the app is run normally (from the start screen)?

    --Rob

    Thursday, June 28, 2012 4:08 AM
    Owner
  • You're right! We were testing from simulator... Running from Local Machine works great!
    Thursday, June 28, 2012 4:29 PM
  • I am having the same problem. Want to take screenshots of my app. but simulator has not the privileges.

    Please get me some other solution.


    http://winspark.net/ | Spark your Windows

    Tuesday, October 09, 2012 4:47 PM
  • Does anyone knows how to get around this issue?  I tried starting visual studio as "Administrator" but I get the same problem when running in Simulator. I need to take screenshots of my app for store submission. Appreciate your help in resolving this issue.
    Thursday, November 22, 2012 1:49 AM
  • I am having the same issue while working on the Contoso Cookbook RC labs.  I am able to run the application with push notification just fine in the local machine, I am unable to run it the Simulator. 

    "The notification platform does not have the proper privileges to complete the request. (Exception from HRESULT: 0x803E0208)"

    Thursday, November 29, 2012 4:38 AM
  • 'Running app in simulator and try to open push channel'

    It has been over 7 months now. Is there still no solution to this problem? Or this is normal behavior for the simulator?

    Monday, January 28, 2013 3:03 PM
  • This is expected behavior. The simulator  doesn't support push notifications.

    --Rob

     
    • Proposed as answer by TChiang Monday, January 28, 2013 6:48 PM
    Monday, January 28, 2013 4:03 PM
    Owner
  • Thanks Rob.
    Monday, January 28, 2013 6:48 PM